]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
improve system libXNVCtrl patch; actually apply it
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 8%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 9%bcond_without nacl # build Native Client support
ba685303 10%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
ba685303 15%bcond_without system_flac # system flac
4e881737 16%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 17%bcond_without system_harfbuzz # system harfbuzz
ba685303 18%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
19%bcond_without system_libexif # system libexif
20%bcond_without system_libmtp # system libmtp
ba685303
ER
21%bcond_without system_libusb # system libusb-1
22%bcond_without system_libwebp # system libwebp
4884fc99 23%bcond_without system_libxnvctrl # system libxnvctrl
126ea630 24%bcond_without system_minizip # system minizip
62950103 25%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 26%bcond_without system_protobuf # system protobuf
ba685303
ER
27%bcond_without system_speex # system speex
28%bcond_with system_sqlite # system sqlite
9bd2659c 29%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 30%bcond_with system_v8 # system v8
4b411ffe 31%bcond_without system_libvpx # system libvpx
ba685303 32%bcond_without system_yasm # system yasm
1c00315b 33%bcond_without system_zlib # system zlib
d2781a31 34%bcond_without tcmalloc # use tcmalloc
7e136323 35%bcond_without verbose # verbose build (V=1)
0c480b89 36
6d92f81c 37# TODO
f1b276d4 38# - check system sqlite linking problems
2108baf2 39# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 40# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 41# - use_system_hunspell
32a2443e 42# - use_system_stlport
a3140cd1 43# - other defaults: src/build/common.gypi
108c5f7c
ER
44# - system usb-ids stuff
45# - libpci: link, because xserver loads it anyway
a3140cd1 46
e53ecfb5 47# NOTES:
4fe038cb
ER
48# - mute BEEP mixer if you do not want to hear horrible system bell when
49# pressing home/end in url bar or more ^F search results on page.
7c638678 50# - space considerations:
4a263112 51# - unpacked sources: ~566MiB
c1ecd31f 52# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 53# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 54# - to look for new tarball, use update-source.sh script
f1b276d4 55
e68aa7e7 56# NOTE TO USERS:
c8b02491 57# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 58# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 59# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 60
a3140cd1 61%define gyp_rev 1014
11ad81c4 62Summary: A WebKit powered web browser
05f72ae2 63Name: chromium-browser
5fa8212f 64Version: 25.0.1364.29
d2781a31 65Release: 0.24
05f72ae2 66License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 67Group: X11/Applications/Networking
108c5f7c 68Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{version}.tar.gz
126ea630 69# Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
37ceaf05 70Source1: %{name}.default
8b53130d
ER
71Source2: %{name}.sh
72Source3: %{name}.desktop
56c6e811
ER
73Source5: find-lang.sh
74Source6: update-source.sh
75Source7: clean-source.sh
836b1cac 76Source8: get-source.sh
0562b864 77Source9: master_preferences.json
48b341f5 78Patch1: plugin-searchdirs.patch
70258ccd 79#Patch2: system-nspr.patch
7abc645c 80Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 81Patch4: path-libpdf.patch
0e5636cb 82Patch6: get-webkit_revision.patch
5aa5df39 83Patch7: dlopen_sonamed_gl.patch
4765ddf1 84Patch8: chromium_useragent.patch.in
c0808220 85Patch9: chromium-ppapi.patch
8456d676 86Patch10: system-libxnvctrl.patch
1347c76c
AM
87# https://bugs.gentoo.org/show_bug.cgi?id=393471
88# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 89Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c
ER
90Patch12: system-ffmpeg.patch
91Patch13: system-libpng.patch
92Patch14: system-opus.patch
5997e180
ER
93Patch15: nacl-build-irt.patch
94Patch16: nacl-linkingfix.patch
9516ca97 95Patch18: nacl-no-untar.patch
08b25440 96Patch19: system-jsoncpp.patch
8fb1dc98 97Patch23: no-pnacl.patch
6897926c 98Patch24: nacl-verbose.patch
c5b396f3
ER
99Patch25: gnome3-volume-control.patch
100Patch26: master-prefs-path.patch
d2781a31 101Patch27: tcmalloc-glibc2.16.patch
750b48f7 102URL: http://www.chromium.org/Home
ae3fe89f 103%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 104BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
105BuildRequires: alsa-lib-devel
106BuildRequires: atk-devel
107BuildRequires: bison
11ad81c4 108BuildRequires: bzip2-devel
5997e180
ER
109%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
110%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
111%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 112%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 113%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 114BuildRequires: dbus-glib-devel
6e3a5dc7 115BuildRequires: elfutils-devel
77f32fa3 116BuildRequires: expat-devel
7d0dbc8d 117%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 118%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 119BuildRequires: flex
11ad81c4 120BuildRequires: fontconfig-devel
f1b276d4 121BuildRequires: glib2-devel
05f72ae2 122BuildRequires: gperf
bbad64b7 123BuildRequires: gtest-devel
8b53130d 124BuildRequires: gtk+2-devel
01b4dc8e 125%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 126%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 127BuildRequires: hicolor-icon-theme
ed514974 128%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
8456d676 129%{?with_system_libxvnctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 130BuildRequires: libevent-devel
8456d676 131%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 132%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 133BuildRequires: libicu-devel >= 4.6
39c71b4c 134%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 135%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 136%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 137BuildRequires: libpng-devel
e266589e 138%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 139BuildRequires: libstdc++-devel
ba685303 140%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 141%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 142%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 143BuildRequires: libxml2-devel
11ad81c4 144BuildRequires: libxslt-devel
f1b276d4 145BuildRequires: lzma
62950103 146%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 147BuildRequires: nspr-devel
f1b276d4 148BuildRequires: nss-devel >= 1:3.12.3
8456d676 149%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 150BuildRequires: pam-devel
f1b276d4 151BuildRequires: pango-devel
48b341f5 152BuildRequires: perl-modules
153BuildRequires: pkgconfig
75a27c2e 154%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 155%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 156BuildRequires: python
46cdefee 157#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 158BuildRequires: python-modules
6e3a5dc7 159BuildRequires: python-ply
0cad051b 160BuildRequires: rpm >= 4.4.9-56
f1b276d4 161BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 162%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 163BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 164%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 165BuildRequires: subversion
0cad051b 166BuildRequires: tar >= 1:1.22
0a424ee2 167BuildRequires: udev-devel
2303ed45 168BuildRequires: util-linux
c14cd342 169%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 170BuildRequires: which
f1b276d4 171BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
172BuildRequires: xorg-lib-libXt-devel
173BuildRequires: xorg-lib-libXtst-devel
836b1cac 174BuildRequires: xz
a3140cd1 175%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 176%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 177Requires: browser-plugins >= 2.0
0cad051b 178Requires: desktop-file-utils
8f5f6775 179%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 180Requires: hicolor-icon-theme
c1edaafa 181%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 182%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
4dc49133 183Requires: xdg-utils >= 1.0.2-4
e53ecfb5 184Provides: wwwbrowser
c3582150 185Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 186Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 187ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 188BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 189
589d90ea 190%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 191
e7fa0817
ER
192# Usage: gyp_with BCOND_NAME [OPTION_NAME]
193%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 194
6b113615
ER
195%if %{without debuginfo}
196%define _enable_debug_packages 0
197%endif
198
11ad81c4 199%description
80838854
ER
200Chromium is an open-source browser project that aims to build a safer,
201faster, and more stable way for all Internet users to experience the
202web.
203
204Chromium serves as a base for Google Chrome, which is Chromium
205rebranded (name and logo) with very few additions such as usage
206tracking and an auto-updater system.
207
f1b276d4
ER
208%package l10n
209Summary: chromium-browser language packages
210Group: I18n
211Requires: %{name} = %{version}-%{release}
212
213%description l10n
214Chromium is an open-source browser project that aims to build a safer,
215faster, and more stable way for all Internet users to experience the
216web.
217
218This package contains language packages for 50 languages:
219
e7fa0817
ER
220ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
221he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
222pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
223zh-TW
f1b276d4
ER
224
225%prep
836b1cac 226%setup -q
589d90ea 227
05f72ae2
ER
228# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
229# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
230. ./src/chrome/VERSION
231ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
232test "$ver" = %{version}
233
234gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 235test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 236
836b1cac 237v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 238
4765ddf1
ER
239# add chromium and pld to useragent
240%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
241sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
242 -e 's/@BUILD_DIST_NAME@/PLD/g' \
243 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 244 < %{PATCH8} | %{__patch} -p1
4765ddf1 245
56c6e811
ER
246%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
247ln -s %{SOURCE7} src
f1b276d4 248
05f72ae2 249%patch1 -p1
7abc645c 250%patch3 -p1
72cb20c1 251%patch4 -p1
0e5636cb 252%patch6 -p1
5aa5df39 253%patch7 -p1
42e551c9 254%patch10 -p1
e9abb380 255%patch15 -p1
77f32fa3 256cd src
c0808220 257%patch9 -p0
70258ccd 258#%patch2 -p1
f4a8da6a 259%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c
ER
260%patch12 -p1
261%patch13 -p0
262%patch14 -p2
5997e180 263%patch16 -p1
08b25440 264%patch19 -p1
c5b396f3 265%patch25 -p1
d2781a31 266%patch27 -p1
1347c76c 267cd ..
9516ca97 268%patch18 -p1
8fb1dc98 269%patch23 -p1
6897926c 270%patch24 -p1
c5b396f3 271%patch26 -p1
0c480b89 272
828bdd1a 273cd src
e9abb380
ER
274
275# Missing gyp files in tarball.
276# https://code.google.com/p/chromium/issues/detail?id=144823
277if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
278 echo "tarball fixed, please remove workaround"
279 exit 1
280fi
281
282install -d chrome/test/data/nacl
283cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
284{
285 'targets': [
286 {
287 'target_name': 'nacl_tests',
288 'type': 'none',
289 },
290 ],
291}
292EOF
293
75a27c2e
ER
294sh -x clean-source.sh \
295 %{!?with_nacl:nacl=0} \
296 %{!?with_system_protobuf:protobuf=0} \
297 %{!?with_system_v8:v8=0} \
298 %{!?with_system_zlib:zlib=0} \
299 %{nil}
164020eb 300
e266589e 301%build
f1b276d4 302cd src
5997e180
ER
303
304%if %{with nacl}
108c5f7c 305rm -rf native_client/toolchain/linux_x86_newlib
fded59be 306if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 307# Make symlinks for NaCL
108c5f7c 308install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 309
108c5f7c
ER
310cd native_client/toolchain/linux_x86_newlib
311ln -s x86_64-nacl/bin bin
312cd x86_64-nacl/bin
2e4113fd 313__cc='%{__cc}'
f64e73f6 314if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
315 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
316 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
317 %{__sed} -i -e '1i#!/bin/sh' gcc g++
318 chmod +x gcc g++
319else
320 ln -s %{_bindir}/x86_64-nacl-gcc gcc
321 ln -s %{_bindir}/x86_64-nacl-g++ g++
322fi
108c5f7c
ER
323ln -s gcc x86_64-nacl-gcc
324ln -s g++ x86_64-nacl-g++
325ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
326ln -s %{_bindir}/x86_64-nacl-ar ar
327ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 328ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 329ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 330ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 331ln -s %{_bindir}/x86_64-nacl-strip strip
108c5f7c
ER
332ln -s %{_prefix}/x86_64-nacl/lib ../lib
333ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
334ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
335cd ../../../../..
fded59be 336fi
5997e180
ER
337%endif
338
c5b396f3 339test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
b4d75247
ER
340test -e Makefile || \
341 CC="%{__cc}" \
342 CXX="%{__cxx}" \
343 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
344 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
345 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
346%{__python} build/gyp_chromium \
673aee14
ER
347 --format=make \
348 -Goutput_dir=../out \
349 build/all.gyp \
f1b276d4
ER
350%ifarch %{ix86}
351 -Dtarget_arch=ia32 \
352%endif
353%ifarch %{x8664}
0c480b89
ER
354 -Dtarget_arch=x64 \
355%endif
7b454a31
AM
356%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
357 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
358%endif
359%if %{with sandboxing}
360 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
361 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
362%endif
363 %{!?debug:-Dwerror=} \
c980b122 364 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 365 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 366 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 367 -Dinclude_tests=0 \
c0808220 368%if %{with nacl}
038f76b9 369 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
370 -Ddisable_glibc_untar=1 \
371 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
372 -Ddisable_glibc=1 \
373 -Ddisable_pnacl=1 \
374 -Dbuild_pnacl_newlib=0 \
c0808220 375%else
8fb1dc98 376 -Ddisable_pnacl_untar=1 \
c0808220
ER
377 -Ddisable_nacl=1 \
378%endif
a3140cd1
ER
379 %{!?with_sse2:-Ddisable_sse2=1} \
380 %{?with_selinux:-Dselinux=1} \
e7fa0817 381 %{gyp_with cups} \
8dda6bbc 382 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
383 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
384 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
385 %{gyp_with pulseaudio} \
7d0dbc8d 386 %{gyp_with system_ffmpeg} \
8f5f6775 387 %{gyp_with system_flac} \
01b4dc8e 388 %{gyp_with system_harfbuzz} \
62950103
ER
389 %{gyp_with system_libexif} \
390 %{gyp_with system_libmtp} \
9bd2659c 391 %{gyp_with system_libsrtp} \
581aec44 392 %{gyp_with system_libusb} \
4b411ffe 393 %{gyp_with system_libvpx} \
ba685303 394 %{gyp_with system_libwebp} \
4884fc99 395 %{gyp_with system_libxnvctrl} \
126ea630 396 %{gyp_with system_minizip} \
62950103 397 %{gyp_with system_opus} \
75a27c2e 398 %{gyp_with system_protobuf} \
e7fa0817
ER
399 %{gyp_with system_speex} \
400 %{gyp_with system_sqlite} \
401 %{gyp_with system_v8} \
402 %{gyp_with system_yasm} \
403 %{gyp_with system_zlib} \
0c480b89 404 -Duse_system_bzip2=1 \
62950103 405 -Duse_system_expat=1 \
0b214002 406 -Duse_system_icu=1 \
f1b276d4 407 -Duse_system_libevent=1 \
0c480b89 408 -Duse_system_libjpeg=1 \
f1b276d4
ER
409 -Duse_system_libpng=1 \
410 -Duse_system_libxml=1 \
411 -Duse_system_libxslt=1 \
7f40f3f4 412 -Duse_system_xdg_utils=1 \
d8ba130c 413 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
414 -Dlinux_use_gold_binary=0 \
415 -Dlinux_use_gold_flags=0
11ad81c4 416
b4d75247 417# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 418%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
419 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
420 %{?with_verbose:V=1} \
f1b276d4
ER
421 CC.host="%{__cc}" \
422 CXX.host="%{__cxx}" \
b4d75247 423 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4
AM
424
425%install
426rm -rf $RPM_BUILD_ROOT
56c6e811 427install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 428 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 429
673aee14 430cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 431cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
432install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
433%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 434cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 435cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 436install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 437install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 438%if %{without system_ffmpeg}
f1b276d4 439install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 440%endif
e7fa0817 441cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 442cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 443
c0808220
ER
444%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
445
164020eb
ER
446%if %{with nacl}
447# Install Native Client files on platforms that support it.
448install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
449install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
450%ifarch %{x8664}
451install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
452%endif
453%ifarch %{ix86}
454install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
455%endif
456%endif
457
0c480b89
ER
458cd -
459
0eb19b0b
ER
460for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
461 size=${icon##*/product_logo_}
462 size=${size%.png}
463
464 # this will skip non-numeric (22_mono_invert, 22_mono)
465 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
466 test -d "$dir" || continue
467
468 install -d $RPM_BUILD_ROOT$dir
469 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
470done
7f40f3f4 471
13840bc2
AM
472%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
473# http://code.google.com/p/chromium/issues/detail?id=24507
474gecko-mediaplayer*.so
475EOF
11ad81c4 476
589d90ea
ER
477# find locales
478%find_lang %{name}.lang
e7fa0817 479# always package en-US
f1b276d4 480%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 481
11ad81c4
AM
482%clean
483rm -rf $RPM_BUILD_ROOT
484
f1b276d4 485%post
0eb19b0b 486%update_icon_cache hicolor
b7a6e4ee 487%update_desktop_database
f1b276d4
ER
488%update_browser_plugins
489
490%postun
491if [ "$1" = 0 ]; then
0eb19b0b 492 %update_icon_cache hicolor
f1b276d4
ER
493 %update_browser_plugins
494fi
495
1d2b9616 496%files
11ad81c4 497%defattr(644,root,root,755)
531537e5 498%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
499%{_browserpluginsconfdir}/browsers.d/%{name}.*
500%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
501%dir %{_sysconfdir}/%{name}
502%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 503%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
504%attr(755,root,root) %{_bindir}/%{name}
505%{_mandir}/man1/%{name}.1*
11ad81c4 506%{_desktopdir}/*.desktop
0eb19b0b 507%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 508%dir %{_libdir}/%{name}
e9abb380 509%{_libdir}/%{name}/chrome*.pak
c14cd342 510%{_libdir}/%{name}/content_resources.pak
97fac491 511%{_libdir}/%{name}/resources.pak
589d90ea 512%dir %{_libdir}/%{name}/locales
f1b276d4
ER
513%{_libdir}/%{name}/locales/en-US.pak
514%dir %{_libdir}/%{name}/resources
a3140cd1 515%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
516%dir %{_libdir}/%{name}/themes
517%dir %{_libdir}/%{name}/extensions
518%dir %{_libdir}/%{name}/plugins
519%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 520# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 521%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
522
523# ffmpeg libs
fcc48c19 524%if %{without system_ffmpeg}
f1b276d4 525%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 526%endif
f1b276d4 527
164020eb
ER
528%if %{with nacl}
529%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
530%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
531%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
532%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
533%endif
534
f1b276d4
ER
535%files l10n -f %{name}.lang
536%defattr(644,root,root,755)
This page took 0.781195 seconds and 4 git commands to generate.