]> git.pld-linux.org Git - packages/chromaprint.git/commitdiff
- new URLs, updated to 1.2 auto/th/chromaprint-1.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 15 Oct 2015 16:39:54 +0000 (18:39 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 15 Oct 2015 16:39:54 +0000 (18:39 +0200)
- removed obsolete ffmpeg patches

chromaprint-ffmpeg.patch [deleted file]
chromaprint-ffmpeg2.0.patch [deleted file]
chromaprint.spec

diff --git a/chromaprint-ffmpeg.patch b/chromaprint-ffmpeg.patch
deleted file mode 100644 (file)
index dc14601..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
---- chromaprint-0.7/src/ext/ffmpeg_decoder.h.orig      2012-09-05 20:05:36.000000000 +0200
-+++ chromaprint-0.7/src/ext/ffmpeg_decoder.h   2012-10-10 17:59:58.632685943 +0200
-@@ -80,7 +80,7 @@
-               avcodec_close(m_codec_ctx);
-       }
-       if (m_format_ctx) {
--              av_close_input_file(m_format_ctx);
-+              avformat_close_input(&m_format_ctx);
-       }
-       //av_audio_convert_free(m_convert_ctx);
-       av_free(m_buffer2);
-@@ -89,12 +89,12 @@
- inline bool Decoder::Open()
- {
--      if (av_open_input_file(&m_format_ctx, m_file_name.c_str(), NULL, 0, NULL) != 0) {
-+      if (avformat_open_input(&m_format_ctx, m_file_name.c_str(), NULL, NULL) != 0) {
-               m_error = "Couldn't open the file." + m_file_name;
-               return false;
-       }
--      if (av_find_stream_info(m_format_ctx) < 0) {
-+      if (avformat_find_stream_info(m_format_ctx, NULL) < 0) {
-               m_error = "Couldn't find stream information in the file.";
-               return false;
-       }
-@@ -129,11 +129,11 @@
-               return false;
-       }
--      if (m_codec_ctx->sample_fmt != SAMPLE_FMT_S16) {
-+      if (m_codec_ctx->sample_fmt != AV_SAMPLE_FMT_S16) {
-               m_error = "Unsupported sample format.\n";
-               return false;
-       }
--      /*m_convert_ctx = av_audio_convert_alloc(SAMPLE_FMT_S16, 1,
-+      /*m_convert_ctx = av_audio_convert_alloc(AV_SAMPLE_FMT_S16, 1,
-                                              m_codec_ctx->sample_fmt, 1,
-                                                                                  NULL, 0);
-       if (!m_convert_ctx) {
diff --git a/chromaprint-ffmpeg2.0.patch b/chromaprint-ffmpeg2.0.patch
deleted file mode 100644 (file)
index 7125cd8..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
---- chromaprint-0.7/examples/fpcalc.c.0000     2012-09-06 02:05:36.000000000 +0800
-+++ chromaprint-0.7/examples/fpcalc.c  2013-07-11 12:46:13.408154060 +0800
-@@ -13,7 +13,7 @@
- #define MAX(a, b) ((a) > (b) ? (a) : (b))
- #define MIN(a, b) ((a) < (b) ? (a) : (b))
--#define BUFFER_SIZE (AVCODEC_MAX_AUDIO_FRAME_SIZE * 2)
-+#define BUFFER_SIZE (192000 * 2)
- #if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(52, 94, 1)
- #define AV_SAMPLE_FMT_S16 SAMPLE_FMT_S16
-@@ -65,7 +65,10 @@
-               goto done;
-       }
--      if (avcodec_open(codec_ctx, codec) < 0) {
-+      /* request regular signed 16-bit packed format */
-+      codec_ctx->request_sample_fmt = AV_SAMPLE_FMT_S16;
-+
-+      if (avcodec_open2(codec_ctx, codec, NULL) < 0) {
-               fprintf(stderr, "ERROR: couldn't open the codec\n");
-               goto done;
-       }
-@@ -146,6 +149,7 @@
-                               int ostride[6] = { 2 };
-                               int len = buffer_size / istride[0];
-                               if (av_audio_convert(convert_ctx, obuf, ostride, ibuf, istride, len) < 0) {
-+                                      fprintf(stderr, "WARNING: unable to convert %d samples\n", buffer_size);
-                                       break;
-                               }
-                               buffer = buffer2;
---- chromaprint-0.7/src/ext/ffmpeg_decoder.h~  2013-08-29 17:59:01.185761084 +0200
-+++ chromaprint-0.7/src/ext/ffmpeg_decoder.h   2013-08-29 18:01:51.129329962 +0200
-@@ -28,6 +28,10 @@
- }
- #include "audio_consumer.h"
-+#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
-+#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000
-+#endif
-+
- class Decoder
- {
- public:
---- chromaprint-0.7/src/ext/ffmpeg_decoder.h~  2013-08-29 18:01:51.129329962 +0200
-+++ chromaprint-0.7/src/ext/ffmpeg_decoder.h   2013-08-29 18:06:34.402639744 +0200
-@@ -128,7 +128,7 @@
-               return false;
-       }
--      if (avcodec_open(m_codec_ctx, codec) < 0) {
-+      if (avcodec_open2(m_codec_ctx, codec, NULL) < 0) {
-               m_error = "Couldn't open the codec.";
-               return false;
-       }
index 6810a2803a6a393e52d817b1d0cfd134a5feca66..c27bd1520d9436c6b33eb35aba0f7f46fed357f2 100644 (file)
@@ -1,18 +1,16 @@
 Summary:       Library implementing the AcoustID fingerprinting
 Summary(pl.UTF-8):     Biblioteka implementująca odciski AcoustID
 Name:          chromaprint
-Version:       0.7
-Release:       6
+Version:       1.2
+Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       https://github.com/downloads/lalinsky/chromaprint/%{name}-%{version}.tar.gz
-# Source0-md5: 3005fc2c69b9ef4a5c6787ef9355a855
-Patch0:                %{name}-ffmpeg.patch
-Patch1:                %{name}-ffmpeg2.0.patch
-URL:           http://www.acoustid.org/chromaprint/
+Source0:       https://bitbucket.org/acoustid/chromaprint/downloads/%{name}-%{version}.tar.gz
+# Source0-md5: 748da044a8f0ee5f31edec8b67045b3e
+URL:           https://acoustid.org/chromaprint
 BuildRequires: boost-devel
 BuildRequires: cmake >= 2.6
-BuildRequires: ffmpeg-devel
+BuildRequires: ffmpeg-devel >= 0.6
 BuildRequires: libstdc++-devel
 BuildRequires: taglib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -74,12 +72,10 @@ tworzenia aplikacji wykorzystujących bibliotekę libchromaprint.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
 
 %build
 %cmake . \
-       -DBUILD_TOOLS=ON \
+       -DBUILD_EXAMPLES=ON \
        -DWITH_AVFFT=ON
 
 %{__make}
@@ -89,9 +85,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# omitted by make install
-install -D tools/fpcollect $RPM_BUILD_ROOT%{_bindir}/fpcollect
-
 %clean
 rm  -rf $RPM_BUILD_ROOT
 
@@ -100,8 +93,8 @@ rm  -rf $RPM_BUILD_ROOT
 
 %files -n libchromaprint
 %defattr(644,root,root,755)
-%doc CHANGES.txt NEWS.txt README.txt
-%attr(755,root,root) %{_bindir}/fpcollect
+%doc NEWS.txt README.md
+%attr(755,root,root) %{_bindir}/fpcalc
 %attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.0
 
This page took 0.141533 seconds and 4 git commands to generate.