]> git.pld-linux.org Git - packages/chntpw.git/blob - chntpw.spec
patch Makefile for our optflags
[packages/chntpw.git] / chntpw.spec
1 %define         reldate 100627
2 Summary:        NT SAM password recovery utility
3 Summary(pl.UTF-8):      Narzędzie do odtwarzania haseł NT SAM
4 Name:           chntpw
5 # Version is taken from HISTORY.txt
6 Version:        0.99.6
7 Release:        1
8 Epoch:          1
9 License:        GPL v2 (ntchpw), LGPL (ntreg)
10 Group:          Applications/System
11 Source0:        http://pogostick.net/~pnh/ntpasswd/%{name}-source-%{reldate}.zip
12 # Source0-md5:  8b046c2073f27eed728e18635ba72dd4
13 Patch0:         %{name}-debian.patch
14 URL:            http://pogostick.net/~pnh/ntpasswd/
15 BuildRequires:  rpmbuild(macros) >= 1.553
16 Source2:        %{name}-README.Dist
17 # Patches from Jim Meyering to improve robustness of the code.
18 Patch5:         %{name}-080526-correct-test-for-failing-open-syscall.patch
19 Patch6:         %{name}-080526-detect-failure-to-write-key.patch
20 Patch7:         %{name}-080526-reged-no-deref-null.patch
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  unzip
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 chntpw is NT SAM password recovery utility. This little program
27 provides a way to view information and change user passwords in a
28 Windows NT/2000 userdatabase file. Old passwords need not be known
29 since they are overwritten. In addition it also contains a simple
30 registry editor (same size data writes) and an hex-editor which
31 enables you to fiddle around with bits and bytes in the file as you
32 wish. If you want GNU/Linux bootdisks for offline password recovery
33 you can add this utility to custom image disks or use those provided
34 at the tools homepage.
35
36 %description -l pl.UTF-8
37 chntpw to narzędzie do odtwarzania haseł NT SAM. Ten mały program
38 dostarcza sposób na oglądanie informacji i zmianę haseł użytkowników w
39 pliku bazy użytkowników Windows NT/2000. Nie trzeba znać starych
40 haseł, ponieważ zostaną one nadpisane. Ponadto pakiet zawiera prosty
41 edytor rejestru (zapis danych o tym samym rozmiarze) i edytor
42 szesnastkowy pozwalający na modyfikowanie bitów i bajtów w dowolnym
43 pliku. Jeśli chcemy mieć bootkietkę z Linuksem do odtwarzania haseł,
44 możemy dodać to narzędzie do własnych obrazów lub użyć obrazów ze
45 strony domowej.
46
47 %prep
48 %setup -q -n %{name}-%{reldate}
49 %patch0 -p1
50 %patch5 -p1
51 %patch6 -p1
52 %patch7 -p1
53
54 cp -p %{SOURCE2} README.Dist
55
56 %undos WinReg.txt
57
58 ver=$(awk '/%{reldate}/{print $3}' HISTORY.txt)
59 if [ "$ver" != %{version} ]; then
60         : plz correct version to $ver
61         exit 1
62 fi
63
64 %build
65 %{__make} chntpw cpnt reged \
66         CC="%{__cc}" \
67         CFLAGS="%{rpmcflags} -DUSEOPENSSL -Wall"
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man8}
72 install -p chntpw cpnt reged $RPM_BUILD_ROOT%{_bindir}
73 cp -a chntpw.8 $RPM_BUILD_ROOT%{_mandir}/man8/chntpw.8
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc README.txt regedit.txt WinReg.txt HISTORY.txt
81 %doc README.Dist
82 %attr(755,root,root) %{_bindir}/chntpw
83 %attr(755,root,root) %{_bindir}/cpnt
84 %attr(755,root,root) %{_bindir}/reged
85 %{_mandir}/man8/chntpw.8*
This page took 0.05491 seconds and 3 git commands to generate.