]> git.pld-linux.org Git - packages/chkconfig.git/commitdiff
- updated to 1.25 auto/th/chkconfig-1.25-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 7 Oct 2023 19:07:46 +0000 (21:07 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 7 Oct 2023 19:07:46 +0000 (21:07 +0200)
chkconfig-noxinet.patch
chkconfig-optflags.patch
chkconfig-pl.patch
chkconfig-split-usr.patch [new file with mode: 0644]
chkconfig.spec

index 83d58ed4f2b6828d16c34a0cfaa6b79d1fe232ef..9be6af2bf7d0f2b28fc02015bf9f81dde855a35f 100644 (file)
@@ -18,9 +18,8 @@ diff -urNpa chkconfig-1.15.orig/chkconfig.8 chkconfig-1.15/chkconfig.8
  .SH OPTIONS
  .TP
  \fB-\-level \fIlevels\fR
-diff -urNpa chkconfig-1.15.orig/chkconfig.c chkconfig-1.15/chkconfig.c
---- chkconfig-1.15.orig/chkconfig.c    2021-05-03 16:44:13.175185842 +0200
-+++ chkconfig-1.15/chkconfig.c 2021-05-03 17:27:19.517139905 +0200
+--- chkconfig-1.25/chkconfig.c.orig    2023-10-07 20:29:44.542142680 +0200
++++ chkconfig-1.25/chkconfig.c 2023-10-07 20:30:56.375086861 +0200
 @@ -117,8 +117,6 @@ static int delService(char *name, int ty
          readServiceError(rc, name);
          return 1;
@@ -70,7 +69,7 @@ diff -urNpa chkconfig-1.15.orig/chkconfig.c chkconfig-1.15/chkconfig.c
          return forgiving ? 0 : 1;
      }
  
-@@ -485,31 +473,10 @@ static int showServiceInfoByName(char *n
+@@ -485,20 +473,6 @@ static int showServiceInfoByName(char *n
      return showServiceInfo(s, forgiving);
  }
  
@@ -89,23 +88,13 @@ diff -urNpa chkconfig-1.15.orig/chkconfig.c chkconfig-1.15/chkconfig.c
 -}
 -
  static int serviceNameCmp(const void *a, const void *b) {
-     return strcmp(*(char **)a, *(char **)b);
- }
--static int xinetdNameCmp(const void *a, const void *b) {
--    const struct service *first = a;
--    const struct service *second = b;
--
--    return strcmp(first->name, second->name);
--}
--
- static int listService(char *item, int type) {
-     DIR *dir;
-     struct dirent *ent;
-@@ -539,55 +506,6 @@ static int listService(char *item, int t
+     const struct service *first = a;
+     const struct service *second = b;
+@@ -534,56 +508,6 @@ static int listService(char *item, int t
+             }
          }
      }
+-
 -    if (isXinetdEnabled() && type & TYPE_XINETD) {
 -        struct service *s, *t;
 -
@@ -145,7 +134,7 @@ diff -urNpa chkconfig-1.15.orig/chkconfig.c chkconfig-1.15/chkconfig.c
 -                numServices++;
 -        }
 -
--        qsort(s, numServices, sizeof(*s), xinetdNameCmp);
+-        qsort(s, numServices, sizeof(*s), serviceNameCmp);
 -        t = s;
 -        for (i = 0; i < numServices; i++, s++) {
 -            char *tmp = malloc(strlen(s->name) + 5);
@@ -158,7 +147,7 @@ diff -urNpa chkconfig-1.15.orig/chkconfig.c chkconfig-1.15/chkconfig.c
      return 0;
  }
  
-@@ -650,11 +568,6 @@ int setService(char *name, int type, int
+@@ -646,11 +570,6 @@ int setService(char *name, int type, int
          reloadSystemd();
  
          return rc;
@@ -170,7 +159,7 @@ diff -urNpa chkconfig-1.15.orig/chkconfig.c chkconfig-1.15/chkconfig.c
      }
  
      return 0;
-@@ -662,8 +575,6 @@ int setService(char *name, int type, int
+@@ -658,8 +577,6 @@ int setService(char *name, int type, int
  
  void forwardSystemd(const char *name, int type, const char *verb) {
      int socket = 0;
@@ -179,7 +168,7 @@ diff -urNpa chkconfig-1.15.orig/chkconfig.c chkconfig-1.15/chkconfig.c
  
      if (!systemdIsInit())
          return;
-@@ -747,12 +658,10 @@ int main(int argc, const char **argv) {
+@@ -743,12 +660,10 @@ int main(int argc, const char **argv) {
          usage(progname);
  
      if (typeString) {
@@ -194,7 +183,7 @@ diff -urNpa chkconfig-1.15.orig/chkconfig.c chkconfig-1.15/chkconfig.c
              exit(1);
          }
      }
-@@ -877,16 +786,9 @@ int main(int argc, const char **argv) {
+@@ -873,16 +788,9 @@ int main(int argc, const char **argv) {
              rc = readServiceInfo(name, type, &s, 0);
              if (rc)
                  return 1;
index 57511dfcfbc6850c36bfa0cb398e946a2dae1937..54de890ab03ef4e5cf3edeeb7438a6c7a7f5a51c 100644 (file)
@@ -1,8 +1,7 @@
-diff -urNpa chkconfig-1.15.orig/Makefile chkconfig-1.15/Makefile
---- chkconfig-1.15.orig/Makefile       2021-01-21 09:19:06.000000000 +0100
-+++ chkconfig-1.15/Makefile    2021-05-04 10:44:37.807341418 +0200
+--- chkconfig-1.25/Makefile.orig       2023-10-07 20:31:30.358236092 +0200
++++ chkconfig-1.25/Makefile    2023-10-07 20:32:21.871290355 +0200
 @@ -2,8 +2,8 @@ VERSION := $(shell awk '/Version:/ { pri
- NEXT_VERSION := $(shell awk '/Version:/ { print $$2 + 0.01 }' chkconfig.spec)
+ NEXT_VERSION := $(shell sed -nr 's/Version:[ ]*([0-9]*)\.([0-9]*)/echo "\1\.$$((\2+1))"/gep' chkconfig.spec)
  TAG = $(VERSION)
  
 -CFLAGS = -g -Wall $(RPM_OPT_FLAGS) -D_GNU_SOURCE
index fd1f0b1585d2a34aee3a2672fdcdc0e20ecaec4d..ad9884d8ffbe6c37f7341b1ff6b9a2e0527a65e9 100644 (file)
@@ -1,17 +1,16 @@
-diff -urNpa chkconfig-1.15.orig/po/pl.po chkconfig-1.15/po/pl.po
---- chkconfig-1.15.orig/po/pl.po       2021-01-21 09:19:06.000000000 +0100
-+++ chkconfig-1.15/po/pl.po    2021-05-04 10:47:45.426341418 +0200
+--- chkconfig-1.25/po/pl.po.orig       2023-10-07 20:34:00.827420930 +0200
++++ chkconfig-1.25/po/pl.po    2023-10-07 21:02:01.268317201 +0200
 @@ -131,11 +131,11 @@ msgstr "Brak wystarczających uprawnień
  
- #: ../chkconfig.c:457 ../chkconfig.c:462 ../chkconfig.c:587
+ #: ../chkconfig.c:457 ../chkconfig.c:462 ../chkconfig.c:583
  msgid "on"
 -msgstr "włączone"
 +msgstr "wł"
  
- #: ../chkconfig.c:457 ../chkconfig.c:462 ../chkconfig.c:587
+ #: ../chkconfig.c:457 ../chkconfig.c:462 ../chkconfig.c:583
  msgid "off"
 -msgstr "wyłączone"
 +msgstr "wył"
  
- #: ../chkconfig.c:547
+ #: ../chkconfig.c:543
  #, c-format
diff --git a/chkconfig-split-usr.patch b/chkconfig-split-usr.patch
new file mode 100644 (file)
index 0000000..b4fb5cd
--- /dev/null
@@ -0,0 +1,11 @@
+--- chkconfig-1.25/Makefile.orig       2023-10-07 21:02:30.061494548 +0200
++++ chkconfig-1.25/Makefile    2023-10-07 21:06:10.476967121 +0200
+@@ -59,7 +59,7 @@ install:
+       [ -d $(DESTDIR)/$(ALTDATADIR) ] || mkdir -p -m 755 $(DESTDIR)/$(ALTDATADIR)
+       [ -d $(DESTDIR)/$(SYSTEMDUTILDIR) ] || mkdir -p -m 755 $(DESTDIR)/$(SYSTEMDUTILDIR)
+-      install -m 755 $(PROG) $(DESTDIR)/$(SBINDIR)/$(PROG)
++      install -m 755 $(PROG) $(DESTDIR)/$(BINDIR)/$(PROG)
+       ln -s ../../..$(SBINDIR)/$(PROG) $(DESTDIR)/$(SYSTEMDUTILDIR)/systemd-sysv-install
+       install -m 755 ntsysv $(DESTDIR)/$(SBINDIR)/ntsysv
index c54cc83fb0af07f028283d862c3494a061517edb..daef8af916f9607ed83f15484bf6317594006db3 100644 (file)
@@ -9,26 +9,26 @@ Summary(ru.UTF-8):    Системная утилита для управления
 Summary(tr.UTF-8):     Sistem servis bilgilerini sorgular ve yeniler
 Summary(uk.UTF-8):     Системна утиліта для керування ієрархією /etc/rc.d
 Name:          chkconfig
-Version:       1.15
+Version:       1.25
 Release:       1
 Epoch:         2
 License:       GPL v2
 Group:         Applications/System
-Source0:       https://github.com/fedora-sysv/chkconfig/archive/refs/tags/%{version}.tar.gz
-# Source0-md5: 36c438a0fa5d95125dbe1093aa2b904c
+#Source0Download: https://github.com/fedora-sysv/chkconfig/releases
+Source0:       https://github.com/fedora-sysv/chkconfig/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 12a7b241ba7d3730b9dc389115be50ee
 Patch0:                %{name}-add.patch
 Patch1:                %{name}-noxinet.patch
 Patch2:                %{name}-rc.d.patch
 Patch3:                %{name}-optflags.patch
 Patch4:                %{name}-pl.patch
+Patch5:                %{name}-split-usr.patch
 URL:           https://github.com/fedora-sysv/chkconfig
 BuildRequires: gettext-tools
 BuildRequires: libselinux-devel
 BuildRequires: newt-devel
 BuildRequires: popt-devel
 Requires:      rc-scripts
-# sr@Latn vs. sr@latin
-Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -160,6 +160,7 @@ Perla; ma być zamiennikiem skryptu update-alternatives z Debiana.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__make} \
This page took 0.113854 seconds and 4 git commands to generate.