]> git.pld-linux.org Git - packages/chkconfig.git/commitdiff
- argh, fixed broken add patch
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 18 Feb 2003 22:35:46 +0000 (22:35 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- cleanups, added pl.po-update patch
- removed Prereq: popt - shouldn't be necessary now (rpm has been fixed)
- release 2

Changed files:
    chkconfig-add.patch -> 1.5
    chkconfig-pl.po-update.patch -> 1.1
    chkconfig.spec -> 1.47

chkconfig-add.patch
chkconfig-pl.po-update.patch [new file with mode: 0644]
chkconfig.spec

index 32f3a90b04ce918f20323f09e704d2a5116fc3ae..330177fb11b6b9017da4cdb9e4af96c14b4d65c9 100644 (file)
@@ -22,6 +22,15 @@ diff -Nru chkconfig-1.2.24h.orig/chkconfig.c chkconfig-1.2.24h/chkconfig.c
      }
  
      return 0;
+@@ -275,7 +274,7 @@
+ int main(int argc, char ** argv) {
+-    int listItem = 0, addItem = 0, delItem = 0;
++    int listItem = 0, delItem = 0;
+     int rc, i, x;
+     char * levels = NULL;
+     int help=0, version=0;
 diff -Nru chkconfig-1.2.24h.orig/leveldb.c chkconfig-1.2.24h/leveldb.c
 --- chkconfig-1.2.24h.orig/leveldb.c   Fri Apr 19 03:15:55 2002
 +++ chkconfig-1.2.24h/leveldb.c        Wed Jan 22 12:04:47 2003
diff --git a/chkconfig-pl.po-update.patch b/chkconfig-pl.po-update.patch
new file mode 100644 (file)
index 0000000..0563f4e
--- /dev/null
@@ -0,0 +1,216 @@
+--- chkconfig-1.2.24h/po/pl.po.orig    Sun Jul 28 10:53:20 2002
++++ chkconfig-1.2.24h/po/pl.po Tue Feb 18 23:18:14 2003
+@@ -1,11 +1,12 @@
+ # t³umaczenie dla lpl.
+ # Copyright (C) 2000 Free Software Foundation, Inc.
+ # Pawe³ Niewiadomski <lilo@free.poltronic.net>, 2000.
++# Jakub Bogusz <qboosh@pld.org.pl>, 2003.
+ #
+ msgid ""
+ msgstr ""
+ "Project-Id-Version: chkconfig\n"
+-"POT-Creation-Date: 2002-07-28 01:50-0700\n"
++"POT-Creation-Date: 2003-02-18 23:12+0100\n"
+ "PO-Revision-Date: 2000-07-03 00:00+CEST\n"
+ "Last-Translator: Pawe³ Niewiadomski <lilo@free.poltronic.net>\n"
+ "Language-Team: POLISH <pl@li.org>\n"
+@@ -13,151 +14,136 @@
+ "Content-Type: text/plain; charset=ISO-8859-2\n"
+ "Content-Transfer-Encoding: 8-bit\n"
+-#: chkconfig.c:41
++#: chkconfig.c:42
+ #, c-format
+ msgid "%s version %s - Copyright (C) 1997-2000 Red Hat, Inc.\n"
+-msgstr ""
++msgstr "%s wersja %s - Copyright (C) 1997-2000 Red Hat, Inc.\n"
+-#: chkconfig.c:42
++#: chkconfig.c:43
+ msgid ""
+ "This may be freely redistributed under the terms of the GNU Public License.\n"
+ msgstr ""
+ "Program mo¿e byæ swobodnie rozprowadzany na warunkach Publicznej Licencji "
+ "GNU.\n"
+-#: chkconfig.c:45
++#: chkconfig.c:46
+ #, c-format
+ msgid "usage:   %s --list [name]\n"
+-msgstr "u¿ycie:  %s --list [nazwa]\n"
++msgstr "sk³adnia: %s --list [nazwa]\n"
+-#: chkconfig.c:46
++#: chkconfig.c:47
+ #, c-format
+ msgid "         %s --add <name>\n"
+-msgstr "         %s --add <nazwa>\n"
++msgstr "          %s --add <nazwa>\n"
+-#: chkconfig.c:47
++#: chkconfig.c:48
+ #, c-format
+ msgid "         %s --del <name>\n"
+-msgstr "         %s --del <nazwa>\n"
++msgstr "          %s --del <nazwa>\n"
+-#: chkconfig.c:48
+-#, fuzzy, c-format
++#: chkconfig.c:49
++#, c-format
+ msgid "         %s [--level <levels>] <name> %s\n"
+-msgstr "         %s [--level <poziomy>] <nazwa> %s)\n"
++msgstr "          %s [--level <poziomy>] <nazwa> %s\n"
+-#: chkconfig.c:55
++#: chkconfig.c:56
+ #, c-format
+ msgid "service %s does not support chkconfig\n"
+ msgstr "us³uga %s nie wspiera chkconfig\n"
+-#: chkconfig.c:57
++#: chkconfig.c:58
+ #, c-format
+ msgid "error reading information on service %s: %s\n"
+ msgstr "b³±d podczas czytania informacji o us³udze %s: %s\n"
+-#: chkconfig.c:122 chkconfig.c:127 chkconfig.c:227
++#: chkconfig.c:119
+ msgid "on"
+-msgstr "***"
++msgstr "w³"
+-#: chkconfig.c:122 chkconfig.c:127 chkconfig.c:227
++#: chkconfig.c:119
+ msgid "off"
+-msgstr "---"
++msgstr "wy³"
+-#: chkconfig.c:159
+-#, fuzzy, c-format
++#: chkconfig.c:136
++#, c-format
+ msgid "failed to open %s: %s\n"
+-msgstr "nie mog³em otworzyæ %s/init.d: %s\n"
++msgstr "nie uda³o siê otworzyæ %s: %s\n"
+-#: chkconfig.c:196
+-#, fuzzy, c-format
++#: chkconfig.c:173
++#, c-format
+ msgid "error reading from directory %s: %s"
+-msgstr "b³±d podczas czytania z katalogu %s/init.d: %s\n"
+-
+-#: chkconfig.c:204
+-msgid "xinetd based services:\n"
+-msgstr ""
++msgstr "b³±d podczas czytania z katalogu %s: %s"
+-#: chkconfig.c:206
+-#, fuzzy, c-format
+-msgid "failed to open directory %s: %s"
+-msgstr "nie mog³em otworzyæ %s/init.d: %s\n"
+-
+-#: chkconfig.c:370
++#: chkconfig.c:310
+ #, c-format
+ msgid "%s version %s\n"
+ msgstr "%s wersja %s\n"
+-#: chkconfig.c:377
++#: chkconfig.c:317
+ msgid "only one of --list, --add, or --del may be specified\n"
+ msgstr "tylko jedna z opcji --list, --add, lub --del mo¿e byæ podana\n"
+-#: chkconfig.c:432
++#: chkconfig.c:372
+ msgid "only one runlevel may be specified for a chkconfig query\n"
+ msgstr "tylko jeden poziom pracy mo¿e byæ podany dla zapytania chkconfig\n"
+ #: ntsysv.c:54
+ msgid "Press <F1> for more information on a service."
+-msgstr "Naci¶nij <F1> aby dowiedzieæ siê wiêcej o us³udze."
++msgstr "Naci¶niêcie <F1> pozwoli dowiedzieæ siê wiêcej o us³udze."
+-#: ntsysv.c:87 ntsysv.c:124
++#: ntsysv.c:81 ntsysv.c:118
+ msgid "Ok"
+-msgstr ""
++msgstr "Ok"
+-#: ntsysv.c:87
++#: ntsysv.c:81
+ msgid "Back"
+ msgstr "Cofnij"
+-#: ntsysv.c:87
++#: ntsysv.c:81
+ msgid "Cancel"
+ msgstr "Anuluj"
+-#: ntsysv.c:99
++#: ntsysv.c:93
+ msgid "What services should be automatically started?"
+ msgstr "Które z us³ug powinny byæ automatycznie uruchamiane?"
+-#: ntsysv.c:105
++#: ntsysv.c:99
+ msgid "Services"
+ msgstr "Us³ugi"
+-#: ntsysv.c:199 ntsysv.c:243
++#: ntsysv.c:189
+ #, c-format
+ msgid "error reading info for service %s: %s\n"
+ msgstr "b³±d podczas odczytywania informacji o %s: %s\n"
+-#: ntsysv.c:208 ntsysv.c:252
+-#, fuzzy, c-format
++#: ntsysv.c:198
++#, c-format
+ msgid "error reading from directory %s: %s\n"
+-msgstr "b³±d podczas czytania z katalogu %s/init.d: %s\n"
++msgstr "b³±d podczas czytania z katalogu %s: %s\n"
+-#: ntsysv.c:310
++#: ntsysv.c:257
+ #, c-format
+ msgid "You must be root to run %s.\n"
+-msgstr ""
++msgstr "Trzeba byæ rootem, aby uruchomiæ %s.\n"
+-#: ntsysv.c:358
++#: ntsysv.c:305
+ msgid "bad argument to --levels\n"
+ msgstr "nieprawid³owy argument dla --levels\n"
+-#: ntsysv.c:365
++#: ntsysv.c:312
+ msgid "No services may be managed by ntsysv!\n"
+ msgstr "Brak us³ug, którymi ntsysv móg³by zarz±dzaæ!\n"
+-#: leveldb.c:384
++#: leveldb.c:324
+ #, c-format
+ msgid "failed to glob pattern %s: %s\n"
+-msgstr "nie mog³em dopasowaæ do wzoru %s: %s\n"
++msgstr "nie uda³o siê dopasowaæ do wzoru %s: %s\n"
+-#: leveldb.c:415
++#: leveldb.c:355
+ msgid "cannot determine current run level\n"
+-msgstr "nie mogê ustaliæ aktualnego poziomu pracy\n"
++msgstr "nie mo¿na ustaliæ aktualnego poziomu pracy\n"
+-#: leveldb.c:503
++#: leveldb.c:389
+ #, c-format
+ msgid "failed to make symlink %s: %s\n"
+-msgstr "nie powiod³a siê próba stworzenia symlinka %s: %s\n"
+-
+-#~ msgid "error reading from directory %s/init.d: %s"
+-#~ msgstr "b³±d poczas czytania z katalogu %s/init.d: %s"
+-
+-#~ msgid "error reading from directory %s/init.d: %s\n"
+-#~ msgstr "b³±d podczas czytania z katalogu %s/init.d: %s\n"
++msgstr "nie uda³o siê utworzyæ dowi±zania symbolicznego %s: %s\n"
index d940d28d77754ff6f59cb95fd7b4e78ff17ee119..1cf6bdb4059d8a1ba5041b417c8821c7dcd954b0 100644 (file)
@@ -9,7 +9,7 @@ Summary(tr):    Sistem servis bilgilerini sorgular ve yeniler
 Summary(uk):   óÉÓÔÅÍÎÁ ÕÔÉ̦ÔÁ ÄÌÑ ËÅÒÕ×ÁÎÎÑ ¦¤ÒÁÒȦ¤À /etc/rc.d
 Name:          chkconfig
 Version:       1.2.24h
-Release:       1
+Release:       2
 Epoch:         1
 License:       GPL
 Group:         Applications/System
@@ -17,11 +17,11 @@ Group:              Applications/System
 Source0:       http://www.buttsoft.com/~thumper/downloads/%{name}/%{name}-%{version}.tar.gz
 Patch0:                %{name}-add.patch
 Patch1:                %{name}-noxinet.patch
+Patch2:                %{name}-pl.po-update.patch
 BuildRequires: gettext-devel
 BuildRequires: newt-devel
 BuildRequires: popt-devel
 BuildRequires: slang-devel
-Prereq:                popt
 Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -118,27 +118,19 @@ ntsysv - 
 %setup  -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %configure2_13 \
        --with-max-level=6
 %{__make}
 
-#%ifarch sparc
-#LIBMHACK=-lm
-#%endif
-
-#%{__make} \
-#      OPTIMIZE="%{rpmcflags}" \
-#      LDFLAGS="%{rpmldflags}" \
-#      LIBMHACK="$LIBMHACK"
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/{etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,sbin}
 
 %{__make} install \
-    DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT
 
 mv $RPM_BUILD_ROOT%{_sbindir}/chkconfig $RPM_BUILD_ROOT/sbin
 
This page took 0.084744 seconds and 4 git commands to generate.