]> git.pld-linux.org Git - packages/cherokee.git/commitdiff
- Version: 0.99.48 auto/th/cherokee-0_99_48-1
authorJacek Konieczny <jajcus@pld-linux.org>
Sat, 1 May 2010 09:10:36 +0000 (09:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- pack compiled python modules

Changed files:
    cherokee-methods.patch -> 1.2
    cherokee.spec -> 1.34

cherokee-methods.patch [deleted file]
cherokee.spec

diff --git a/cherokee-methods.patch b/cherokee-methods.patch
deleted file mode 100644 (file)
index aaca31f..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
---- cherokee-0.99.44/cherokee/header.c.orig    2010-03-20 14:48:22.000000000 +0100
-+++ cherokee-0.99.44/cherokee/header.c 2010-04-09 11:01:11.000000000 +0200
-@@ -320,16 +320,28 @@
-               detect_method (line, "TRACE", trace)
-               break;
-       case 'C':
-+              detect_method (line, "CHECKIN", checkin)
-+              else
-+              detect_method (line, "CHECKOUT", checkout)
-+              else
-               detect_method (line, "CONNECT", connect)
-               else
-               detect_method (line, "COPY", copy)
-               break;
-       case 'L':
-+              detect_method (line, "LABEL", label)
-+              break;
-               detect_method (line, "LOCK", lock)
-               break;
-       case 'M':
-+              detect_method (line, "MERGE", merge)
-+              else
-+              detect_method (line, "MKACTIVITY", mkactivity)
-+              else
-               detect_method (line, "MKCOL", mkcol)
-               else
-+              detect_method (line, "MKWORKSPACE", mkworkspace)
-+              else
-               detect_method (line, "MOVE", move)
-               break;
-       case 'N':
-@@ -341,6 +353,10 @@
-               detect_method (line, "SUBSCRIBE", subscribe)
-               break;
-       case 'U':
-+              detect_method (line, "UPDATE", update)
-+              else
-+              detect_method (line, "UNCHECKOUT", uncheckout)
-+              else
-               detect_method (line, "UNLOCK", unlock)
-               else
-               detect_method (line, "UNSUBSCRIBE", unsubscribe)
-@@ -348,6 +364,15 @@
-       case 'R':
-               detect_method (line, "REPORT", report)
-               break;
-+      case 'V':
-+              detect_method (line, "VERSION_CONTROL", version_control)
-+              break;
-+      case 'B':
-+              detect_method (line, "BASELINE_CONTROL", baseline_control)
-+              break;
-+      case 'I':
-+              detect_method (line, "INVALID", invalid)
-+              break;
-       }
-       return ret_error;
---- cherokee-0.99.44/cherokee/http.h.orig      2010-03-20 14:41:49.000000000 +0100
-+++ cherokee-0.99.44/cherokee/http.h   2010-04-09 11:14:38.000000000 +0200
-@@ -44,7 +44,7 @@
- typedef enum {
-       http_unknown      = 0LL,
--      http_all_methods  = 0xFFFFFFFLL,
-+      http_all_methods  = 0x1FFFFFFFFLL,
-       http_get              = 1,
-       http_post             = 1LL << 1,
index f473645ce6046c1d8a3ca3399bafdfe845f52f6b..8288619681b47d63487a701c2b804a8cb37ac965 100644 (file)
@@ -2,6 +2,7 @@
 # TODO:
 #   - think about moving modules to subpackages. At least, those with extra
 #     dependencies.
+#   - maybe there is no need to pack *.py (are *.pyc enough?)
 #
 # Conditional build:
 %bcond_without geoip           # without GeoIP support
 Summary:       Fast, Flexible and Lightweight Web server
 Summary(pl.UTF-8):     Cherokee - serwer WWW
 Name:          cherokee
-Version:       0.99.44
-Release:       3
+Version:       0.99.48
+Release:       1
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       http://www.cherokee-project.com/download/0.99/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 268e7130c12b441523de963f95b9b85d
+# Source0-md5: 16f3769e99919648c82383281588ccb0
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Patch0:                %{name}-config.patch
 Patch1:                %{name}-php-path.patch
 Patch2:                %{name}-panic_path.patch
-Patch3:                %{name}-methods.patch
 URL:           http://www.cherokee-project.com/
 %{?with_geoip:BuildRequires:   GeoIP-devel}
 BuildRequires: autoconf
@@ -120,7 +120,6 @@ Biblioteki serwera WWW Cherokee.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %build
 %{__libtoolize}
@@ -165,9 +164,14 @@ mv $RPM_BUILD_ROOT%{_docdir}/%{name} html
 # provided via %doc
 rm $RPM_BUILD_ROOT/etc/cherokee/cherokee.conf.perf_sample
 
+# compile python modules, otherwise *.pyc may get generated on runtime
+# and stay after package removal
+%py_comp $RPM_BUILD_ROOT%{_datadir}/cherokee/admin/
+
 mv $RPM_BUILD_ROOT%{_localedir}/{sv_SE,sv}
 %find_lang %{name}
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -302,7 +306,19 @@ fi
 %{_datadir}/cherokee/admin/performance.conf.sample
 %{_datadir}/cherokee/admin/*.html
 %attr(755,root,root) %{_datadir}/cherokee/admin/*.py
+%{_datadir}/cherokee/admin/*.pyc
 %{_datadir}/cherokee/admin/static
+%dir %{_datadir}/cherokee/admin/CTK
+%dir %{_datadir}/cherokee/admin/CTK/CTK
+%{_datadir}/cherokee/admin/CTK/CTK/*.py
+%{_datadir}/cherokee/admin/CTK/CTK/*.pyc
+%{_datadir}/cherokee/admin/CTK/static
+%dir %{_datadir}/cherokee/admin/plugins
+%{_datadir}/cherokee/admin/plugins/*.py
+%{_datadir}/cherokee/admin/plugins/*.pyc
+%dir %{_datadir}/cherokee/admin/wizards
+%{_datadir}/cherokee/admin/wizards/*.py
+%{_datadir}/cherokee/admin/wizards/*.pyc
 
 %files libs
 %defattr(644,root,root,755)
This page took 0.272063 seconds and 4 git commands to generate.