]> git.pld-linux.org Git - packages/cherokee.git/blob - cherokee.spec
- updated to 0.4.29
[packages/cherokee.git] / cherokee.spec
1 %bcond_with     php             # adds PHP support
2 %bcond_with     mono    # adds ASPX support
3 %bcond_with     gnomevfs        # compile the gnomevfs handler (broken)
4 %bcond_without  gnutls  # build with tls=gnutls
5 %bcond_with     openssl # build with tls=openssl
6 #
7 %if %{with gnutls} || %{with openssl}
8 %define with_tls 1
9 %endif
10 Summary:        Fast, Flexible and Lightweight Web server
11 Summary(pl):    Cherokee - serwer WWW
12 Name:           cherokee
13 Version:        0.4.29
14 Release:        0.4
15 License:        GPL v2
16 Group:          Networking/Daemons
17 Source0:        http://www.0x50.org/download/0.4/0.4.29/%{name}-%{version}.tar.gz
18 # Source0-md5:  854e6e61a69781746496012658d8ef98
19 Source1:        %{name}.init
20 Source2:        %{name}.sysconfig
21 URL:            http://www.0x50.org/
22 BuildRequires:  fcgi-devel
23 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
24 %{?with_gnutls:BuildRequires:   gnutls-devel >= 0.9.99}
25 %{?with_openssl:BuildRequires:  openssl-devel}
26 BuildRequires:  pam-devel
27 BuildRequires:  pcre-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  zlib-devel
30 Requires(post): /sbin/ldconfig
31 Provides:       webserver
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _sysconfdir     /etc/cherokee
35 %define         _wwwhome        /home/services/%{name}
36 %define         _wwwroot        %{_wwwhome}/html
37
38 %description
39 Cherokee is a flexible, very fast, lightweight Web server. It is
40 implemented entirely in C, and has no dependencies beyond a standard C
41 library. It is embeddable and extensible wi th plug-ins. It supports
42 on-the-fly configuration by reading files or strings, TLS/SSL (via
43 GNUTLS or OpenSSL), virtual hosts, authentication, cache friendly
44 features, PHP, custom error management, and much more.
45
46 %description -l pl
47 Cherokee to serwer WWW:
48 - SZYBKI i ma³y
49 - mo¿liwy do wbudowania
50 - rozszerzalny przy pomocy wtyczek
51 - z mo¿liwo¶ci± przypisania sposobu obs³ugi do ¶cie¿ek
52 - z obs³ug± serwerów wirtualnych
53 - z obs³ug± FastCGI
54 - z obs³ug± kodowania, w tym GZipa
55 - z obs³ug± loggerów, w tym NCSA
56 - z dynamiczn± lub statyczn± kompilacj± wtyczek
57 - z obs³ug± strumieni
58 - wykonuj±cy popularne zadania: praca jako demon, obs³uga typów MIME,
59   logowanie poprzez sysloga, po³±czenia keep-alive, dzia³anie w
60   ¶rodowisku chrootowanym
61 - o przejrzystym kodzie ;-)
62 - bêd±cy oprogramowaniem wolnodostêpnym.
63
64 %package devel
65 Summary:        Header files for Cherokee web server
66 Summary(pl):    Pliki nag³ówkowe dla serwera WWW Cherokee
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}
69
70 %description devel
71 Header files for Cherokee web server.
72
73 %description devel -l pl
74 Pliki nag³ówkowe dla serwera WWW Cherokee.
75
76 %prep
77 %setup -q
78
79 %build
80 %configure \
81         --sysconfdir=/etc \
82         --with-wwwroot=%{_wwwroot} \
83         --disable-static \
84         %{?with_gnomevfs:--enable-gnomevfs} \
85         %{?with_tls:--enable-tls=%{?with_gnutls:gnutls}%{?with_openssl:openssl}} \
86         --enable-pthreads \
87         %{?with_php:--with-php=DIR} \
88         %{?with_mono:--with-mono=DIR}
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
100 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
101
102 # modules dlopened by *.so
103 rm -f $RPM_BUILD_ROOT%{_libdir}/cherokee/lib*.la
104
105 # unify manual dir
106 rm -rf html
107 mv $RPM_BUILD_ROOT%{_docdir}/%{name} html
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 /sbin/ldconfig
114 /sbin/chkconfig --add %{name}
115 %service %{name} restart "Cherokee webserver"
116
117 %preun
118 if [ "$1" = "0" ]; then
119         %service %{name} stop
120         /sbin/chkconfig --del %{name}
121 fi
122
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS ChangeLog TODO html
128 %dir %{_sysconfdir}
129 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cherokee.conf
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icons.conf
131 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/advanced.conf
132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mime.conf
133 %dir %{_sysconfdir}/mods-available
134 %dir %{_sysconfdir}/mods-enabled
135 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mods-available/admin
136 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mods-available/ssl
137 %dir %{_sysconfdir}/sites-available
138 %dir %{_sysconfdir}/sites-enabled
139 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites-available/default
140 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites-available/example.com
141 %attr(750,root,root) %dir %{_sysconfdir}/ssl
142
143 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cherokee
144 %attr(754,root,root) /etc/rc.d/init.d/cherokee
145
146 %attr(755,root,root) %{_bindir}/cget
147 %attr(755,root,root) %{_bindir}/cherokee-panic
148 %attr(755,root,root) %{_bindir}/cherokee_logrotate
149 %attr(755,root,root) %{_sbindir}/cherokee
150
151 %dir %{_libdir}/cherokee
152 %attr(755,root,root) %{_libdir}/cherokee/libplugin_cgi.so
153 %attr(755,root,root) %{_libdir}/cherokee/libplugin_combined.so
154 %attr(755,root,root) %{_libdir}/cherokee/libplugin_common.so
155 %attr(755,root,root) %{_libdir}/cherokee/libplugin_dirlist.so
156 %attr(755,root,root) %{_libdir}/cherokee/libplugin_error_redir.so
157 %attr(755,root,root) %{_libdir}/cherokee/libplugin_fastcgi.so
158 %attr(755,root,root) %{_libdir}/cherokee/libplugin_file.so
159 %attr(755,root,root) %{_libdir}/cherokee/libplugin_gzip.so
160 %attr(755,root,root) %{_libdir}/cherokee/libplugin_htdigest.so
161 %attr(755,root,root) %{_libdir}/cherokee/libplugin_htpasswd.so
162 %attr(755,root,root) %{_libdir}/cherokee/libplugin_ncsa.so
163 %attr(755,root,root) %{_libdir}/cherokee/libplugin_nn.so
164 %attr(755,root,root) %{_libdir}/cherokee/libplugin_pam.so
165 %attr(755,root,root) %{_libdir}/cherokee/libplugin_phpcgi.so
166 %attr(755,root,root) %{_libdir}/cherokee/libplugin_plain.so
167 %attr(755,root,root) %{_libdir}/cherokee/libplugin_read_config.so
168 %attr(755,root,root) %{_libdir}/cherokee/libplugin_redir.so
169 %attr(755,root,root) %{_libdir}/cherokee/libplugin_server_info.so
170 %attr(755,root,root) %{_libdir}/cherokee/libplugin_w3c.so
171 %attr(755,root,root) %{_libdir}/libcherokee-base.so.*.*.*
172 %attr(755,root,root) %{_libdir}/libcherokee-client.so.*.*.*
173 %attr(755,root,root) %{_libdir}/libcherokee-config.so.*.*.*
174 %attr(755,root,root) %{_libdir}/libcherokee-server.so.*.*.*
175
176 %{_mandir}/man1/cherokee.1*
177 %{_mandir}/man1/cget.1*
178 %{_mandir}/man1/cherokee_logrotate.1*
179
180 %{_datadir}/cherokee
181
182 %dir %{_wwwhome}
183 %{_wwwroot}
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/cherokee-config
188
189 %{_libdir}/libcherokee-base.la
190 %{_libdir}/libcherokee-client.la
191 %{_libdir}/libcherokee-config.la
192 %{_libdir}/libcherokee-server.la
193
194 %{_includedir}/cherokee
195 %{_pkgconfigdir}/cherokee.pc
196 %{_aclocaldir}/cherokee.m4
197 %{_mandir}/man1/cherokee-config.1*
This page took 0.259361 seconds and 4 git commands to generate.