]> git.pld-linux.org Git - packages/chef.git/commitdiff
up to 11.6.0
authorElan Ruusamäe <glen@delfi.ee>
Sat, 14 Sep 2013 13:14:13 +0000 (16:14 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 14 Sep 2013 13:14:43 +0000 (16:14 +0300)
FHS.patch
chef.spec
platform-pld.patch

index 9ae155b2aafa09acd33998a878df8b56d6dee95a..d99cc188cb442d5152e7ade7f88fafcdf4b2bdde 100644 (file)
--- a/FHS.patch
+++ b/FHS.patch
@@ -1,6 +1,17 @@
---- chef-11.4.4.gem/lib/chef/config.rb 2013-04-30 01:35:11.703271336 +0300
-+++ chef-11.4.4/lib/chef/config.rb     2013-04-30 01:38:24.665295683 +0300
-@@ -141,20 +141,20 @@
+--- chef-11.4.4.gem/lib/chef/handler/json_file.rb      2013-04-30 01:35:11.709938303 +0300
++++ chef-11.4.4/lib/chef/handler/json_file.rb  2013-04-30 01:38:24.665295683 +0300
+@@ -27,7 +27,7 @@
+       def initialize(config={})
+         @config = config
+-        @config[:path] ||= "/var/chef/reports"
++        @config[:path] ||= "/var/lib/chef/reports"
+         @config
+       end
+--- chef-11.6.0/lib/chef/config.rb~    2013-08-18 18:27:57.000000000 +0300
++++ chef-11.6.0/lib/chef/config.rb     2013-08-18 18:28:08.057227738 +0300
+@@ -123,17 +123,17 @@
  
      # Where the cookbooks are located. Meaning is somewhat context dependent between
      # knife, chef-client, and chef-solo.
      # An array of paths to search for knife exec scripts if they aren't in the current directory
      script_path []
  
-     # Where files are stored temporarily during uploads
--    sandbox_path "/var/chef/sandboxes"
-+    sandbox_path "/var/lib/chef/sandboxes"
      # Where cookbook files are stored on the server (by content checksum)
 -    checksum_path "/var/chef/checksums"
 +    checksum_path "/var/lib/chef/checksums"
@@ -26,7 +33,7 @@
  
      # By default, chef-client (or solo) creates a lockfile in
      # `file_cache_path`/chef-client-running.pid
-@@ -166,7 +166,7 @@
+@@ -145,7 +145,7 @@
      lockfile nil
  
      # Where backups of chef-managed files should go
  
      ## Daemonization Settings ##
      # What user should Chef run as?
-@@ -202,7 +202,7 @@
-     # toggle info level log items that can create a lot of output
-     verbose_logging true
-     node_name nil
--    node_path "/var/chef/node"
-+    node_path "/var/lib/chef/node"
-     diff_disable            false
-     diff_filesize_threshold 10000000
-     diff_output_threshold   1000000
-@@ -239,9 +239,9 @@
+@@ -207,11 +207,11 @@
+     ssl_ca_file nil
  
      # Where should chef-solo look for role files?
 -    role_path platform_specific_path("/var/chef/roles")
 -    data_bag_path platform_specific_path("/var/chef/data_bags")
 +    data_bag_path platform_specific_path("/var/lib/chef/data_bags")
  
+-    environment_path platform_specific_path("/var/chef/environments")
++    environment_path platform_specific_path("/var/lib/chef/environments")
      # Where should chef-solo download recipes from?
      recipe_url nil
-@@ -286,8 +286,8 @@
-     # Server Signing CA
-     #
-     # In truth, these don't even have to change
--    signing_ca_cert "/var/chef/ca/cert.pem"
--    signing_ca_key "/var/chef/ca/key.pem"
-+    signing_ca_cert "/var/lib/chef/ca/cert.pem"
-+    signing_ca_key "/var/lib/chef/ca/key.pem"
-     signing_ca_user nil
-     signing_ca_group nil
-     signing_ca_country "US"
-@@ -318,7 +318,7 @@
+@@ -302,7 +302,7 @@
      syntax_check_cache_path nil
  
      # Deprecated:
  
      # Set to false to silence Chef 11 deprecation warnings:
      chef11_deprecation_warnings true
---- chef-11.4.4.gem/lib/chef/handler/json_file.rb      2013-04-30 01:35:11.709938303 +0300
-+++ chef-11.4.4/lib/chef/handler/json_file.rb  2013-04-30 01:38:24.665295683 +0300
-@@ -27,7 +27,7 @@
-       def initialize(config={})
-         @config = config
--        @config[:path] ||= "/var/chef/reports"
-+        @config[:path] ||= "/var/lib/chef/reports"
-         @config
-       end
+--- chef-11.6.0/lib/chef/chef_fs/config.rb~    2013-08-18 18:28:38.000000000 +0300
++++ chef-11.6.0/lib/chef/chef_fs/config.rb     2013-08-18 18:29:11.806714479 +0300
+@@ -158,17 +158,17 @@
+       def configure_repo_paths
+         # Smooth out some (for now) inappropriate defaults set by Chef
+-        if @chef_config[:cookbook_path] == [ @chef_config.platform_specific_path("/var/chef/cookbooks"),
+-                      @chef_config.platform_specific_path("/var/chef/site-cookbooks") ]
++        if @chef_config[:cookbook_path] == [ @chef_config.platform_specific_path("/var/lib/chef/cookbooks"),
++                      @chef_config.platform_specific_path("/var/lib/chef/site-cookbooks") ]
+           @chef_config[:cookbook_path] = nil
+         end
+-        if @chef_config[:data_bag_path] == @chef_config.platform_specific_path('/var/chef/data_bags')
++        if @chef_config[:data_bag_path] == @chef_config.platform_specific_path('/var/lib/chef/data_bags')
+           @chef_config[:data_bag_path] = nil
+         end
+-        if @chef_config[:node_path] == '/var/chef/node'
++        if @chef_config[:node_path] == '/var/lib/chef/node'
+           @chef_config[:node_path] = nil
+         end
+-        if @chef_config[:role_path] == @chef_config.platform_specific_path('/var/chef/roles')
++        if @chef_config[:role_path] == @chef_config.platform_specific_path('/var/lib/chef/roles')
+           @chef_config[:role_path] = nil
+         end
  
index 50b82197d7250dcd5f806c652f791fb89778b6f2..3dd7b702516d1e7d0ef59f0e9c42c20e3466ead1 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -4,12 +4,12 @@
 
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
-Version:       11.4.4
-Release:       5
+Version:       11.6.0
+Release:       1
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{name}-%{version}.gem
-# Source0-md5: dc50aa6a4a7d4785a4c82fcaab3f9436
+# Source0-md5: 3e8f67a5d11144573cf2c8d520ca39a6
 Source1:       %{name}.rb
 Patch0:                platform-pld.patch
 Patch1:                FHS.patch
@@ -23,8 +23,12 @@ BuildRequires:       rpmbuild(macros) >= 1.656
 BuildRequires: sed >= 4.0
 %if %{with tests}
 BuildRequires: ruby-abstract
+BuildRequires: ruby-chef-zero < 2
+BuildRequires: ruby-chef-zero >= 1.4
 BuildRequires: ruby-mixlib-authentication >= 1.3.0
 BuildRequires: ruby-net-ssh-multi >= 1.1.0
+BuildRequires: ruby-puma < 2
+BuildRequires: ruby-puma >= 1.6
 BuildRequires: ruby-rack
 BuildRequires: ruby-rake
 #BuildRequires:        ruby-rdoc
@@ -37,6 +41,7 @@ BuildRequires:        ruby-rspec-mocks >= 2.12.0
 %endif
 Requires:      lsb-release
 Requires:      poldek >= 0.30
+Requires:      ruby >= 1:1.9.3.429-4
 Requires:      ruby-erubis
 Requires:      ruby-highline >= 1.6.9
 Requires:      ruby-json >= 1.4.4
@@ -51,7 +56,6 @@ Requires:     ruby-ohai >= 0.6.0
 Requires:      ruby-rest-client >= 1.0.4
 Requires:      ruby-rubygems
 Requires:      ruby-yajl >= 1.1
-Requires:      ruby >= 1:1.9.3.429-4
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -93,6 +97,7 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
 %attr(755,root,root) %{_bindir}/chef-apply
 %attr(755,root,root) %{_bindir}/chef-client
+%attr(755,root,root) %{_bindir}/chef-service-manager
 %attr(755,root,root) %{_bindir}/chef-shell
 %attr(755,root,root) %{_bindir}/chef-solo
 %attr(755,root,root) %{_bindir}/knife
index ccf734834d33932eaa44b671f7048993840193ae..5bf207e6184b4d36bd056d52b56ebc4b360f9390 100644 (file)
@@ -1,7 +1,7 @@
---- chef-11.4.0/lib/chef/platform.rb~  2013-04-14 16:43:01.000000000 +0300
-+++ chef-11.4.0/lib/chef/platform.rb   2013-04-14 21:34:43.907576130 +0300
-@@ -147,6 +147,14 @@
-               :mdadm => Chef::Provider::Mdadm
+--- chef-11.6.0/lib/chef/platform/provider_mapping.rb~ 2013-08-18 18:21:27.000000000 +0300
++++ chef-11.6.0/lib/chef/platform/provider_mapping.rb  2013-08-18 18:25:27.133441297 +0300
+@@ -173,6 +173,15 @@
+               :ifconfig => Chef::Provider::Ifconfig::Redhat
              }
            },
 +          :pld => {
@@ -9,7 +9,8 @@
 +              :service => Chef::Provider::Service::Redhat,
 +              :cron => Chef::Provider::Cron,
 +              :package => Chef::Provider::Package::Poldek,
-+              :mdadm => Chef::Provider::Mdadm
++              :mdadm => Chef::Provider::Mdadm,
++              :ifconfig => Chef::Provider::Ifconfig::Redhat # TODO: PLD config path needed
 +            }
 +          },
            :suse     => {
This page took 0.073763 seconds and 4 git commands to generate.