]> git.pld-linux.org Git - packages/chef.git/commitdiff
up to 14.3.37 (current stable) chef-14.3
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 21 Jul 2018 15:25:18 +0000 (18:25 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Tue, 18 Sep 2018 12:04:43 +0000 (15:04 +0300)
FHS.patch
chef.spec

index 97e0690d026bd06dacf0d9d38fe640ba9fa67672..3ea1b04b8df59b5ba49522093eae52609a10a9f8 100644 (file)
--- a/FHS.patch
+++ b/FHS.patch
  
      # The chef-client (or solo) lockfile.
      #
+--- chef-14.3.37/lib/chef/resource/launchd.rb~ 2018-07-10 23:49:12.000000000 +0300
++++ chef-14.3.37/lib/chef/resource/launchd.rb  2018-07-21 18:36:11.686358648 +0300
+@@ -36,7 +36,7 @@
+       property :backup, [Integer, FalseClass],
+                desired_state: false,
+-               description: "The number of backups to be kept in /var/chef/backup. Set to false to prevent backups from being kept."
++               description: "The number of backups to be kept in /var/lib/chef/backup. Set to false to prevent backups from being kept."
+       property :cookbook, String,
+                desired_state: false,
 --- chef-14.1.21/chef-config/spec/unit/config_spec.rb.orig     2018-05-21 18:22:54.000000000 +0200
 +++ chef-14.1.21/chef-config/spec/unit/config_spec.rb  2018-07-14 22:10:47.642865027 +0200
 @@ -252,7 +252,7 @@
    end
  
    # Don't need to have an after block to reset the config...
---- chef-14.1.21/spec/unit/application/solo_spec.rb~   2018-05-21 18:22:54.000000000 +0200
-+++ chef-14.1.21/spec/unit/application/solo_spec.rb    2018-07-14 22:13:57.265002987 +0200
+--- chef-14.3.37/spec/unit/application/solo_spec.rb~   2018-07-10 23:49:12.000000000 +0300
++++ chef-14.3.37/spec/unit/application/solo_spec.rb    2018-07-21 18:35:10.469813803 +0300
 @@ -206,10 +206,10 @@
      end
  
 -      expect(Chef::Config).to receive(:find_chef_repo_path).and_return("/var/chef")
 +      expect(Chef::Config).to receive(:find_chef_repo_path).and_return("/var/lib/chef")
        app.reconfigure
-       expect(Chef::Config.has_key?(:chef_repo_path)).to be_truthy
+       expect(Chef::Config.key?(:chef_repo_path)).to be_truthy
 -      expect(Chef::Config[:chef_repo_path]).to eq ("/var/chef")
 +      expect(Chef::Config[:chef_repo_path]).to eq ("/var/lib/chef")
      end
index e54a2aef93276e7a75c701dbce90214a34c6bdbb..fbaa23a6187778c794238141fac9fbc7ccd94c46 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -1,5 +1,5 @@
 # NOTE:
-# - check releases here: https://downloads.chef.io/chef-client/debian/
+# - check releases here: https://downloads.chef.io/chef
 #   the versions tagged in github are somewhat newer, perhaps dev-releases
 
 # Conditional build:
@@ -7,12 +7,12 @@
 
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
-Version:       14.1.36
-Release:       1
+Version:       14.3.37
+Release:       0.1
 License:       Apache v2.0
 Group:         Networking/Admin
 Source0:       https://github.com/chef/chef/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 442169a1a824b3335376a88723e133a0
+# Source0-md5: 359e65ddde289f6bfb33a95fabb81d0c
 Source2:       %{name}.tmpfiles
 Source3:       https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
 # Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
This page took 0.089006 seconds and 4 git commands to generate.