]> git.pld-linux.org Git - packages/chef.git/commitdiff
update plist patch
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 17 Jul 2018 08:32:06 +0000 (11:32 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Tue, 17 Jul 2018 08:32:06 +0000 (11:32 +0300)
chef.spec
optional-plist.patch

index 46c0b8008af58663339a80bbdc2dcc81bff91b48..7d1c012ac088bdb9e819d777937a1d5737426376 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -8,7 +8,7 @@
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
 Version:       14.1.36
-Release:       0.2
+Release:       0.3
 License:       Apache v2.0
 Group:         Networking/Admin
 Source0:       https://github.com/chef/chef/archive/v%{version}/%{name}-%{version}.tar.gz
index a3483650961a35795fda4299519a912775153d98..dc02eb6bbb4aaeb3e7e3790b70da0bdaf23851ae 100644 (file)
            Plist::Emit.save_plist(user_info, user_plist_file)
            run_plutil("convert", "binary1", user_plist_file)
          end
+--- chef-14.1.36/lib/chef/provider/launchd.rb~ 2018-06-04 22:47:04.000000000 +0300
++++ chef-14.1.36/lib/chef/provider/launchd.rb  2018-07-16 17:04:37.751739371 +0300
+@@ -20,7 +20,6 @@
+ require "chef/resource/file"
+ require "chef/resource/cookbook_file"
+ require "chef/resource/macosx_service"
+-require "plist"
+ require "forwardable"
+ class Chef
+@@ -173,6 +172,8 @@
+       end
+       def content
++        require "plist"
++
+         plist_hash = new_resource.plist_hash || gen_hash
+         Plist::Emit.dump(plist_hash) unless plist_hash.nil?
+       end
This page took 0.344755 seconds and 4 git commands to generate.