]> git.pld-linux.org Git - packages/chef.git/blobdiff - chef.spec
chef-zero is optional for typical chef-client run
[packages/chef.git] / chef.spec
index 4dfd7f5103f5ee337e859e7a417059d64f5d3fbf..c7ba8345d0f40f7c049437e9454da02372255724 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -5,7 +5,7 @@
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
 Version:       11.8.2
-Release:       0.1
+Release:       0.13
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{name}-%{version}.gem
@@ -24,40 +24,50 @@ BuildRequires:      rpmbuild(macros) >= 1.656
 BuildRequires: sed >= 4.0
 %if %{with tests}
 BuildRequires: ruby-abstract
-BuildRequires: ruby-chef-zero < 2
-BuildRequires: ruby-chef-zero >= 1.4
 BuildRequires: ruby-mixlib-authentication >= 1.3.0
 BuildRequires: ruby-net-ssh-multi >= 1.1.0
-BuildRequires: ruby-puma < 2
-BuildRequires: ruby-puma >= 1.6
 BuildRequires: ruby-rack
 BuildRequires: ruby-rake
 #BuildRequires:        ruby-rdoc
 BuildRequires: ruby-rest-client >= 1.0.4
-BuildRequires: ruby-rspec-core >= 2.12.0
-BuildRequires: ruby-rspec-expectations >= 2.12.0
-BuildRequires: ruby-rspec-mocks >= 2.12.0
+BuildRequires: ruby-rspec-core < 2.14
+BuildRequires: ruby-rspec-core >= 2.13.0
+BuildRequires: ruby-rspec-expectations < 2.14
+BuildRequires: ruby-rspec-expectations >= 2.13.0
+BuildRequires: ruby-rspec-mocks < 2.14
+BuildRequires: ruby-rspec-mocks >= 2.13.0
 #BuildRequires:        ruby-rspec_junit_formatter
 #BuildRequires:        ruby-sdoc
 %endif
-#Requires:     diffutils
 Requires:      lsb-release
 Requires:      poldek >= 0.30
 Requires:      ruby >= 1:1.9.3.429-4
+Requires:      ruby-diff-lcs < 2
+Requires:      ruby-diff-lcs >= 1.2
+Requires:      ruby-diff-lcs >= 1.2.4
 Requires:      ruby-erubis
 Requires:      ruby-highline >= 1.6.9
 Requires:      ruby-json >= 1.4.4
+Requires:      ruby-mime-types < 2
+Requires:      ruby-mime-types >= 1.16
 Requires:      ruby-mixlib-authentication >= 1.3.0
 Requires:      ruby-mixlib-cli >= 1.3.0
-Requires:      ruby-mixlib-config >= 1.1.2
+Requires:      ruby-mixlib-config < 3
+Requires:      ruby-mixlib-config >= 2.0
 Requires:      ruby-mixlib-log >= 1.3.0
-Requires:      ruby-mixlib-shellout
+Requires:      ruby-mixlib-shellout >= 1.2
 Requires:      ruby-net-ssh >= 2.6
 Requires:      ruby-net-ssh-multi >= 1.1.0
-Requires:      ruby-ohai >= 0.6.0
+Requires:      ruby-ohai < 7
+Requires:      ruby-ohai >= 6.0
+Requires:      ruby-pry < 1
+Requires:      ruby-pry >= 0.9
+Requires:      ruby-puma < 2
+Requires:      ruby-puma >= 1.6
 Requires:      ruby-rest-client >= 1.0.4
 Requires:      ruby-rubygems
 Requires:      ruby-yajl >= 1.1
+Suggests:      chef-zero >= 1.6.2
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -68,6 +78,17 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 A systems integration framework, built to bring the benefits of
 configuration management to your entire infrastructure.
 
+%package -n knife
+Summary:       knife - Chef Server API client utility
+Group:         Development/Languages
+Requires:      %{name} = %{version}-%{release}
+
+%description -n knife
+Knife is a command-line utility used to manage data on a Chef server
+through the HTTP(S) API. Knife is organized into groups of subcommands
+centered around the various object types in Chef. Each category of
+subcommand is documented in its own manual page.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -110,9 +131,33 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/chef-service-manager
 %attr(755,root,root) %{_bindir}/chef-shell
 %attr(755,root,root) %{_bindir}/chef-solo
-%attr(755,root,root) %{_bindir}/knife
 %attr(755,root,root) %{_bindir}/shef
 %{_mandir}/man1/chef-shell.1*
+%{_mandir}/man8/chef-client.8*
+%{_mandir}/man8/chef-solo.8*
+%{ruby_vendorlibdir}/chef.rb
+%{ruby_vendorlibdir}/chef
+%exclude %{ruby_vendorlibdir}/chef/knife
+%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
+%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
+%exclude %{ruby_vendorlibdir}/chef/knife.rb
+%{systemdtmpfilesdir}/chef.conf
+
+%dir /var/lib/%{name}
+%dir /var/lib/%{name}/roles
+%dir /var/lib/%{name}/data_bags
+%dir /var/lib/%{name}/environments
+
+%dir /var/cache/%{name}
+%dir /var/run/%{name}
+
+%files -n knife
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/knife
+%{ruby_vendorlibdir}/chef/knife.rb
+%{ruby_vendorlibdir}/chef/knife
+%{ruby_vendorlibdir}/chef/application/knife.rb
+%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
 %{_mandir}/man1/knife-bootstrap.1*
 %{_mandir}/man1/knife-client.1*
 %{_mandir}/man1/knife-configure.1*
@@ -141,16 +186,3 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/knife-user.1*
 %{_mandir}/man1/knife-xargs.1*
 %{_mandir}/man1/knife.1*
-%{_mandir}/man8/chef-client.8*
-%{_mandir}/man8/chef-solo.8*
-%{ruby_vendorlibdir}/chef.rb
-%{ruby_vendorlibdir}/chef
-%{systemdtmpfilesdir}/chef.conf
-
-%dir /var/lib/%{name}
-%dir /var/lib/%{name}/roles
-%dir /var/lib/%{name}/data_bags
-%dir /var/lib/%{name}/environments
-
-%dir /var/cache/%{name}
-%dir /var/run/%{name}
This page took 0.485842 seconds and 4 git commands to generate.