]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
d2066b1fc8d8d0789360a13da8b6e31bf3509a9b
[packages/chef.git] / chef.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6 Name:           chef
7 Version:        11.8.0
8 Release:        0.1
9 License:        Apache v2.0
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  522cb7dfcff513a575f6c68493030584
13 Source1:        %{name}.rb
14 Source2:        %{name}.tmpfiles
15 Patch0:         platform-pld.patch
16 Patch1:         FHS.patch
17 Patch2:         https://github.com/glensc/chef/compare/poldek.patch
18 # Patch2-md5:   5a0fc35de33910b41cba4e87dcb4bf9a
19 Patch3:         https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
20 # Patch3-md5:   bfc884469fad7b5aa46341402be5fccd
21 URL:            http://wiki.opscode.com/display/chef
22 BuildRequires:  rpm-rubyprov
23 BuildRequires:  rpmbuild(macros) >= 1.656
24 BuildRequires:  sed >= 4.0
25 %if %{with tests}
26 BuildRequires:  ruby-abstract
27 BuildRequires:  ruby-chef-zero < 2
28 BuildRequires:  ruby-chef-zero >= 1.4
29 BuildRequires:  ruby-mixlib-authentication >= 1.3.0
30 BuildRequires:  ruby-net-ssh-multi >= 1.1.0
31 BuildRequires:  ruby-puma < 2
32 BuildRequires:  ruby-puma >= 1.6
33 BuildRequires:  ruby-rack
34 BuildRequires:  ruby-rake
35 #BuildRequires: ruby-rdoc
36 BuildRequires:  ruby-rest-client >= 1.0.4
37 BuildRequires:  ruby-rspec-core >= 2.12.0
38 BuildRequires:  ruby-rspec-expectations >= 2.12.0
39 BuildRequires:  ruby-rspec-mocks >= 2.12.0
40 #BuildRequires: ruby-rspec_junit_formatter
41 #BuildRequires: ruby-sdoc
42 %endif
43 #Requires:      diffutils
44 Requires:       lsb-release
45 Requires:       poldek >= 0.30
46 Requires:       ruby >= 1:1.9.3.429-4
47 Requires:       ruby-erubis
48 Requires:       ruby-highline >= 1.6.9
49 Requires:       ruby-json >= 1.4.4
50 Requires:       ruby-mixlib-authentication >= 1.3.0
51 Requires:       ruby-mixlib-cli >= 1.3.0
52 Requires:       ruby-mixlib-config >= 1.1.2
53 Requires:       ruby-mixlib-log >= 1.3.0
54 Requires:       ruby-mixlib-shellout
55 Requires:       ruby-net-ssh >= 2.6
56 Requires:       ruby-net-ssh-multi >= 1.1.0
57 Requires:       ruby-ohai >= 0.6.0
58 Requires:       ruby-rest-client >= 1.0.4
59 Requires:       ruby-rubygems
60 Requires:       ruby-yajl >= 1.1
61 BuildArch:      noarch
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 # do not generate python dependency, yum support is optional
65 %define         _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
66
67 %description
68 A systems integration framework, built to bring the benefits of
69 configuration management to your entire infrastructure.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77
78 grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
79
80 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
81
82 %build
83 %if %{with tests}
84 rspec spec
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
90         $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments}}}
91
92 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
93 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
94 cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
95
96 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
97 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README.md CONTRIBUTING.md
105 %dir %{_sysconfdir}/%{name}
106 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
107 %attr(755,root,root) %{_bindir}/chef-apply
108 %attr(755,root,root) %{_bindir}/chef-client
109 %attr(755,root,root) %{_bindir}/chef-service-manager
110 %attr(755,root,root) %{_bindir}/chef-shell
111 %attr(755,root,root) %{_bindir}/chef-solo
112 %attr(755,root,root) %{_bindir}/knife
113 %attr(755,root,root) %{_bindir}/shef
114 %{_mandir}/man1/chef-shell.1*
115 %{_mandir}/man1/knife-bootstrap.1*
116 %{_mandir}/man1/knife-client.1*
117 %{_mandir}/man1/knife-configure.1*
118 %{_mandir}/man1/knife-cookbook-site.1*
119 %{_mandir}/man1/knife-cookbook.1*
120 %{_mandir}/man1/knife-data-bag.1*
121 %{_mandir}/man1/knife-environment.1*
122 %{_mandir}/man1/knife-exec.1*
123 %{_mandir}/man1/knife-index.1*
124 %{_mandir}/man1/knife-node.1*
125 %{_mandir}/man1/knife-role.1*
126 %{_mandir}/man1/knife-search.1*
127 %{_mandir}/man1/knife-ssh.1*
128 %{_mandir}/man1/knife-status.1*
129 %{_mandir}/man1/knife-tag.1*
130 %{_mandir}/man1/knife.1*
131 %{_mandir}/man8/chef-client.8*
132 %{_mandir}/man8/chef-expander.8*
133 %{_mandir}/man8/chef-expanderctl.8*
134 %{_mandir}/man8/chef-server-webui.8*
135 %{_mandir}/man8/chef-server.8*
136 %{_mandir}/man8/chef-solo.8*
137 %{_mandir}/man8/chef-solr.8*
138 %{ruby_vendorlibdir}/chef.rb
139 %{ruby_vendorlibdir}/chef
140 %{systemdtmpfilesdir}/chef.conf
141
142 %dir /var/lib/%{name}
143 %dir /var/lib/%{name}/roles
144 %dir /var/lib/%{name}/data_bags
145 %dir /var/lib/%{name}/environments
146
147 %dir /var/cache/%{name}
148 %dir /var/run/%{name}
This page took 0.059107 seconds and 2 git commands to generate.