]> git.pld-linux.org Git - packages/check.git/blob - check.spec
- no need for libstdc++-devel, just undefine __cxx
[packages/check.git] / check.spec
1 Summary:        Check - unit testing framework for C
2 Summary(pl.UTF-8):      Check - szkielet testów jednostkowych dla C
3 Name:           check
4 Version:        0.9.5
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/check/%{name}-%{version}.tar.gz
9 # Source0-md5:  30143c7974b547a12a7da47809a90951
10 Patch0:         %{name}-info.patch
11 URL:            http://check.sourceforge.net/
12 # aclocal required for %{_aclocaldir}
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRequires:  texinfo >= 4.2
16 Requires(post,postun):  /sbin/ldconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %undefine       __cxx
20
21 %description
22 Check is a unit test framework for C. It features a simple interface
23 for defining unit tests, putting little in the way of the developer.
24 Tests are run in a separate address space, so Check can catch both
25 assertion failures and code errors that cause segmentation faults or
26 other signals. The output from unit tests can be used within source
27 code editors and IDEs.
28
29 %description -l pl.UTF-8
30 Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
31 definiowania testów jednostkowych, nie przeszkadzający zbytnio
32 programiście. Testy są uruchamiane w wydzielonej przestrzeni
33 adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
34 zapewnień (assert), jak i błędy w kodzie powodujące naruszenie
35 ochrony pamięci lub inne sygnały. Wyjście z testów jednostkowych może
36 być używane z poziomu edytorów kodu źródłowego i IDE.
37
38 %package static
39 Summary:        Static check library
40 Summary(pl.UTF-8):      Biblioteka statyczna check
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description static
45 Static check library.
46
47 %description static -l pl.UTF-8
48 Biblioteka statyczna check.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53
54 %build
55 CFLAGS="%{rpmcflags} -fPIC"
56 %configure
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         exampledir=%{_examplesdir}/%{name}-%{version} \
64         examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
65         exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
69 rm -f $RPM_BUILD_ROOT%{_libdir}/libcheck.la
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 /sbin/ldconfig
76 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
77
78 %postun
79 /sbin/ldconfig
80 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS ChangeLog* NEWS README SVNChangeLog THANKS TODO
85 %attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
86 %attr(755,root,root) %{_libdir}/libcheck.so
87 %{_includedir}/check.h
88 %{_aclocaldir}/check.m4
89 %{_pkgconfigdir}/check.pc
90 %{_infodir}/check.info*
91 %{_examplesdir}/%{name}-%{version}
92
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/libcheck.a
This page took 0.080011 seconds and 4 git commands to generate.