]> git.pld-linux.org Git - packages/check.git/blob - check.spec
- BR: automake, libstdc++-devel
[packages/check.git] / check.spec
1 Summary:        Check - unit testing framework for C
2 Summary(pl.UTF-8):      Check - szkielet testów jednostkowych dla C
3 Name:           check
4 Version:        0.9.5
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/check/%{name}-%{version}.tar.gz
9 # Source0-md5:  30143c7974b547a12a7da47809a90951
10 Patch0:         %{name}-info.patch
11 URL:            http://check.sourceforge.net/
12 # aclocal required for %{_aclocaldir}
13 BuildRequires:  automake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 BuildRequires:  texinfo >= 4.2
17 Requires(post,postun):  /sbin/ldconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Check is a unit test framework for C. It features a simple interface
22 for defining unit tests, putting little in the way of the developer.
23 Tests are run in a separate address space, so Check can catch both
24 assertion failures and code errors that cause segmentation faults or
25 other signals. The output from unit tests can be used within source
26 code editors and IDEs.
27
28 %description -l pl.UTF-8
29 Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
30 definiowania testów jednostkowych, nie przeszkadzający zbytnio
31 programiście. Testy są uruchamiane w wydzielonej przestrzeni
32 adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
33 zapewnień (assert), jak i błędy w kodzie powodujące naruszenie
34 ochrony pamięci lub inne sygnały. Wyjście z testów jednostkowych może
35 być używane z poziomu edytorów kodu źródłowego i IDE.
36
37 %package static
38 Summary:        Static check library
39 Summary(pl.UTF-8):      Biblioteka statyczna check
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description static
44 Static check library.
45
46 %description static -l pl.UTF-8
47 Biblioteka statyczna check.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52
53 %build
54 CFLAGS="%{rpmcflags} -fPIC"
55 %configure
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         exampledir=%{_examplesdir}/%{name}-%{version} \
63         examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
64         exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
68 rm -f $RPM_BUILD_ROOT%{_libdir}/libcheck.la
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 /sbin/ldconfig
75 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
76
77 %postun
78 /sbin/ldconfig
79 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS ChangeLog* NEWS README SVNChangeLog THANKS TODO
84 %attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
85 %attr(755,root,root) %{_libdir}/libcheck.so
86 %{_includedir}/check.h
87 %{_aclocaldir}/check.m4
88 %{_pkgconfigdir}/check.pc
89 %{_infodir}/check.info*
90 %{_examplesdir}/%{name}-%{version}
91
92 %files static
93 %defattr(644,root,root,755)
94 %{_libdir}/libcheck.a
This page took 0.089132 seconds and 3 git commands to generate.