]> git.pld-linux.org Git - packages/check.git/blob - check.spec
a345195c1d7ea0b26bd42ce00e5838df278154f9
[packages/check.git] / check.spec
1 Summary:        Check - unit testing framework for C
2 Summary(pl):    Check - szkielet testów jednostkowych dla C
3 Name:           check
4 Version:        0.9.5
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/check/%{name}-%{version}.tar.gz
9 # Source0-md5:  30143c7974b547a12a7da47809a90951
10 URL:            http://check.sourceforge.net/
11 BuildRequires:  libtool
12 BuildRequires:  texinfo >= 4.2
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Check is a unit test framework for C. It features a simple interface
17 for defining unit tests, putting little in the way of the developer.
18 Tests are run in a separate address space, so Check can catch both
19 assertion failures and code errors that cause segmentation faults or
20 other signals. The output from unit tests can be used within source
21 code editors and IDEs.
22
23 %description -l pl
24 Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
25 definiowania testów jednostkowych, nie przeszkadzaj±cy zbytnio
26 programi¶cie. Testy s± uruchamiane w wydzielonej przestrzeni
27 adresowej, dziêki czemu Check mo¿e wy³apaæ zarówno niepowodzenia
28 zapewnieñ (assert), jak i b³êdy w kodzie powoduj±ce naruszenie
29 ochrony pamiêci lub inne sygna³y. Wyj¶cie z testów jednostkowych mo¿e
30 byæ u¿ywane z poziomu edytorów kodu ¼ród³owego i IDE.
31
32 %prep
33 %setup -q
34
35 %build
36 %configure2_13
37 %{__make} \
38     CFLAGS="%{rpmcflags} -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -fPIC"
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         exampledir=%{_examplesdir}/%{name}-%{version} \
45         examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
46         exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/
50 rm -f $RPM_BUILD_ROOT%{_libdir}/libcheck.la
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
57
58 %postun
59 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
60
61 %files
62 %defattr(644,root,root,755)
63 %doc AUTHORS ChangeLog* NEWS README SVNChangeLog
64 %{_aclocaldir}/check.m4
65 %{_includedir}/check.h
66 %{_libdir}/libcheck.a
67 %{_libdir}/libcheck.so.0.0.0
68 %{_pkgconfigdir}/check.pc
69 %{_examplesdir}/%{name}-%{version}
70 %{_infodir}/check.info*
This page took 0.326695 seconds and 2 git commands to generate.