]> git.pld-linux.org Git - packages/check.git/blame_incremental - check.spec
- new URLs, updated to 0.12.0
[packages/check.git] / check.spec
... / ...
CommitLineData
1Summary: Check - unit testing framework for C
2Summary(pl.UTF-8): Check - szkielet testów jednostkowych dla C
3Name: check
4Version: 0.9.10
5Release: 2
6License: LGPL v2.1+
7Group: Libraries
8Source0: http://downloads.sourceforge.net/check/%{name}-%{version}.tar.gz
9# Source0-md5: 6d10a8efb9a683467b92b3bce97aeb30
10Patch0: %{name}-info.patch
11URL: http://check.sourceforge.net/
12# aclocal required for %{_aclocaldir}
13BuildRequires: automake
14BuildRequires: libtool
15BuildRequires: texinfo >= 4.2
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%undefine __cxx
19
20%description
21Check is a unit test framework for C. It features a simple interface
22for defining unit tests, putting little in the way of the developer.
23Tests are run in a separate address space, so Check can catch both
24assertion failures and code errors that cause segmentation faults or
25other signals. The output from unit tests can be used within source
26code editors and IDEs.
27
28This package contains only shared library.
29
30%description -l pl.UTF-8
31Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
32definiowania testów jednostkowych, nie przeszkadzający zbytnio
33programiście. Testy są uruchamiane w wydzielonej przestrzeni
34adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
35zapewnień (assert), jak i błędy w kodzie powodujące naruszenie ochrony
36pamięci lub inne sygnały. Wyjście z testów jednostkowych może być
37używane z poziomu edytorów kodu źródłowego i IDE.
38
39Ten pakiet zawiera tylko bibliotekę współdzieloną.
40
41%package devel
42Summary: Headers for developing programs with check library
43Summary(pl.UTF-8): Pliki nagłówkowe do tworzenia programów przy użyciu biblioteki checka
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description devel
48Headers for developing programs with check library.
49
50%description devel -l pl.UTF-8
51Pliki nagłówkowe do tworzenia programów przy użyciu biblioteki checka.
52
53%package static
54Summary: Static check library
55Summary(pl.UTF-8): Biblioteka statyczna check
56Group: Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description static
60Static check library.
61
62%description static -l pl.UTF-8
63Biblioteka statyczna check.
64
65%prep
66%setup -q
67%patch0 -p1
68
69%build
70CFLAGS="%{rpmcflags} -fPIC"
71%configure
72%{__make}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%{__make} install \
78 exampledir=%{_examplesdir}/%{name}-%{version} \
79 examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
80 exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
81 DESTDIR=$RPM_BUILD_ROOT
82
83%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
84%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcheck.la
85%{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%post devel -p /sbin/postshell
94-/usr/sbin/fix-info-dir -c %{_infodir}
95
96%postun devel -p /sbin/postshell
97-/usr/sbin/fix-info-dir -c %{_infodir}
98
99%files
100%defattr(644,root,root,755)
101%doc AUTHORS ChangeLog* NEWS README SVNChangeLog THANKS TODO
102%attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
103%attr(755,root,root) %ghost %{_libdir}/libcheck.so.0
104
105%files devel
106%defattr(644,root,root,755)
107%attr(755,root,root) %{_bindir}/checkmk
108%attr(755,root,root) %{_libdir}/libcheck.so
109%{_includedir}/check.h
110%{_includedir}/check_stdint.h
111%{_aclocaldir}/check.m4
112%{_pkgconfigdir}/check.pc
113%{_mandir}/man1/checkmk.1*
114%{_infodir}/check.info*
115%{_examplesdir}/%{name}-%{version}
116
117%files static
118%defattr(644,root,root,755)
119%{_libdir}/libcheck.a
This page took 0.104959 seconds and 4 git commands to generate.