]> git.pld-linux.org Git - packages/check.git/blob - check.spec
- new URLs, updated to 0.12.0
[packages/check.git] / check.spec
1 Summary:        Check - unit testing framework for C
2 Summary(pl.UTF-8):      Check - szkielet testów jednostkowych dla C
3 Name:           check
4 Version:        0.9.10
5 Release:        2
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/check/%{name}-%{version}.tar.gz
9 # Source0-md5:  6d10a8efb9a683467b92b3bce97aeb30
10 Patch0:         %{name}-info.patch
11 URL:            http://check.sourceforge.net/
12 # aclocal required for %{_aclocaldir}
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRequires:  texinfo >= 4.2
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %undefine       __cxx
19
20 %description
21 Check is a unit test framework for C. It features a simple interface
22 for defining unit tests, putting little in the way of the developer.
23 Tests are run in a separate address space, so Check can catch both
24 assertion failures and code errors that cause segmentation faults or
25 other signals. The output from unit tests can be used within source
26 code editors and IDEs.
27
28 This package contains only shared library.
29
30 %description -l pl.UTF-8
31 Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
32 definiowania testów jednostkowych, nie przeszkadzający zbytnio
33 programiście. Testy są uruchamiane w wydzielonej przestrzeni
34 adresowej, dzięki czemu Check może wyłapać zarówno niepowodzenia
35 zapewnień (assert), jak i błędy w kodzie powodujące naruszenie ochrony
36 pamięci lub inne sygnały. Wyjście z testów jednostkowych może być
37 używane z poziomu edytorów kodu źródłowego i IDE.
38
39 Ten pakiet zawiera tylko bibliotekę współdzieloną.
40
41 %package devel
42 Summary:        Headers for developing programs with check library
43 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów przy użyciu biblioteki checka
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Headers for developing programs with check library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe do tworzenia programów przy użyciu biblioteki checka.
52
53 %package static
54 Summary:        Static check library
55 Summary(pl.UTF-8):      Biblioteka statyczna check
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static check library.
61
62 %description static -l pl.UTF-8
63 Biblioteka statyczna check.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68
69 %build
70 CFLAGS="%{rpmcflags} -fPIC"
71 %configure
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         exampledir=%{_examplesdir}/%{name}-%{version} \
79         examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
80         exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
84 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcheck.la
85 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %post   devel -p /sbin/postshell
94 -/usr/sbin/fix-info-dir -c %{_infodir}
95
96 %postun devel -p /sbin/postshell
97 -/usr/sbin/fix-info-dir -c %{_infodir}
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS ChangeLog* NEWS README SVNChangeLog THANKS TODO
102 %attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libcheck.so.0
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_bindir}/checkmk
108 %attr(755,root,root) %{_libdir}/libcheck.so
109 %{_includedir}/check.h
110 %{_includedir}/check_stdint.h
111 %{_aclocaldir}/check.m4
112 %{_pkgconfigdir}/check.pc
113 %{_mandir}/man1/checkmk.1*
114 %{_infodir}/check.info*
115 %{_examplesdir}/%{name}-%{version}
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libcheck.a
This page took 0.096231 seconds and 3 git commands to generate.