]> git.pld-linux.org Git - packages/charles.git/blob - charles.spec
- up to 3.5.1
[packages/charles.git] / charles.spec
1 # I have no access to full version, so I'm packaging trial version only.
2 # If you have full tarball, add with(out?)_trial bcond
3
4 # Conditional build:
5 %bcond_without  trial           # build from full tarball
6
7 %define         rel     0.1
8 %include        /usr/lib/rpm/macros.java
9 Summary:        Web debugging proxy application
10 Name:           charles
11 Version:        3.5.1
12 Release:        %{rel}
13 License:        Proprietary, not distributable
14 Group:          Networking/Daemons
15 Source0:        http://www.charlesproxy.com/assets/release/%{version}/charles.tar.gz
16 # NoSource0-md5:        1a21214d16f017318be061df061e6b8b
17 NoSource:       0
18 Source1:        %{name}.sh
19 URL:            http://www.charlesproxy.com/
20 BuildRequires:  jpackage-utils
21 BuildRequires:  rpm-javaprov
22 BuildRequires:  rpmbuild(macros) >= 1.300
23 Requires:       jpackage-utils
24 Requires:       jre-X11
25 ExclusiveArch:  i586 i686 pentium3 pentium4 athlon %{x8664}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # already stripped
29 %define         _enable_debug_packages  0
30
31 %description
32 Charles is an HTTP proxy / HTTP monitor / Reverse Proxy that enables a
33 developer to view all of the HTTP and SSL / HTTPS traffic between
34 their machine and the Internet. This includes requests, responses and
35 the HTTP headers (which contain the cookies and caching information).
36
37 %prep
38 %setup -q -n %{name}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_javadir}/%{name},%{_libdir}/%{name},%{_bindir}}
43
44 cp -a lib/*.jar $RPM_BUILD_ROOT%{_javadir}/%{name}
45 %ifarch %{ix86}
46 install -p lib/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
47 %endif
48 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %attr(755,root,root) %{_bindir}/%{name}
56 %{_javadir}/%{name}
57 %ifarch %{ix86}
58 %dir %{_libdir}/%{name}
59 %attr(755,root,root) %{_libdir}/%{name}/libjdic.so
60 %endif
This page took 0.075877 seconds and 3 git commands to generate.