]> git.pld-linux.org Git - packages/charles.git/blob - charles.spec
- unified
[packages/charles.git] / charles.spec
1 # I have no access to full version, so I'm packaging trial version only.
2 # If you have full tarball, add with(out?)_trial bcond
3
4 # Conditional build:
5 %bcond_without  trial           # build from full tarball
6
7 %define         rel     0.1
8 %include        /usr/lib/rpm/macros.java
9 Summary:        Web debugging proxy application
10 Name:           charles
11 Version:        3.4.1
12 Release:        %{rel}%{?with_trial:trial}
13 License:        Proprietary, not distributable
14 Group:          Networking/Daemons
15 Source0:        http://www.charlesproxy.com/assets/release/%{version}/%{name}.tar.gz
16 # Source0-md5:  bcab2cd381d8f5ae9ffed08a0a89b76d
17 NoSource:       0
18 Source1:        %{name}.sh
19 URL:            http://www.charlesproxy.com/
20 BuildRequires:  jpackage-utils
21 BuildRequires:  rpm-javaprov
22 BuildRequires:  rpmbuild(macros) >= 1.300
23 Requires:       jpackage-utils
24 Requires:       jre-X11
25 ExclusiveArch:  %{ix86}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # already stripped
29 %define         _enable_debug_packages  0
30
31 %description
32 Charles is an HTTP proxy / HTTP monitor / Reverse Proxy that enables a
33 developer to view all of the HTTP and SSL / HTTPS traffic between
34 their machine and the Internet. This includes requests, responses and
35 the HTTP headers (which contain the cookies and caching information).
36
37 %prep
38 %setup -q -n %{name}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_javadir}/%{name},%{_libdir}/%{name},%{_bindir}}
43 cp -a lib/*.jar $RPM_BUILD_ROOT%{_javadir}/%{name}
44 install -p lib/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
45 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %attr(755,root,root) %{_bindir}/%{name}
53 %{_javadir}/%{name}
54 %dir %{_libdir}/%{name}
55 %attr(755,root,root) %{_libdir}/%{name}/libjdic.so
This page took 0.04972 seconds and 3 git commands to generate.