]> git.pld-linux.org Git - packages/charles.git/blob - charles.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/charles.git] / charles.spec
1 # I have no access to full version, so I'm packaging trial version only.
2 # If you have full tarball, add with(out?)_trial bcond
3
4 # Conditional build:
5 %bcond_without  trial           # build from full tarball
6
7 %define         rel     0.4
8 Summary:        Web debugging proxy application
9 Name:           charles
10 Version:        3.5.2
11 Release:        %{rel}
12 License:        Proprietary, not distributable
13 Group:          Networking/Daemons
14 Source0:        http://www.charlesproxy.com/assets/release/%{version}/%{name}.tar.gz
15 # NoSource0-md5:        49498a331ae53fc1bb02c21d8bcd3be9
16 NoSource:       0
17 Source1:        %{name}.sh
18 URL:            http://www.charlesproxy.com/
19 BuildRequires:  rpm-javaprov
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 Requires:       java(jaf)
22 Requires:       java-oro >= 1.4
23 Requires:       jpackage-utils
24 Requires:       jre-X11 >= 1.4
25 ExclusiveArch:  i586 i686 pentium3 pentium4 athlon %{x8664}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # already stripped
29 %define         _enable_debug_packages  0
30
31 %description
32 Charles is an HTTP proxy / HTTP monitor / Reverse Proxy that enables a
33 developer to view all of the HTTP and SSL / HTTPS traffic between
34 their machine and the Internet. This includes requests, responses and
35 the HTTP headers (which contain the cookies and caching information).
36
37 %prep
38 %setup -q -n %{name}
39
40 install -p %{SOURCE1} .
41 %if "%{_lib}" != "lib"
42 %{__sed} -i -e 's,/usr/lib,%{_libdir},' %{name}.sh
43 %endif
44
45 rm lib/jakarta-oro-2.0.8.jar
46 rm lib/activation.jar
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_javadir}/%{name},%{_libdir}/%{name},%{_bindir}}
51
52 cp -a lib/*.jar $RPM_BUILD_ROOT%{_javadir}/%{name}
53 %ifarch %{ix86}
54 install -p lib/*.so $RPM_BUILD_ROOT%{_libdir}/%{name}
55 %endif
56 install -p %{name}.sh $RPM_BUILD_ROOT%{_bindir}/%{name}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{_bindir}/%{name}
64 %{_javadir}/%{name}
65 %ifarch %{ix86}
66 %dir %{_libdir}/%{name}
67 %attr(755,root,root) %{_libdir}/%{name}/libjdic.so
68 %endif
This page took 0.073907 seconds and 3 git commands to generate.