]> git.pld-linux.org Git - packages/changepassword.git/blob - changepassword.spec
- revert illegal use of sysconfdir macro
[packages/changepassword.git] / changepassword.spec
1 # TODO
2 # - webapps
3 # - move cgi binary to /usr/share/changepassword
4 # - write changepassword.conf for apache redirection + execution
5 # - get sources for libdes and compile then instead of using
6 #   precompiled version for x86!!!
7 #
8 # Conditional build:
9 %bcond_without  samba   # without samba passwords support
10 %bcond_without  squid   # without squid passwords support
11 #
12 Summary:        ChangePassword
13 Summary(pl.UTF-8):      ChangePassword - modyfikator haseł
14 Name:           changepassword
15 Version:        0.9
16 Release:        2
17 License:        GPL
18 Group:          Networking/Admin
19 Source0:        http://dl.sourceforge.net/changepassword/%{name}-%{version}.tar.gz
20 # Source0-md5:  7449a80c65db2e37c0aa3bb709926127
21 Source1:        pldlogo.png
22 URL:            http://changepassword.sourceforge.net/
23 Requires:       webserver = apache
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _cgidir         /home/services/httpd/cgi-bin
27
28 %description
29 ChangePassword modifies the passwords of passwd, Samba, and Squid
30 through the Web. All passwords are syncronized and changed in real
31 time through browsers like Mozilla, Netscape, IE, Opera, and others.
32
33 %description -l pl.UTF-8
34 ChangePassword modyfikuje hasła dla passwd, Samby i Squida za
35 pośrednictwem interfejsu WWW. Wszystkie hasła są synchronizowane i
36 zmieniane w trybie rzeczywistym.
37
38 %prep
39 %setup -q
40 cp %{SOURCE1} .
41
42 %build
43 %configure \
44         --enable-cgidir=%{_cgidir} \
45         --enable-language=Polish \
46         --enable-logo=pldlogo.png \
47         --enable-smbpasswd=/etc/samba/smbpasswd \
48         --enable-squidpasswd=/etc/squid/passwd \
49 %if %{without samba}
50         --disable-smbpasswd \
51 %endif
52 %if %{without squid}
53         --disable-squidpasswd
54 %endif
55
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_cgidir}
61 install -d $RPM_BUILD_ROOT/home/services/httpd/html
62
63 install changepassword.cgi $RPM_BUILD_ROOT%{_cgidir}
64 install %{SOURCE1} $RPM_BUILD_ROOT/home/services/httpd/html
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc BUGS CHANGELOG README TODO
72 %lang(pt_BR) %doc README.brazilian
73 %attr(755,root,root) %{_cgidir}/changepassword.cgi
74 /home/services/httpd/html/pldlogo.png
This page took 0.102213 seconds and 3 git commands to generate.