]> git.pld-linux.org Git - packages/cgilib.git/blob - cgilib.spec
- spaces->tabs
[packages/cgilib.git] / cgilib.spec
1 Summary:        A CGI (Common Gateway Interface) library for C++
2 Summary(pl):    Biblioteka CGI dla C++
3 Name:           cgilib
4 Version:        0.1.1
5 Release:        2
6 License:        GPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/cgilib/%{name}-%{version}.tar.bz2
9 # Source0-md5:  961308218b6e19ed98aacfd397a0f062
10 Patch0:         %{name}-misc.patch
11 Patch1:         %{name}-am_ac.patch
12 Patch2:         %{name}-gcc3.patch
13 URL:            http://cgilib.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 cgilib is a library for programming CGIs (Common Gateway Interface,
22 most commonly used for server-side web page scripting) in C++
23
24 %description -l pl
25 cgilib jest bibliotek± do programowania CGI (Common Gateway Interface,
26 najbardziej popularny sposób uruchamiania skryptów po stronie serwera
27 WWW) napisan± w C++.
28
29 %package devel
30 Summary:        Header files and develpment documentation for cgilib
31 Summary(pl):    Pliki nag³ówkowe oraz dokumentacja developerska dla cgilib
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}
34
35 %description devel
36 Header files and develpment documentation for cgilib.
37
38 %description devel -l pl
39 Pliki nag³ówkowe oraz dokumentacja developerska dla cgilib.
40
41 %package static
42 Summary:        Static cgilib library
43 Summary(pl):    Biblioteka statyczna cgilib
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}
46
47 %description static
48 Static cgilib library.
49
50 %description static -l pl
51 Biblioteka statyczna cgilib.
52
53 %prep
54 %setup -q
55 %patch0 -p1
56 %patch1 -p1
57 %patch2 -p1
58
59 %build
60 rm -f *.m4 missing
61 %{__libtoolize}
62 %{__aclocal}
63 %{__autoconf}
64 %{__automake}
65 %configure \
66         --enable-static
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS NEWS
84 %attr(755,root,root) %{_libdir}/lib*.so.*.*
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/lib*.so
89 %{_libdir}/lib*.la
90 %{_includedir}/cgilib
91
92 %files static
93 %defattr(644,root,root,755)
94 %{_libdir}/lib*.a
This page took 0.058192 seconds and 3 git commands to generate.