]> git.pld-linux.org Git - packages/cgi.tcl.git/blob - cgi.tcl.spec
- 1.8.0 - STBR
[packages/cgi.tcl.git] / cgi.tcl.spec
1 Summary:        Tool Command Language embeddable scripting language, with shared libraries
2 Summary(pl):    Tool Command Language - jêzyk skryptowy z bibliotekami dynamicznymi
3 Name:           cgi.tcl
4 %define         _mainver        1.8
5 Version:        1.8.0
6 Release:        1
7 License:        Public Domain
8 Group:          Development/Languages/Tcl
9 Source0:        http://expect.nist.gov/%{name}/%{name}.tar.gz
10 Patch0:         %{name}-DESTDIR.patch
11 URL:            http://expect.nist.gov/cgi.tcl/
12 BuildRequires:  autoconf
13 Requires:       tcl
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _packagedir     %{_libdir}/tcl8.3/cgi%{_mainver}
17
18 %description
19 cgi.tcl is the CGI support library for Tcl programmers. The library is
20 very thorough - it supports forms, tables, cookies, file upload,
21 plug-ins, JavaScript, Netscape extensions, etc, etc. It also provides
22 very convenient support for debugging and handling CGI errors. cgi.tcl
23 can also be used for generating static HTML. This enables you to get
24 programming features into HTML, such as variables, if/then/else, file
25 I/O, etc. For example, HTML lacks variables so if you repeatedly use a
26 link on a page and one day the link changes, you've got to update
27 every use of the link, possibly on hundreds of pages. By storing the
28 link in a Tcl variable, you can just change the one place where the
29 variable is defined. This makes maintenance much easier. This is just
30 a tiny example of the benefits cgi.tcl provides.
31
32 %description -l pl
33 cgi.tcl to biblioteka obs³ugi CGI dla programistów Tcl. Biblioteka ma
34 du¿± funkcjonalno¶æ - obs³uguje formularze, tablelki, ciasteczka,
35 upload plików, wtyczki, JavaScript, rozszerzenia Netscape itp.
36 Udostêpnia tak¿e bardzo wygodne wsparcie dla odpluskwiania i obs³ugi
37 b³êdów CGI. cgi.tcl mo¿e byæ u¿ywane tak¿e do generowania statycznego
38 HTML-a. Pozwala to na umieszczanie w HTML elementów programów w HTML,
39 takich jak zmienne, if/then/else, operacje na plikach itp. Na
40 przyk³ad, HTML nie ma zmiennych, wiêc je¶li u¿ywa siê tego samego
41 odno¶nika wielokrotnie na stronie, i w pewnym momencie on siê zmienia,
42 trzeba uaktualniæ ka¿de u¿ycie tego odno¶nika, byæ mo¿e na setkach
43 stron. Dziêki zapisaniu odno¶nika w zmiennej Tcl, wystarczy zmieniæ
44 tylko to miejsce, gdzie zmienna jest zdefiniowana. Znacznie u³atwia to
45 utrzymywanie stron. Jest to tylko ma³y przyk³ad zalet cgi.tcl.
46
47 %prep
48 %setup  -q -n %{name}-%{_mainver}
49 %patch0 -p1
50
51 %build
52 %{__autoconf}
53 %configure
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         SCRIPTDIR=%{_packagedir} \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc HISTORY README doc/*.txt example
70 %attr(644,root,root) %{_packagedir}/*.tcl
71 %{_mandir}/man3/*
This page took 0.033178 seconds and 3 git commands to generate.