]> git.pld-linux.org Git - packages/cfitsio.git/blob - cfitsio.spec
- updated to 3.250
[packages/cfitsio.git] / cfitsio.spec
1 Summary:        CFITSIO Interface Library
2 Summary(pl.UTF-8):      Biblioteka interfejsu CFITSIO
3 Name:           cfitsio
4 Version:        3.250
5 %define sver    %(echo %{version} | tr -d .)
6 Release:        1
7 License:        GPL (forced only by gzip code, basically BSD-like)
8 Group:          Libraries
9 Source0:        ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/%{name}%{sver}.tar.gz
10 # Source0-md5:  1e6e390f21fab4e04781156fddcd2f8b
11 Patch0:         %{name}-link.patch
12 Patch1:         %{name}-ldflags.patch
13 Patch2:         %{name}-compress.patch
14 URL:            http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
15 BuildRequires:  gcc-g77
16 BuildRequires:  sed >= 4.0
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 CFITSIO is a library of ANSI C routines for reading and writing FITS
21 format data files.  A set of Fortran-callable wrapper routines are
22 also included for the convenience of Fortran programmers.
23
24 %description -l pl.UTF-8
25 CFITSIO to biblioteka funkcji w C do odczytu i zapisu plików z danymi
26 w formacie FITS. Zawiera także zestaw wrapperów pozwalających na
27 wywoływanie tych funkcji z programów w Fortranie.
28
29 %package devel
30 Summary:        Header files and documentation for CFITSIO
31 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do CFITSIO
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files and development documentation for CFITSIO.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe i dokumentacja programisty do CFITSIO.
40
41 %package static
42 Summary:        Static CFITSIO library
43 Summary(pl.UTF-8):      Statyczna biblioteka CFITSIO
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static version of CFITSIO library.
49
50 %description static -l pl.UTF-8
51 Statyczna wersja biblioteki CFITSIO.
52
53 %prep
54 %setup -q -n %{name}
55 %patch0 -p1
56 %patch1 -p0
57 %patch2 -p0
58
59 sed -i -e 's/ f77 xlf / gfortran f77 xlf /' configure
60
61 %build
62 %configure
63
64 %{__make} shared
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
69
70 %{__make} install \
71         CFITSIO_LIB=$RPM_BUILD_ROOT%{_libdir} \
72         CFITSIO_INCLUDE=$RPM_BUILD_ROOT%{_includedir}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc License.txt README changes.txt
83 %attr(755,root,root) %{_libdir}/libcfitsio.so
84
85 %files devel
86 %defattr(644,root,root,755)
87 %doc cfitsio.doc cfitsio.ps fitsio.doc fitsio.ps quick.ps
88 %{_includedir}/drvrsmem.h
89 %{_includedir}/fitsio*.h
90 %{_includedir}/longnam.h
91 %{_pkgconfigdir}/cfitsio.pc
92
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/libcfitsio.a
This page took 0.065843 seconds and 3 git commands to generate.