]> git.pld-linux.org Git - packages/cfitsio.git/blob - cfitsio.spec
- added link patch, release 2
[packages/cfitsio.git] / cfitsio.spec
1 Summary:        CFITSIO Interface Library
2 Summary(pl):    Biblioteka interfejsu CFITSIO
3 Name:           cfitsio
4 Version:        3.020
5 %define sver    %(echo %{version} | tr -d .)
6 Release:        2
7 License:        GPL (forced only by gzip code, basically BSD-like)
8 Group:          Libraries
9 Source0:        ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/%{name}%{sver}.tar.gz
10 # Source0-md5:  fbc9e0db4d4b48b0a6a8de0f2036eb47
11 Patch0:         %{name}-link.patch
12 URL:            http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
13 BuildRequires:  gcc-g77
14 BuildRequires:  sed >= 4.0
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 CFITSIO is a library of ANSI C routines for reading and writing FITS
19 format data files.  A set of Fortran-callable wrapper routines are
20 also included for the convenience of Fortran programmers.
21
22 %description -l pl
23 CFITSIO to biblioteka funkcji w C do odczytu i zapisu plików z danymi
24 w formacie FITS. Zawiera tak¿e zestaw wrapperów pozwalaj±cych na
25 wywo³ywanie tych funkcji z programów w Fortranie.
26
27 %package devel
28 Summary:        Header files and documentation for CFITSIO
29 Summary(pl):    Pliki nag³ówkowe i dokumentacja do CFITSIO
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Header files and development documentation for CFITSIO.
35
36 %description devel -l pl
37 Pliki nag³ówkowe i dokumentacja programisty do CFITSIO.
38
39 %package static
40 Summary:        Static CFITSIO library
41 Summary(pl):    Statyczna biblioteka CFITSIO
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static version of CFITSIO library.
47
48 %description static -l pl
49 Statyczna wersja biblioteki CFITSIO.
50
51 %prep
52 %setup -q -n %{name}
53 %patch0 -p1
54
55 sed -i -e 's/ f77 xlf / gfortran f77 xlf /' configure
56
57 %build
58 %configure2_13
59
60 %{__make} shared
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
65
66 %{__make} install \
67         CFITSIO_LIB=$RPM_BUILD_ROOT%{_libdir} \
68         CFITSIO_INCLUDE=$RPM_BUILD_ROOT%{_includedir}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %doc License.txt README changes.txt
79 %attr(755,root,root) %{_libdir}/libcfitsio.so
80
81 %files devel
82 %defattr(644,root,root,755)
83 %doc cfitsio.doc cfitsio.ps fitsio.doc fitsio.ps quick.ps
84 %{_includedir}/*.h
85 %{_pkgconfigdir}/cfitsio.pc
86
87 %files static
88 %defattr(644,root,root,755)
89 %{_libdir}/libcfitsio.a
This page took 0.084126 seconds and 3 git commands to generate.