]> git.pld-linux.org Git - packages/cfg.git/blob - cfg.spec
c4035d1b3c1c60849b36806c4853252ca6d61edf
[packages/cfg.git] / cfg.spec
1 # TODO: resolve conflict with libcfg+-devel - header files
2 #       has the same name.
3 # NOTE: API is NOT documented
4 Summary:        OSSP cfg - Configuration Parsing
5 Summary(pl):    OSSP cfg - parsowanie konfiguracji
6 Name:           cfg
7 Version:        0.9.4
8 Release:        0.1
9 Epoch:          0
10 License:        distributable (see README)
11 Group:          Libraries
12 Source0:        ftp://ftp.ossp.org/pkg/lib/cfg/%{name}-%{version}.tar.gz
13 # Source0-md5:  a41ac64a92a55030f44e307cc5461657
14 URL:            http://www.ossp.org/pkg/lib/cfg/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  bison
18 BuildRequires:  flex    
19 BuildRequires:  libtool
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 OSSP cfg is a ISO-C library for parsing arbitrary C/C++-style
24 configuration files. A configuration is sequence of directives. Each
25 directive consists of zero or more tokens. Each token can be either a
26 string or again a complete sequence. This means the configuration
27 syntax has a recursive structure and this way allows to create
28 configurations with arbitrarily nested sections.
29
30 Additionally the configuration syntax provides complex
31 single/double/balanced quoting of tokens, hexadecimal/octal/decimal
32 character encodings, character escaping, C/C++ and Shell-style
33 comments, etc. The library API allows importing a configuration text
34 into an Abstract Syntax Tree (AST), traversing the AST and optionally
35 exporting the AST again as a configuration text.
36
37 %description -l pl
38 OSSP cfg to biblioteka ISO-C do parsowania dowolnych plików
39 konfiguracyjnych w stylu C/C++. Konfiguracja jest sekwencj± dyrektyw.
40 Ka¿da dyrektywa zawiera zero lub wiêcej tokenów. Ka¿dy token mo¿e byæ
41 ³añcuchem albo znowu ca³± sekwencj±. Oznacza to, ¿e sk³adnia
42 konfiguracji ma strukturê rekurencyjn±, co pozwala tworzyæ
43 konfiguracje z dowolnie zagnie¿d¿onymi sekcjami.
44
45 Sk³adnia konfiguracji udostêpnia dodatkowo z³o¿one
46 pojedyncze/podwójne/zrównowa¿one cytowanie tokenów,
47 szesnastkowe/ósemkowe/dziesiêtne kodowanie znaków, cytowanie znaków,
48 komentarze w stylu C/C++ i pow³oki itp. API biblioteki umo¿liwia
49 importowanie tekstu konfiguracji do abstrakcyjnych drzew sk³adniowych
50 (AST), przechodzenie po AST i opcjonalnie eksportowanie AST z powrotem
51 do tekstu konfiguracji.
52
53 %package devel
54 Summary:        OSSP cfg - Configuration Parsing - header files and development libraries
55 Summary(pl):    OSSP cfg - parsowanie konfiguracji - pliki nag³ówkowe i biblioteki dla deweloperów
56 Group:          Development/Libraries
57 Requires:       %{name} = %{epoch}:%{version}-%{release}
58
59 %description devel
60 OSSP cfg - Configuration Parsing - header files and development
61 libraries.
62
63 %description devel -l pl
64 OSSP cfg - parsowanie konfiguracji - pliki nag³ówkowe i biblioteki dla
65 deweloperów.
66
67 %package static
68 Summary:        OSSP cfg - Configuration Parsing - static libraries
69 Summary(pl):    OSSP cfg - parsowanie konfiguracji - biblioteki statyczne
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 OSSP cfg - Configuration Parsing - static libraries.
75
76 %description static -l pl
77 OSSP cfg - parsowanie konfiguracji - biblioteki statyczne.
78
79 %prep
80 %setup -q
81
82 %build
83 mv -f aclocal.m4 acinclude.m4
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %configure
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS ChangeLog HACKING README THANKS TODO
105 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_bindir}/*
110 %attr(755,root,root) %{_libdir}/lib*.so
111 %{_libdir}/lib*.la
112 %{_includedir}/*
113 %{_mandir}/man3/*
114
115 %files static
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/lib*.a
This page took 0.061372 seconds and 2 git commands to generate.