]> git.pld-linux.org Git - packages/ceph.git/commitdiff
- up to 17.2.3
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 25 Aug 2022 04:25:36 +0000 (06:25 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 25 Aug 2022 04:25:36 +0000 (06:25 +0200)
- updated fio,types patches

ceph-fio.patch
ceph.spec
types.patch

index ed10f6d401701a8b435dbcd9ba019db879116893..3688c427777684ef99603c51aa7f986b2ef4697c 100644 (file)
@@ -1,7 +1,7 @@
---- ceph-16.2.9/src/test/fio/CMakeLists.txt.orig       2022-05-18 21:51:52.000000000 +0200
-+++ ceph-16.2.9/src/test/fio/CMakeLists.txt    2022-06-14 18:58:25.354554233 +0200
-@@ -35,11 +35,11 @@ if(WITH_FIO)
endif()
+--- ceph-17.2.2/src/test/fio/CMakeLists.txt.orig       2022-05-18 21:51:52.000000000 +0200
++++ ceph-17.2.2/src/test/fio/CMakeLists.txt    2022-06-14 18:58:25.354554233 +0200
+@@ -11,11 +11,11 @@ add_library(fio_librgw SHARED fio_librgw
target_link_libraries(fio_librgw rgw fio)
  
  target_link_libraries(fio_ceph_objectstore os global)
 -install(TARGETS fio_ceph_objectstore DESTINATION lib)
index 3ea7edc4982a208c1324ed88dc64ab74abab215f..e31c82bd299fe7af82facc18702dc74015a002d8 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
 Summary:       User space components of the Ceph file system
 Summary(pl.UTF-8):     Działające w przestrzeni użytkownika elementy systemu plików Ceph
 Name:          ceph
-Version:       17.2.2
+Version:       17.2.3
 Release:       1
 License:       LGPL v2.1 (libraries), GPL v2 (some programs)
 Group:         Base
 Source0:       http://download.ceph.com/tarballs/%{name}-%{version}.tar.gz
-# Source0-md5: 739ca7bdbdb6463db94e869ad78826d7
+# Source0-md5: 96f10fa942ec0db4008993cddaec88ec
 Source1:       ceph.sysconfig
 Source3:       ceph.tmpfiles
 Patch0:                %{name}-python.patch
@@ -117,9 +117,10 @@ BuildRequires:     perl-base
 BuildRequires: pkgconfig
 %{?with_pmem:BuildRequires:    pmdk-devel >= 1.10.0}
 BuildRequires: python3 >= 1:3.2
+BuildRequires: python3-Cython
+BuildRequires: python3-PyYAML
 BuildRequires: python3-devel >= 1:3.2
 %{?with_tests:BuildRequires:   python3-tox >= 2.9.1}
-BuildRequires: python3-Cython
 BuildRequires: rabbitmq-c-devel
 %{?with_system_rocksdb:BuildRequires:  rocksdb-devel >= 5.14}
 BuildRequires: rpmbuild(macros) >= 1.671
@@ -127,6 +128,8 @@ BuildRequires:      sed >= 4.0
 BuildRequires: snappy-devel
 BuildRequires: sphinx-pdg >= 4.4.0
 BuildRequires: sqlite3-devel >= 3
+# >= 0.13.0 wanted, but seems to build with 0.11.0
+BuildRequires: thrift-devel
 BuildRequires: udev-devel
 %{?with_dpdk:BuildRequires:    xorg-lib-libpciaccess-devel}
 BuildRequires: xfsprogs-devel
@@ -377,6 +380,9 @@ cd build
        %{!?with_tests:-DWITH_TESTS=OFF} \
        %{?with_zfs:-DWITH_ZFS=ON}
 
+# some object files have missing dependencies on these, pregenerate to avoid global -j1
+%{__make} legacy-option-headers
+
 %{__make}
 
 %install
index 5427d9f75d73bd10277a75e186628fe6ba67156f..34515e2bd534711c59e304c8aedb3fcab8bc34bf 100644 (file)
        for (auto &[peer, peer_replayer] : m_peer_replayers) {
          dout(10) << ": peer=" << peer << dendl;
          peer_replayer->remove_directory(dir_path);
+--- ceph-17.2.2/src/os/bluestore/BlueStore.cc.orig     2022-07-21 19:29:33.000000000 +0200
++++ ceph-17.2.2/src/os/bluestore/BlueStore.cc  2022-08-23 16:55:10.753944515 +0200
+@@ -18583,7 +18583,7 @@ int BlueStore::__restore_allocator(Alloc
+   uint64_t        extent_count       = 0;
+   uint64_t        extents_bytes_left = file_size - (header_size + trailer_size + sizeof(crc));
+   while (extents_bytes_left) {
+-    int req_bytes  = std::min(extents_bytes_left, sizeof(buffer));
++    uint64_t req_bytes  = std::min<uint64_t>(extents_bytes_left, sizeof(buffer));
+     int read_bytes = bluefs->read(p_handle.get(), offset, req_bytes, nullptr, (char*)buffer);
+     if (read_bytes != req_bytes) {
+       derr << "Failed bluefs->read()::read_bytes=" << read_bytes << ", req_bytes=" << req_bytes << dendl;
+--- ceph-17.2.2/src/rgw/store/dbstore/sqlite/sqliteDB.cc.orig  2022-07-21 19:29:33.000000000 +0200
++++ ceph-17.2.2/src/rgw/store/dbstore/sqlite/sqliteDB.cc       2022-08-24 06:15:01.162110603 +0200
+@@ -514,8 +514,10 @@ static int list_lc_head(const DoutPrefix
+   op.lc_head.index = (const char*)sqlite3_column_text(stmt, LCHeadIndex);
+   op.lc_head.head.marker = (const char*)sqlite3_column_text(stmt, LCHeadMarker);
+- 
+-  SQL_DECODE_BLOB_PARAM(dpp, stmt, LCHeadStartDate, op.lc_head.head.start_date, sdb);
++
++  { int64_t start_date;
++  SQL_DECODE_BLOB_PARAM(dpp, stmt, LCHeadStartDate, start_date, sdb);
++  op.lc_head.head.start_date = start_date; }
+   return 0;
+ }
+@@ -2773,7 +2775,8 @@ int SQLInsertLCHead::Bind(const DoutPref
+   SQL_BIND_TEXT(dpp, stmt, index, params->op.lc_head.head.marker.c_str(), sdb);
+   SQL_BIND_INDEX(dpp, stmt, index, p_params.op.lc_head.start_date.c_str(), sdb);
+-  SQL_ENCODE_BLOB_PARAM(dpp, stmt, index, params->op.lc_head.head.start_date, sdb);
++  { int64_t start_date = params->op.lc_head.head.start_date;
++  SQL_ENCODE_BLOB_PARAM(dpp, stmt, index, start_date, sdb); }
+ out:
+   return rc;
This page took 1.454272 seconds and 4 git commands to generate.