]> git.pld-linux.org Git - packages/ceph.git/commitdiff
- updated to 17.2.5 auto/th/ceph-17.2.5-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 Mar 2023 05:29:19 +0000 (06:29 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 Mar 2023 05:29:19 +0000 (06:29 +0100)
ceph-gcc12.patch
ceph-libfmt.patch
ceph.spec

index 7e4f116cf9888e1a68717976c3bcc98e1946f54c..4440750f58f4930f6baf6cac16682daafca1ffcb 100644 (file)
    }
  }
  
---- ceph-16.2.7/src/common/dout.h.orig 2022-01-18 08:58:11.805226954 -0500
-+++ ceph-16.2.7/src/common/dout.h      2022-01-19 08:06:23.987388663 -0500
-@@ -99,11 +99,15 @@
- template<typename T>
- struct dynamic_marker_t {
-   T value;
--  operator T() const { return value; }
-+  // constexpr ctor isn't needed as it's an aggregate type
-+  constexpr operator T() const { return value; }
- };
- template<typename T>
--dynamic_marker_t<T> need_dynamic(T&& t) {
-+constexpr dynamic_marker_t<T> need_dynamic(T&& t) {
-+  // deprecated in C++17 but that's fine for testing
-+  static_assert(std::is_literal_type_v<T>);
-+  static_assert(std::is_literal_type_v<dynamic_marker_t<T>>);
-   return dynamic_marker_t<T>{ std::forward<T>(t) };
- }
 --- ceph-16.2.7/src/test/librados/tier_cxx.cc.orig     2022-01-19 09:30:47.209459506 -0500
 +++ ceph-16.2.7/src/test/librados/tier_cxx.cc  2022-01-19 10:02:47.783240298 -0500
 @@ -114,7 +114,7 @@
index 72fabc92e771940853b5494c5030fa7340bba8f1..705358b8e34a582fd48ab6487c29b49f8d6c98c8 100644 (file)
  #include "crimson/admin/admin_socket.h"
  #include "crimson/common/log.h"
  #include "crimson/osd/exceptions.h"
-@@ -299,7 +300,7 @@ static ghobject_t test_ops_get_object_na
-       // the return type of `fmt::format` is `std::string`
-       using namespace fmt::literals;
-       throw std::invalid_argument{
--        "Invalid pool '{}'"_format(*pool_arg)
-+      fmt::format("Invalid pool '{}'", *pool_arg)
-       };
-     }
-     return pool;
 --- ceph-17.2.3/src/crimson/admin/pg_commands.cc.orig  2022-07-28 23:52:12.000000000 +0200
 +++ ceph-17.2.3/src/crimson/admin/pg_commands.cc       2022-09-14 20:59:47.803920736 +0200
 @@ -13,6 +13,7 @@
              return seastar::now();
            });
          }).si_then([&ret] {
---- ceph-17.2.3/src/mon/LogMonitor.cc.orig     2022-07-28 23:52:12.000000000 +0200
-+++ ceph-17.2.3/src/mon/LogMonitor.cc  2022-09-04 17:59:19.765987645 +0200
+--- ceph-17.2.5/src/mon/LogMonitor.cc.orig     2023-03-22 06:45:27.743273749 +0100
++++ ceph-17.2.5/src/mon/LogMonitor.cc  2023-03-22 06:25:06.412142157 +0100
 @@ -415,7 +415,7 @@ void LogMonitor::log_external(const LogE
      }
  
      if (fd >= 0) {
--      fmt::format_to(file_log_buffer, "{}\n", le);
+-      fmt::format_to(std::back_inserter(file_log_buffer), "{}\n", le);
 +      fmt::format_to(std::back_inserter(file_log_buffer), "{}\n", fmt::streamed(le));
        int err = safe_write(fd, file_log_buffer.data(), file_log_buffer.size());
        file_log_buffer.clear();
 +
 +template <>
 +struct fmt::formatter<entity_addrvec_t> : ostream_formatter {};
---- ceph-17.2.3/src/osd/osd_types_fmt.h.orig   2022-07-28 23:52:12.000000000 +0200
-+++ ceph-17.2.3/src/osd/osd_types_fmt.h        2022-09-14 16:25:21.495245277 +0200
-@@ -104,3 +104,21 @@ struct fmt::formatter<object_info_t> {
-     return fmt::format_to(ctx.out(), ")");
+--- ceph-17.2.5/src/osd/osd_types_fmt.h.orig   2023-03-22 06:45:27.893272937 +0100
++++ ceph-17.2.5/src/osd/osd_types_fmt.h        2023-03-22 06:26:17.049743254 +0100
+@@ -115,3 +115,18 @@ struct fmt::formatter<pg_t> {
+     return fmt::format_to(ctx.out(), "{}.{:x}", pg.pool(), pg.m_seed);
    }
  };
 +
 +struct fmt::formatter<pg_history_t> : ostream_formatter {};
 +
 +template <>
-+struct fmt::formatter<pg_t> : ostream_formatter {};
-+
-+template <>
 +struct fmt::formatter<spg_t> : ostream_formatter {};
 +
 +template <>
index e2c7a1f12a176f10f6e2f6f7e43ac1469e19eb82..ca3f74435606c08b747aee59b47fdd1c110808f6 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
 Summary:       User space components of the Ceph file system
 Summary(pl.UTF-8):     Działające w przestrzeni użytkownika elementy systemu plików Ceph
 Name:          ceph
-Version:       17.2.3
-Release:       4
+Version:       17.2.5
+Release:       1
 License:       LGPL v2.1 (libraries), GPL v2 (some programs)
 Group:         Base
 Source0:       http://download.ceph.com/tarballs/%{name}-%{version}.tar.gz
-# Source0-md5: 96f10fa942ec0db4008993cddaec88ec
+# Source0-md5: e331cea04680ea8ff982a58c516d7611
 Source1:       ceph.sysconfig
 Source3:       ceph.tmpfiles
 Patch0:                %{name}-python.patch
@@ -527,6 +527,7 @@ fi
 %attr(755,root,root) %{_bindir}/ceph-dencoder
 %attr(755,root,root) %{_bindir}/ceph-diff-sorted
 %attr(755,root,root) %{_bindir}/ceph-erasure-code-tool
+%attr(755,root,root) %{_bindir}/ceph-exporter
 %attr(755,root,root) %{_bindir}/ceph-immutable-object-cache
 %attr(755,root,root) %{_bindir}/ceph-kvstore-tool
 %attr(755,root,root) %{_bindir}/ceph-mds
This page took 0.207426 seconds and 4 git commands to generate.