]> git.pld-linux.org Git - packages/ceph.git/commitdiff
fix build with boost 1.81 (from gentoo)
authorJan Palus <atler@pld-linux.org>
Sat, 18 Feb 2023 17:27:59 +0000 (18:27 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 18 Feb 2023 17:27:59 +0000 (18:27 +0100)
boost1.81.patch [new file with mode: 0644]
ceph.spec

diff --git a/boost1.81.patch b/boost1.81.patch
new file mode 100644 (file)
index 0000000..2dd06ed
--- /dev/null
@@ -0,0 +1,49 @@
+https://bugs.gentoo.org/887481
+--- a/src/rgw/rgw_asio_client.cc
++++ b/src/rgw/rgw_asio_client.cc
+@@ -39,11 +39,11 @@
+     const auto& value = header->value();
+     if (field == beast::http::field::content_length) {
+-      env.set("CONTENT_LENGTH", value.to_string());
++      env.set("CONTENT_LENGTH", value);
+       continue;
+     }
+     if (field == beast::http::field::content_type) {
+-      env.set("CONTENT_TYPE", value.to_string());
++      env.set("CONTENT_TYPE", value);
+       continue;
+     }
+@@ -62,26 +62,26 @@
+     }
+     *dest = '\0';
+-    env.set(buf, value.to_string());
++    env.set(buf, value);
+   }
+   int major = request.version() / 10;
+   int minor = request.version() % 10;
+   env.set("HTTP_VERSION", std::to_string(major) + '.' + std::to_string(minor));
+-  env.set("REQUEST_METHOD", request.method_string().to_string());
++  env.set("REQUEST_METHOD", request.method_string());
+   // split uri from query
+   auto uri = request.target();
+   auto pos = uri.find('?');
+   if (pos != uri.npos) {
+     auto query = uri.substr(pos + 1);
+-    env.set("QUERY_STRING", query.to_string());
++    env.set("QUERY_STRING", query);
+     uri = uri.substr(0, pos);
+   }
+-  env.set("SCRIPT_URI", uri.to_string());
++  env.set("SCRIPT_URI", uri);
+-  env.set("REQUEST_URI", request.target().to_string());
++  env.set("REQUEST_URI", request.target());
+   char port_buf[16];
+   snprintf(port_buf, sizeof(port_buf), "%d", local_endpoint.port());
index 27214e2ba3f128dd84a3b53ed01fd54179751dd8..81862152bc921632c78ef4dc834cf52eaa190a54 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
@@ -74,6 +74,7 @@ Patch14:      %{name}-system-rocksdb.patch
 Patch15:       %{name}-gcc12.patch
 # https://src.fedoraproject.org/rpms/ceph/blob/rawhide/f/0020-src-arrow-cpp-cmake_modules-ThirdpartyToolchain.cmake.patch
 Patch16:       %{name}-system-xsimd.patch
+Patch17:       boost1.81.patch
 URL:           https://ceph.io/
 %{?with_qatzip:BuildRequires:  QATzip-devel}
 %{?with_babeltrace:BuildRequires:      babeltrace-devel}
@@ -348,6 +349,7 @@ uruchamiania demonów.
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
+%patch17 -p1
 
 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' \
        src/{ceph-post-file.in,rbd-replay-many,rbdmap} \
This page took 0.328121 seconds and 4 git commands to generate.