]> git.pld-linux.org Git - packages/ceph.git/blobdiff - ceph.spec
boost rebuild
[packages/ceph.git] / ceph.spec
index c55b617918ffb6547a1e6048db43e86c9ad07bcb..6ebd038a32a91b9e6322ddc8b34d2409907a6a28 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
@@ -11,7 +11,7 @@
 %bcond_with    cryptopp        # use cryptopp instead of NSS crypto/SSL
 %bcond_with    dpdk            # DPDK messaging (requires cryptopp instead of nss)
 %bcond_without fcgi            # RADOS Gateway FCGI frontend
-%bcond_without fio             # FIO engines support
+%bcond_with    fio             # FIO engines support
 %bcond_without pmem            # PMDK (persistent memory) support
 %bcond_with    spdk            # Ceph SPDK support (DPDK based)
 %bcond_without system_rocksdb  # system RocksDB storage support
@@ -19,6 +19,7 @@
 %bcond_without lttng           # LTTng tracing
 %bcond_without babeltrace      # Babeltrace traces support
 %bcond_without tcmalloc        # tcmalloc allocator
+%bcond_with    tests           # build tests
 
 %ifarch x32
 %undefine      with_tcmalloc
@@ -34,7 +35,7 @@ Summary:      User space components of the Ceph file system
 Summary(pl.UTF-8):     Działające w przestrzeni użytkownika elementy systemu plików Ceph
 Name:          ceph
 Version:       12.2.13
-Release:       4
+Release:       10
 License:       LGPL v2.1 (libraries), GPL v2 (some programs)
 Group:         Base
 Source0:       http://download.ceph.com/tarballs/%{name}-%{version}.tar.gz
@@ -68,6 +69,7 @@ BuildRequires:        expat-devel >= 1.95
 BuildRequires: gdbm-devel
 %if %{with java}
 BuildRequires: jdk
+BuildRequires: jre-X11
 %endif
 BuildRequires: keyutils-devel
 BuildRequires: leveldb-devel >= 1.2
@@ -249,6 +251,18 @@ OCF Resource Agents for Ceph processes.
 %description resource-agents -l pl.UTF-8
 Agenci OCF do monitorowania procesów Cepha.
 
+%package test
+Summary:       Ceph benchmarks and test tools
+Summary(pl.UTF-8):     Narzędzia testowe oraz do mierzenia wydajności dla Ceph
+Group:         Applications/System
+Requires:      %{name} = %{version}-%{release}
+
+%description test
+Ceph benchmarks and test tools.
+
+%description test -l pl.UTF-8
+Narzędzia testowe oraz do mierzenia wydajności dla Ceph.
+
 %package -n fio-ceph-objectstore
 Summary:       FIO engine module for Ceph ObjectStore
 Summary(pl.UTF-8):     Moduł silnika FIO do używania Ceph ObjectStore
@@ -295,6 +309,7 @@ cd build
        -DSPHINX_BUILD=/usr/bin/sphinx-build-2 \
        %{!?with_babeltrace:-DWITH_BABELTRACE=OFF} \
        %{?with_java:-DWITH_CEPHFS_JAVA=ON} \
+       %{?with_java:-DJAVA_JVM_LIBRARY:PATH=%{_jvmdir}/java/lib/server/libjvm.so} \
        %{?with_dpdk:-DWITH_DPDK=ON} \
        %{?with_fio:-DWITH_FIO=ON} \
        %{!?with_lttng:-DWITH_LTTNG=OFF} \
@@ -309,7 +324,8 @@ cd build
        -DWITH_SYSTEMD=ON \
        %{?with_accelio:-DWITH_XIO=ON} \
        %{?with_zfs:-DWITH_ZFS=ON} \
-       -DWITH_REENTRANT_STRSIGNAL=ON
+       -DWITH_REENTRANT_STRSIGNAL=ON \
+       %{!?with_tests:-DWITH_TESTS=OFF}
 
 %{__make}
 
@@ -340,8 +356,10 @@ cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/ceph.conf
 %py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
 
+%if %{with tests}
 # tests
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/ceph_test_*
+%endif
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/sample.ceph.conf
 # cleanup
@@ -403,50 +421,21 @@ fi
 %attr(755,root,root) %{_bindir}/ceph-authtool
 %attr(755,root,root) %{_bindir}/ceph-bluestore-tool
 %attr(755,root,root) %{_bindir}/ceph-brag
-%attr(755,root,root) %{_bindir}/ceph-client-debug
 %attr(755,root,root) %{_bindir}/ceph-clsinfo
 %attr(755,root,root) %{_bindir}/ceph-conf
-%attr(755,root,root) %{_bindir}/ceph-coverage
 %attr(755,root,root) %{_bindir}/ceph-crush-location
-%attr(755,root,root) %{_bindir}/ceph-debugpack
 %attr(755,root,root) %{_bindir}/ceph-dencoder
 %attr(755,root,root) %{_bindir}/ceph-detect-init
-%attr(755,root,root) %{_bindir}/ceph-kvstore-tool
 %attr(755,root,root) %{_bindir}/ceph-mds
 %attr(755,root,root) %{_bindir}/ceph-mgr
 %attr(755,root,root) %{_bindir}/ceph-mon
-%attr(755,root,root) %{_bindir}/ceph-monstore-tool
 %attr(755,root,root) %{_bindir}/ceph-objectstore-tool
 %attr(755,root,root) %{_bindir}/ceph-osd
-%attr(755,root,root) %{_bindir}/ceph-osdomap-tool
 %attr(755,root,root) %{_bindir}/ceph-post-file
 %attr(755,root,root) %{_bindir}/ceph-rbdnamer
 %attr(755,root,root) %{_bindir}/ceph-rest-api
 %attr(755,root,root) %{_bindir}/ceph-run
 %attr(755,root,root) %{_bindir}/ceph-syn
-%attr(755,root,root) %{_bindir}/ceph_bench_log
-%attr(755,root,root) %{_bindir}/ceph_erasure_code
-%attr(755,root,root) %{_bindir}/ceph_erasure_code_benchmark
-%attr(755,root,root) %{_bindir}/ceph_kvstorebench
-%attr(755,root,root) %{_bindir}/ceph_multi_stress_watch
-%attr(755,root,root) %{_bindir}/ceph_objectstore_bench
-%attr(755,root,root) %{_bindir}/ceph_omapbench
-%attr(755,root,root) %{_bindir}/ceph_perf_local
-%attr(755,root,root) %{_bindir}/ceph_perf_msgr_client
-%attr(755,root,root) %{_bindir}/ceph_perf_msgr_server
-%attr(755,root,root) %{_bindir}/ceph_perf_objectstore
-%attr(755,root,root) %{_bindir}/ceph_psim
-%attr(755,root,root) %{_bindir}/ceph_radosacl
-%attr(755,root,root) %{_bindir}/ceph_rgw_jsonparser
-%attr(755,root,root) %{_bindir}/ceph_rgw_multiparser
-%attr(755,root,root) %{_bindir}/ceph_scratchtool
-%attr(755,root,root) %{_bindir}/ceph_scratchtoolpp
-%attr(755,root,root) %{_bindir}/ceph_smalliobench
-%attr(755,root,root) %{_bindir}/ceph_smalliobenchdumb
-%attr(755,root,root) %{_bindir}/ceph_smalliobenchfs
-%attr(755,root,root) %{_bindir}/ceph_smalliobenchrbd
-%attr(755,root,root) %{_bindir}/ceph_tpbench
-%attr(755,root,root) %{_bindir}/ceph_xattr_bench
 %attr(755,root,root) %{_bindir}/cephfs-data-scan
 %attr(755,root,root) %{_bindir}/cephfs-journal-tool
 %attr(755,root,root) %{_bindir}/cephfs-table-tool
@@ -474,7 +463,6 @@ fi
 %endif
 %{_libexecdir}/ceph/ceph_common.sh
 %attr(755,root,root) %{_libexecdir}/ceph/ceph-osd-prestart.sh
-%attr(755,root,root) %{_libdir}/ceph/ceph-monstore-update-crush.sh
 %{_libdir}/ceph/mgr
 %dir %{_libdir}/ceph/compressor
 %attr(755,root,root) %{_libdir}/ceph/compressor/libceph_lz4.so*
@@ -534,12 +522,10 @@ fi
 %{_mandir}/man8/ceph-clsinfo.8*
 %{_mandir}/man8/ceph-conf.8*
 %{_mandir}/man8/ceph-create-keys.8*
-%{_mandir}/man8/ceph-debugpack.8*
 %{_mandir}/man8/ceph-dencoder.8*
 %{_mandir}/man8/ceph-deploy.8*
 %{_mandir}/man8/ceph-detect-init.8*
 %{_mandir}/man8/ceph-disk.8*
-%{_mandir}/man8/ceph-kvstore-tool.8*
 %{_mandir}/man8/ceph-mds.8*
 %{_mandir}/man8/ceph-mon.8*
 %{_mandir}/man8/ceph-osd.8*
@@ -664,7 +650,6 @@ fi
 %attr(755,root,root) %ghost %{_libdir}/libcephfs_jni.so.1
 %attr(755,root,root) %{_libdir}/libcephfs_jni.so
 %{_javadir}/libcephfs.jar
-%{_javadir}/libcephfs-test.jar
 %endif
 
 %files fuse
@@ -691,6 +676,44 @@ fi
 %dir %{_prefix}/lib/ocf/resource.d/ceph
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/rbd
 
+%if %{with test}
+%files test
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ceph-client-debug
+%attr(755,root,root) %{_bindir}/ceph-coverage
+%attr(755,root,root) %{_bindir}/ceph-debugpack
+%attr(755,root,root) %{_bindir}/ceph-kvstore-tool
+%attr(755,root,root) %{_bindir}/ceph-monstore-tool
+%attr(755,root,root) %{_bindir}/ceph-osdomap-tool
+%attr(755,root,root) %{_bindir}/ceph_bench_log
+%attr(755,root,root) %{_bindir}/ceph_erasure_code
+%attr(755,root,root) %{_bindir}/ceph_erasure_code_benchmark
+%attr(755,root,root) %{_bindir}/ceph_kvstorebench
+%attr(755,root,root) %{_bindir}/ceph_multi_stress_watch
+%attr(755,root,root) %{_bindir}/ceph_objectstore_bench
+%attr(755,root,root) %{_bindir}/ceph_omapbench
+%attr(755,root,root) %{_bindir}/ceph_perf_local
+%attr(755,root,root) %{_bindir}/ceph_perf_msgr_client
+%attr(755,root,root) %{_bindir}/ceph_perf_msgr_server
+%attr(755,root,root) %{_bindir}/ceph_perf_objectstore
+%attr(755,root,root) %{_bindir}/ceph_psim
+%attr(755,root,root) %{_bindir}/ceph_radosacl
+%attr(755,root,root) %{_bindir}/ceph_rgw_jsonparser
+%attr(755,root,root) %{_bindir}/ceph_rgw_multiparser
+%attr(755,root,root) %{_bindir}/ceph_scratchtool
+%attr(755,root,root) %{_bindir}/ceph_scratchtoolpp
+%attr(755,root,root) %{_bindir}/ceph_smalliobench
+%attr(755,root,root) %{_bindir}/ceph_smalliobenchdumb
+%attr(755,root,root) %{_bindir}/ceph_smalliobenchfs
+%attr(755,root,root) %{_bindir}/ceph_smalliobenchrbd
+%attr(755,root,root) %{_bindir}/ceph_test_*
+%attr(755,root,root) %{_bindir}/ceph_tpbench
+%attr(755,root,root) %{_bindir}/ceph_xattr_bench
+%attr(755,root,root) %{_libdir}/ceph/ceph-monstore-update-crush.sh
+%{_mandir}/man8/ceph-debugpack.8*
+%{_mandir}/man8/ceph-kvstore-tool.8*
+%endif
+
 %if %{with fio}
 %files -n fio-ceph-objectstore
 %defattr(644,root,root,755)
This page took 0.061857 seconds and 4 git commands to generate.