]> git.pld-linux.org Git - packages/ceph.git/blobdiff - ceph.spec
- enhanced types patch wrt. unsigned 32-bit constant
[packages/ceph.git] / ceph.spec
index 9546e61f54feeebb7e485ddef234f9e30c3bc56a..173d32bf82d3e3f9a5d80aedd5256dd6c32ea0fe 100644 (file)
--- a/ceph.spec
+++ b/ceph.spec
 %bcond_with    accelio         # Accelio transport support [needs update for internal API changes]
 %bcond_with    cryptopp        # use cryptopp instead of NSS crypto/SSL
 %bcond_with    dpdk            # DPDK messaging (requires cryptopp instead of nss)
-%bcond_with    fcgi            # RADOS Gateway FCGI frontend
-%bcond_with    fio             # FIO engines support
+%bcond_without fcgi            # RADOS Gateway FCGI frontend
+%bcond_without fio             # FIO engines support
 %bcond_without pmem            # PMDK (persistent memory) support
 %bcond_with    spdk            # Ceph SPDK support (DPDK based)
 %bcond_without system_rocksdb  # system RocksDB storage support
-%bcond_with    zfs             # ZFS support [not ready for zfs 0.8.x]
+%bcond_without zfs             # ZFS support [not ready for zfs 0.8.x]
 %bcond_without lttng           # LTTng tracing
 %bcond_without babeltrace      # Babeltrace traces support
 %bcond_without tcmalloc        # tcmalloc allocator
@@ -50,10 +50,14 @@ Patch4:             %{name}-types.patch
 Patch5:                %{name}-tcmalloc.patch
 Patch6:                %{name}-rocksdb.patch
 Patch7:                %{name}-fcgi.patch
+Patch8:                %{name}-fio.patch
+Patch9:                %{name}-zfs.patch
+Patch10:       %{name}-includes.patch
 URL:           https://ceph.io/
 %{?with_accelio:BuildRequires: accelio-devel}
 %{?with_babeltrace:BuildRequires:      babeltrace-devel}
 BuildRequires: boost-devel >= 1.66
+BuildRequires: boost-python-devel >= 1.66
 BuildRequires: cmake >= 2.8.11
 %{?with_cryptopp:BuildRequires:        cryptopp-devel}
 BuildRequires: curl-devel
@@ -95,7 +99,9 @@ BuildRequires:        python >= 1:2.7
 BuildRequires: python-devel >= 1:2.7
 BuildRequires: python-Cython
 BuildRequires: python3-devel >= 1:3.2
-%{?with_rocksdb:BuildRequires: rocksdb-devel >= 3.0.0}
+BuildRequires: python3-Cython
+# upstream uses 3.0.0, rocksdb patch adjusts for 5.6.0 API change
+%{?with_system_rocksdb:BuildRequires:  rocksdb-devel >= 5.6.0}
 BuildRequires: rpmbuild(macros) >= 1.671
 BuildRequires: sed >= 4.0
 BuildRequires: snappy-devel
@@ -107,7 +113,8 @@ BuildRequires:      xfsprogs-devel
 %ifarch %{x8664}
 BuildRequires: yasm
 %endif
-%{?with_zfs:BuildRequires:     zfs-devel}
+# zfs patch updates to 0.8.0 API
+%{?with_zfs:BuildRequires:     zfs-devel >= 0.8.0}
 BuildRequires: zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires(preun):       rc-scripts
@@ -244,6 +251,24 @@ OCF Resource Agents for Ceph processes.
 %description resource-agents -l pl.UTF-8
 Agenci OCF do monitorowania procesów Cepha.
 
+%package -n fio-ceph-objectstore
+Summary:       FIO engine module for Ceph ObjectStore
+Summary(pl.UTF-8):     Moduł silnika FIO do używania Ceph ObjectStore
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+%if %{with fio}
+%requires_ge_to        fio fio-devel
+%endif
+
+%description -n fio-ceph-objectstore
+This FIO engine allows you to mount and use a ceph object store
+directly, without having to build a ceph cluster or start any daemons.
+
+%description -n fio-ceph-objectstore -l pl.UTF-8
+Ten silnik FIO pozwala na bezpośrednie montowanie i używanie
+przestrzeni obiektów ceph, bez potrzeby budowania klastra ceph czy
+uruchamiania demonów.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -254,6 +279,9 @@ Agenci OCF do monitorowania procesów Cepha.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
 
 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
        src/{ceph-create-keys,ceph-rest-api,mount.fuse.ceph} \
@@ -448,9 +476,9 @@ fi
 %if "%{_libexecdir}" != "%{_libdir}"
 %dir %{_libexecdir}/ceph
 %endif
-%attr(755,root,root) %{_libexecdir}/ceph/ceph-monstore-update-crush.sh
+%{_libexecdir}/ceph/ceph_common.sh
 %attr(755,root,root) %{_libexecdir}/ceph/ceph-osd-prestart.sh
-%{_libdir}/ceph/ceph_common.sh
+%attr(755,root,root) %{_libdir}/ceph/ceph-monstore-update-crush.sh
 %{_libdir}/ceph/mgr
 %dir %{_libdir}/ceph/compressor
 %attr(755,root,root) %{_libdir}/ceph/compressor/libceph_lz4.so*
@@ -662,3 +690,10 @@ fi
 %defattr(644,root,root,755)
 %dir %{_prefix}/lib/ocf/resource.d/ceph
 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/ceph/rbd
+
+%if %{with fio}
+%files -n fio-ceph-objectstore
+%defattr(644,root,root,755)
+%doc src/test/fio/{README.md,ceph-*.conf,ceph-*.fio}
+%attr(755,root,root) %{_libdir}/libfio_ceph_objectstore.so
+%endif
This page took 0.064728 seconds and 4 git commands to generate.