]> git.pld-linux.org Git - packages/celestia.git/blob - celestia.spec
Version: 1.6.1
[packages/celestia.git] / celestia.spec
1 #
2 # Conditional build:
3 %bcond_with     kde             # KDE3 UI as the default one
4 %bcond_without  gtk             # use GTK+2 UI instead
5 %bcond_with     gnome           # use libgnome2 UI instead
6 %bcond_with     glut            # use glut UI instead
7 %bcond_without  theora          # without theora support
8 #
9 %if %{with kde} || %{with gnome} || %{with glut}
10 %undefine       with_gtk
11 %endif
12 Summary:        A real-time visual space simulation
13 Summary(pl.UTF-8):      Symulacja przestrzeni kosmicznej w czasie rzeczywistym
14 Name:           celestia
15 Version:        1.6.1
16 Release:        1
17 License:        GPL
18 Group:          X11/Applications/Science
19 Source0:        http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
20 # Source0-md5:  02208982a431b984502fac909bf380f4
21 Patch0:         %{name}-includes.patch
22 Patch1:         %{name}-as-needed.patch
23 Patch2:         gtk-enable-locales-early.patch
24 Patch3:         use-stdint_h.patch
25 Patch4:         %{name}-desktop.patch
26 Patch5:         %{name}-gcc47.patch
27 Patch6:         %{name}-null.patch
28 #Patch2:                %{name}-extras.patch
29 #Patch4:                %{name}-lua51.patch
30 URL:            http://www.shatters.net/celestia/
31 BuildRequires:  OpenGL-GLU-devel
32 %{?with_glut:BuildRequires:     OpenGL-glut-devel >= 4.0}
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  gettext-tools
36 %if %{with gtk} || %{with gnome}
37 BuildRequires:  cairo-devel
38 BuildRequires:  gtk+2-devel >= 2:2.6
39 BuildRequires:  gtkglext-devel
40 %endif
41 BuildRequires:  gettext-tools
42 %{?with_kde:BuildRequires:      kdelibs-devel}
43 %{?with_gnome:BuildRequires:    libgnomeui-devel}
44 BuildRequires:  libjpeg-devel
45 BuildRequires:  libpng-devel
46 BuildRequires:  libstdc++-devel
47 %{?with_theora:BuildRequires:   libtheora-devel}
48 BuildRequires:  libtool
49 BuildRequires:  lua51-devel
50 BuildRequires:  pkgconfig
51 BuildRequires:  sed >= 4.0
52 # celestia < 1.4 original packages
53 Obsoletes:      celestia-extrasolar
54 Obsoletes:      celestia-generator
55 Obsoletes:      celestia-stars
56 Obsoletes:      celestia-task-default
57 # texture replacement addons, virtual provides
58 Obsoletes:      celestia-textures-earth
59 Obsoletes:      celestia-textures-earth-clouds
60 Obsoletes:      celestia-textures-earth-night
61 Obsoletes:      celestia-textures-galileanmoons
62 Obsoletes:      celestia-textures-mars
63 Obsoletes:      celestia-textures-mars-bumpmap
64 Obsoletes:      celestia-textures-mercury
65 Obsoletes:      celestia-textures-mercury-bumpmap
66 Obsoletes:      celestia-textures-moon
67 Obsoletes:      celestia-textures-moon-bumpmap
68 # celestia addons
69 Obsoletes:      celestia-blackhole
70 Obsoletes:      celestia-galaxies_extended
71 Obsoletes:      celestia-galaxy_clusters
72 Obsoletes:      celestia-globular_clusters
73 Obsoletes:      celestia-im-starwars
74 Obsoletes:      celestia-pathfinder
75 Obsoletes:      celestia-voyager
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %description
79 Celestia is a free real-time space simulation that lets you experience
80 our universe in three dimensions. Unlike most planetarium software,
81 Celestia doesn't confine you to the surface of the Earth. You can
82 travel throughout the solar system, to any of over 100,000 stars, or
83 even beyond the galaxy. All travel in Celestia is seamless; the
84 exponential zoom feature lets you explore space across a huge range of
85 scales, from galaxy clusters down to spacecraft only a few meters
86 across. A 'point-and-goto' interface makes it simple to navigate
87 through the universe to the object you want to visit.
88
89 %description -l pl.UTF-8
90 Celestia to wolny symulator przestrzeni komicznej w czasie
91 rzeczywistym, który pozwala doświadczać naszego Wszechświata w
92 trzech wymiarach. W odróżnieniu od innych programów planetarnych
93 Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
94 podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
95 nawet poza galaktykę. Wszystkie podróże w Celestii są
96 niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
97 odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
98 widoku kilkumetrowych statków kosmicznych. Interfejs typu
99 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107 %patch4 -p1
108 %patch5 -p1
109 %patch6 -p1
110
111 # ugly hack not to require GConf2-devel if we're not building gnome version
112 %{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
113
114 %build
115 %{__gettextize}
116 cp -a po/Makefile* po2/
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122
123 %configure \
124         CFLAGS="%{rpmcflags} $(pkg-config --cflags libpng)" \
125         LIBS="-ldl" \
126         %{?with_kde:--with-kde} \
127         %{?with_gtk:--with-gtk} \
128         %{?with_gnome:--with-gnome} \
129         %{?with_glut:--with-glut} \
130         --disable-rpath \
131         %{!?with_theora:--disable-theora} \
132         --with-lua \
133         --with-qt-dir=%{_libdir}
134
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT \
142         kde_htmldir=%{_kdedocdir} \
143         kde_libs_htmldir=%{_kdedocdir} \
144         appsdir=%{_desktopdir}/kde
145
146 # desktop/icon
147 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
148 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
149 install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
150
151 rm -r $RPM_BUILD_ROOT%{_localedir}/no
152
153 %find_lang %{name} --all-name --with-kde
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %if %{with gnome}
159 %post
160 %gconf_schema_install celestia.schemas
161
162 %preun
163 %gconf_schema_uninstall celestia.schemas
164 %endif
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc NEWS README AUTHORS controls.txt ChangeLog
169 %attr(755,root,root) %{_bindir}/*
170 %{_datadir}/celestia
171 %{_pixmapsdir}/*
172 %if %{with kde}
173 %{_datadir}/apps/celestia
174 %{_datadir}/config/*
175 %{_datadir}/mimelnk/application/*
176 %{_datadir}/services/*
177 %{_iconsdir}/*/*/apps/%{name}.png
178 %{_desktopdir}/kde/*.desktop
179 %else
180 %{_desktopdir}/*.desktop
181 %endif
182 %{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.084545 seconds and 4 git commands to generate.