]> git.pld-linux.org Git - packages/celestia.git/blob - celestia.spec
- missing BR: gettext-devel
[packages/celestia.git] / celestia.spec
1
2 %bcond_without  kde             # KDE UI as the default one
3 %bcond_with     gtk             # use gtk2 UI instead
4 %bcond_with     gnome           # use libgnome2 UI instead
5 %bcond_with     glut            # use glut UI instead
6
7 %if %{with gtk} || %{with gnome} || %{with glut}
8 %undefine       with_kde
9 %endif
10
11 Summary:        A real-time visual space simulation
12 Summary(pl.UTF-8):      Symulacja przestrzeni kosmicznej w czasie rzeczywistym
13 Name:           celestia
14 Version:        1.5.1
15 Release:        1
16 License:        GPL
17 Group:          X11/Applications/Science
18 Source0:        http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
19 # Source0-md5:  df6854a2cf62d2e96612398c13b68fd2
20 Patch0:         %{name}-as-needed.patch
21 Patch1:         %{name}-gcc43.patch
22 Patch2:         %{name}-extras.patch
23 Patch3:         %{name}-desktop.patch
24 URL:            http://www.shatters.net/celestia/
25 BuildRequires:  OpenGL-devel
26 %{?with_glut:BuildRequires:     OpenGL-glut-devel >= 4.0}
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 %if %{with gtk} || %{with gnome}
30 BuildRequires:  cairo-devel
31 BuildRequires:  gettext-devel
32 BuildRequires:  gtk+2-devel >= 2.6
33 BuildRequires:  gtkglext-devel
34 %endif
35 %{?with_kde:BuildRequires:      kdelibs-devel}
36 %{?with_gnome:BuildRequires:    libgnomeui-devel}
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool
41 BuildRequires:  lua50-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  sed >= 4.0
44 Requires:       OpenGL
45 # celestia < 1.4 original packages
46 Obsoletes:      celestia-extrasolar
47 Obsoletes:      celestia-generator
48 Obsoletes:      celestia-stars
49 Obsoletes:      celestia-task-default
50 # texture replacement addons, virtual provides
51 Obsoletes:      celestia-textures-earth
52 Obsoletes:      celestia-textures-earth-clouds
53 Obsoletes:      celestia-textures-earth-night
54 Obsoletes:      celestia-textures-galileanmoons
55 Obsoletes:      celestia-textures-mars
56 Obsoletes:      celestia-textures-mars-bumpmap
57 Obsoletes:      celestia-textures-mercury
58 Obsoletes:      celestia-textures-mercury-bumpmap
59 Obsoletes:      celestia-textures-moon
60 Obsoletes:      celestia-textures-moon-bumpmap
61 # celestia addons
62 Obsoletes:      celestia-blackhole
63 Obsoletes:      celestia-galaxies_extended
64 Obsoletes:      celestia-galaxy_clusters
65 Obsoletes:      celestia-globular_clusters
66 Obsoletes:      celestia-im-starwars
67 Obsoletes:      celestia-pathfinder
68 Obsoletes:      celestia-voyager
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
72
73 %description
74 Celestia is a free real-time space simulation that lets you experience
75 our universe in three dimensions. Unlike most planetarium software,
76 Celestia doesn't confine you to the surface of the Earth. You can
77 travel throughout the solar system, to any of over 100,000 stars, or
78 even beyond the galaxy. All travel in Celestia is seamless; the
79 exponential zoom feature lets you explore space across a huge range of
80 scales, from galaxy clusters down to spacecraft only a few meters
81 across. A 'point-and-goto' interface makes it simple to navigate
82 through the universe to the object you want to visit.
83
84 %description -l pl.UTF-8
85 Celestia to wolny symulator przestrzeni komicznej w czasie
86 rzeczywistym, który pozwala doświadczać naszego Wszechświata w
87 trzech wymiarach. W odróżnieniu od innych programów planetarnych
88 Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
89 podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
90 nawet poza galaktykę. Wszystkie podróże w Celestii są
91 niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
92 odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
93 widoku kilkumetrowych statków kosmicznych. Interfejs typu
94 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
95
96 %prep
97 %setup -q
98 %patch0
99 %patch1 -p1
100 %patch2 -p1
101 %patch3 -p1
102
103 # ugly hack not to require GConf2-devel if we're not building gnome version
104 %{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
105
106 %build
107 cp -f /usr/share/automake/config.sub admin
108 %{__make} -f admin/Makefile.common
109
110 %configure \
111         %{?with_kde:--with-kde} \
112         %{?with_gtk:--with-gtk} \
113         %{?with_gnome:--with-gnome} \
114         %{?with_glut:--with-glut} \
115         --disable-rpath \
116         --with-lua \
117         --with-xinerama \
118         --with-qt-dir=%{_libdir}
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT \
127         kde_htmldir=%{_kdedocdir} \
128         kde_libs_htmldir=%{_kdedocdir} \
129         appsdir=%{_desktopdir}/kde
130
131 # desktop/icon
132 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
133 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
134 install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
135
136 %find_lang %{name} --all-name --with-kde
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %if %{with gnome}
142 %post
143 %gconf_schema_install celestia.schemas
144
145 %preun
146 %gconf_schema_uninstall celestia.schemas
147 %endif
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc README AUTHORS TODO controls.txt ChangeLog
152 %attr(755,root,root) %{_bindir}/*
153 %{_datadir}/celestia
154 %{_pixmapsdir}/*
155 %if %{with kde}
156 %{_datadir}/apps/celestia
157 %{_datadir}/config/*
158 %{_datadir}/mimelnk/application/*
159 %{_datadir}/services/*
160 %{_iconsdir}/*/*/apps/%{name}.png
161 %{_desktopdir}/kde/*.desktop
162 %else
163 %{_desktopdir}/*.desktop
164 %endif
165 %{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.187808 seconds and 4 git commands to generate.