]> git.pld-linux.org Git - packages/celestia.git/blob - celestia.spec
- correct version of required GLUT API
[packages/celestia.git] / celestia.spec
1
2 %bcond_without  kde             # KDE UI as the default one
3 %bcond_with     gtk             # use gtk2 UI instead
4 %bcond_with     gnome           # use libgnome2 UI instead
5 %bcond_with     glut            # use glut UI instead
6
7 %if %{with gtk} || %{with gnome} || %{with glut}
8 %undefine       with_kde
9 %endif
10
11 Summary:        A real-time visual space simulation
12 Summary(pl.UTF-8):      Symulacja przestrzeni kosmicznej w czasie rzeczywistym
13 Name:           celestia
14 Version:        1.5.1
15 Release:        1
16 License:        GPL
17 Group:          X11/Applications/Science
18 Source0:        http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
19 # Source0-md5:  df6854a2cf62d2e96612398c13b68fd2
20 Patch0:         %{name}-as-needed.patch
21 Patch1:         %{name}-gcc43.patch
22 Patch2:         %{name}-extras.patch
23 Patch3:         %{name}-desktop.patch
24 URL:            http://www.shatters.net/celestia/
25 BuildRequires:  OpenGL-devel
26 %{?with_glut:BuildRequires:     OpenGL-glut-devel >= 4.0}
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 %if %{with gtk} || %{with gnome}
30 BuildRequires:  cairo-devel
31 BuildRequires:  gtk+2-devel >= 2.6
32 BuildRequires:  gtkglext-devel
33 %endif
34 %{?with_kde:BuildRequires:      kdelibs-devel}
35 %{?with_gnome:BuildRequires:    libgnomeui-devel}
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool
40 BuildRequires:  lua50-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  sed >= 4.0
43 Requires:       OpenGL
44 # celestia < 1.4 original packages
45 Obsoletes:      celestia-extrasolar
46 Obsoletes:      celestia-generator
47 Obsoletes:      celestia-stars
48 Obsoletes:      celestia-task-default
49 # texture replacement addons, virtual provides
50 Obsoletes:      celestia-textures-earth
51 Obsoletes:      celestia-textures-earth-clouds
52 Obsoletes:      celestia-textures-earth-night
53 Obsoletes:      celestia-textures-galileanmoons
54 Obsoletes:      celestia-textures-mars
55 Obsoletes:      celestia-textures-mars-bumpmap
56 Obsoletes:      celestia-textures-mercury
57 Obsoletes:      celestia-textures-mercury-bumpmap
58 Obsoletes:      celestia-textures-moon
59 Obsoletes:      celestia-textures-moon-bumpmap
60 # celestia addons
61 Obsoletes:      celestia-blackhole
62 Obsoletes:      celestia-galaxies_extended
63 Obsoletes:      celestia-galaxy_clusters
64 Obsoletes:      celestia-globular_clusters
65 Obsoletes:      celestia-im-starwars
66 Obsoletes:      celestia-pathfinder
67 Obsoletes:      celestia-voyager
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
71
72 %description
73 Celestia is a free real-time space simulation that lets you experience
74 our universe in three dimensions. Unlike most planetarium software,
75 Celestia doesn't confine you to the surface of the Earth. You can
76 travel throughout the solar system, to any of over 100,000 stars, or
77 even beyond the galaxy. All travel in Celestia is seamless; the
78 exponential zoom feature lets you explore space across a huge range of
79 scales, from galaxy clusters down to spacecraft only a few meters
80 across. A 'point-and-goto' interface makes it simple to navigate
81 through the universe to the object you want to visit.
82
83 %description -l pl.UTF-8
84 Celestia to wolny symulator przestrzeni komicznej w czasie
85 rzeczywistym, który pozwala doświadczać naszego Wszechświata w
86 trzech wymiarach. W odróżnieniu od innych programów planetarnych
87 Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
88 podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
89 nawet poza galaktykę. Wszystkie podróże w Celestii są
90 niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
91 odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
92 widoku kilkumetrowych statków kosmicznych. Interfejs typu
93 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
94
95 %prep
96 %setup -q
97 %patch0
98 %patch1 -p1
99 %patch2 -p1
100 %patch3 -p1
101
102 # ugly hack not to require GConf2-devel if we're not building gnome version
103 %{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
104
105 %build
106 cp -f /usr/share/automake/config.sub admin
107 %{__make} -f admin/Makefile.common
108
109 %configure \
110         %{?with_kde:--with-kde} \
111         %{?with_gtk:--with-gtk} \
112         %{?with_gnome:--with-gnome} \
113         %{?with_glut:--with-glut} \
114         --disable-rpath \
115         --with-lua \
116         --with-xinerama \
117         --with-qt-dir=%{_libdir}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT \
126         kde_htmldir=%{_kdedocdir} \
127         kde_libs_htmldir=%{_kdedocdir} \
128         appsdir=%{_desktopdir}/kde
129
130 # desktop/icon
131 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
132 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
133 install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
134
135 %find_lang %{name} --all-name --with-kde
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %if %{with gnome}
141 %post
142 %gconf_schema_install celestia.schemas
143
144 %preun
145 %gconf_schema_uninstall celestia.schemas
146 %endif
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc README AUTHORS TODO controls.txt ChangeLog
151 %attr(755,root,root) %{_bindir}/*
152 %{_datadir}/celestia
153 %{_pixmapsdir}/*
154 %if %{with kde}
155 %{_datadir}/apps/celestia
156 %{_datadir}/config/*
157 %{_datadir}/mimelnk/application/*
158 %{_datadir}/services/*
159 %{_iconsdir}/*/*/apps/%{name}.png
160 %{_desktopdir}/kde/*.desktop
161 %else
162 %{_desktopdir}/*.desktop
163 %endif
164 %{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.052546 seconds and 4 git commands to generate.