]> git.pld-linux.org Git - packages/celestia.git/blob - celestia.spec
- updated gettext BR
[packages/celestia.git] / celestia.spec
1 #
2 # Conditional build:
3 %bcond_without  kde             # KDE UI as the default one
4 %bcond_with     gtk             # use GTK+2 UI instead
5 %bcond_with     gnome           # use libgnome2 UI instead
6 %bcond_with     glut            # use glut UI instead
7 %bcond_without  theora          # without theora support
8 #
9 %if %{with gtk} || %{with gnome} || %{with glut}
10 %undefine       with_kde
11 %endif
12 Summary:        A real-time visual space simulation
13 Summary(pl.UTF-8):      Symulacja przestrzeni kosmicznej w czasie rzeczywistym
14 Name:           celestia
15 Version:        1.5.1
16 Release:        1
17 License:        GPL
18 Group:          X11/Applications/Science
19 Source0:        http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
20 # Source0-md5:  df6854a2cf62d2e96612398c13b68fd2
21 Patch0:         %{name}-as-needed.patch
22 Patch1:         %{name}-gcc43.patch
23 Patch2:         %{name}-extras.patch
24 Patch3:         %{name}-desktop.patch
25 Patch4:         %{name}-lua51.patch
26 URL:            http://www.shatters.net/celestia/
27 BuildRequires:  OpenGL-GLU-devel
28 %{?with_glut:BuildRequires:     OpenGL-glut-devel >= 4.0}
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %if %{with gtk} || %{with gnome}
32 BuildRequires:  cairo-devel
33 BuildRequires:  gtk+2-devel >= 2:2.6
34 BuildRequires:  gtkglext-devel
35 %endif
36 BuildRequires:  gettext-tools
37 %{?with_kde:BuildRequires:      kdelibs-devel}
38 %{?with_gnome:BuildRequires:    libgnomeui-devel}
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libpng-devel
41 BuildRequires:  libstdc++-devel
42 %{?with_theora:BuildRequires:   libtheora-devel}
43 BuildRequires:  libtool
44 BuildRequires:  lua51-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  sed >= 4.0
47 # celestia < 1.4 original packages
48 Obsoletes:      celestia-extrasolar
49 Obsoletes:      celestia-generator
50 Obsoletes:      celestia-stars
51 Obsoletes:      celestia-task-default
52 # texture replacement addons, virtual provides
53 Obsoletes:      celestia-textures-earth
54 Obsoletes:      celestia-textures-earth-clouds
55 Obsoletes:      celestia-textures-earth-night
56 Obsoletes:      celestia-textures-galileanmoons
57 Obsoletes:      celestia-textures-mars
58 Obsoletes:      celestia-textures-mars-bumpmap
59 Obsoletes:      celestia-textures-mercury
60 Obsoletes:      celestia-textures-mercury-bumpmap
61 Obsoletes:      celestia-textures-moon
62 Obsoletes:      celestia-textures-moon-bumpmap
63 # celestia addons
64 Obsoletes:      celestia-blackhole
65 Obsoletes:      celestia-galaxies_extended
66 Obsoletes:      celestia-galaxy_clusters
67 Obsoletes:      celestia-globular_clusters
68 Obsoletes:      celestia-im-starwars
69 Obsoletes:      celestia-pathfinder
70 Obsoletes:      celestia-voyager
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 Celestia is a free real-time space simulation that lets you experience
75 our universe in three dimensions. Unlike most planetarium software,
76 Celestia doesn't confine you to the surface of the Earth. You can
77 travel throughout the solar system, to any of over 100,000 stars, or
78 even beyond the galaxy. All travel in Celestia is seamless; the
79 exponential zoom feature lets you explore space across a huge range of
80 scales, from galaxy clusters down to spacecraft only a few meters
81 across. A 'point-and-goto' interface makes it simple to navigate
82 through the universe to the object you want to visit.
83
84 %description -l pl.UTF-8
85 Celestia to wolny symulator przestrzeni komicznej w czasie
86 rzeczywistym, który pozwala doświadczać naszego Wszechświata w
87 trzech wymiarach. W odróżnieniu od innych programów planetarnych
88 Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
89 podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
90 nawet poza galaktykę. Wszystkie podróże w Celestii są
91 niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
92 odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
93 widoku kilkumetrowych statków kosmicznych. Interfejs typu
94 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
95
96 %prep
97 %setup -q
98 %patch0
99 %patch1 -p1
100 %patch2 -p1
101 %patch3 -p1
102 %patch4
103
104 # ugly hack not to require GConf2-devel if we're not building gnome version
105 %{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
106
107 %build
108 cp -f /usr/share/automake/config.sub admin
109 %{__make} -f admin/Makefile.common
110
111 %configure \
112         %{?with_kde:--with-kde} \
113         %{?with_gtk:--with-gtk} \
114         %{?with_gnome:--with-gnome} \
115         %{?with_glut:--with-glut} \
116         --disable-rpath \
117         %{!?with_theora:--disable-theora} \
118         --with-lua \
119         --with-qt-dir=%{_libdir}
120
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         kde_htmldir=%{_kdedocdir} \
129         kde_libs_htmldir=%{_kdedocdir} \
130         appsdir=%{_desktopdir}/kde
131
132 # desktop/icon
133 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
134 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
135 install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
136
137 %find_lang %{name} --all-name --with-kde
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %if %{with gnome}
143 %post
144 %gconf_schema_install celestia.schemas
145
146 %preun
147 %gconf_schema_uninstall celestia.schemas
148 %endif
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc README AUTHORS TODO controls.txt ChangeLog
153 %attr(755,root,root) %{_bindir}/*
154 %{_datadir}/celestia
155 %{_pixmapsdir}/*
156 %if %{with kde}
157 %{_datadir}/apps/celestia
158 %{_datadir}/config/*
159 %{_datadir}/mimelnk/application/*
160 %{_datadir}/services/*
161 %{_iconsdir}/*/*/apps/%{name}.png
162 %{_desktopdir}/kde/*.desktop
163 %else
164 %{_desktopdir}/*.desktop
165 %endif
166 %{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.050658 seconds and 4 git commands to generate.