]> git.pld-linux.org Git - packages/celestia.git/blob - celestia.spec
- linking with theora is now predictable
[packages/celestia.git] / celestia.spec
1
2 %bcond_without  kde             # KDE UI as the default one
3 %bcond_with     gtk             # use gtk2 UI instead
4 %bcond_with     gnome           # use libgnome2 UI instead
5 %bcond_with     glut            # use glut UI instead
6
7 %bcond_without  theora          # without theora support
8
9 %if %{with gtk} || %{with gnome} || %{with glut}
10 %undefine       with_kde
11 %endif
12
13 Summary:        A real-time visual space simulation
14 Summary(pl.UTF-8):      Symulacja przestrzeni kosmicznej w czasie rzeczywistym
15 Name:           celestia
16 Version:        1.5.1
17 Release:        1
18 License:        GPL
19 Group:          X11/Applications/Science
20 Source0:        http://dl.sourceforge.net/celestia/%{name}-%{version}.tar.gz
21 # Source0-md5:  df6854a2cf62d2e96612398c13b68fd2
22 Patch0:         %{name}-as-needed.patch
23 Patch1:         %{name}-gcc43.patch
24 Patch2:         %{name}-extras.patch
25 Patch3:         %{name}-desktop.patch
26 URL:            http://www.shatters.net/celestia/
27 BuildRequires:  OpenGL-GLU-devel
28 %{?with_glut:BuildRequires:     OpenGL-glut-devel >= 4.0}
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %if %{with gtk} || %{with gnome}
32 BuildRequires:  cairo-devel
33 BuildRequires:  gettext-devel
34 BuildRequires:  gtk+2-devel >= 2.6
35 BuildRequires:  gtkglext-devel
36 %endif
37 %{?with_kde:BuildRequires:      kdelibs-devel}
38 %{?with_gnome:BuildRequires:    libgnomeui-devel}
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libpng-devel
41 BuildRequires:  libstdc++-devel
42 %{?with_theora:BuildRequires:   libtheora-devel}
43 BuildRequires:  libtool
44 BuildRequires:  lua50-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  sed >= 4.0
47 Requires:       OpenGL
48 # celestia < 1.4 original packages
49 Obsoletes:      celestia-extrasolar
50 Obsoletes:      celestia-generator
51 Obsoletes:      celestia-stars
52 Obsoletes:      celestia-task-default
53 # texture replacement addons, virtual provides
54 Obsoletes:      celestia-textures-earth
55 Obsoletes:      celestia-textures-earth-clouds
56 Obsoletes:      celestia-textures-earth-night
57 Obsoletes:      celestia-textures-galileanmoons
58 Obsoletes:      celestia-textures-mars
59 Obsoletes:      celestia-textures-mars-bumpmap
60 Obsoletes:      celestia-textures-mercury
61 Obsoletes:      celestia-textures-mercury-bumpmap
62 Obsoletes:      celestia-textures-moon
63 Obsoletes:      celestia-textures-moon-bumpmap
64 # celestia addons
65 Obsoletes:      celestia-blackhole
66 Obsoletes:      celestia-galaxies_extended
67 Obsoletes:      celestia-galaxy_clusters
68 Obsoletes:      celestia-globular_clusters
69 Obsoletes:      celestia-im-starwars
70 Obsoletes:      celestia-pathfinder
71 Obsoletes:      celestia-voyager
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
75
76 %description
77 Celestia is a free real-time space simulation that lets you experience
78 our universe in three dimensions. Unlike most planetarium software,
79 Celestia doesn't confine you to the surface of the Earth. You can
80 travel throughout the solar system, to any of over 100,000 stars, or
81 even beyond the galaxy. All travel in Celestia is seamless; the
82 exponential zoom feature lets you explore space across a huge range of
83 scales, from galaxy clusters down to spacecraft only a few meters
84 across. A 'point-and-goto' interface makes it simple to navigate
85 through the universe to the object you want to visit.
86
87 %description -l pl.UTF-8
88 Celestia to wolny symulator przestrzeni komicznej w czasie
89 rzeczywistym, który pozwala doświadczać naszego Wszechświata w
90 trzech wymiarach. W odróżnieniu od innych programów planetarnych
91 Celestia nie przywiązuje Cię do powierzchni ziemi. Możesz
92 podróżować przez Układ Słoneczny do ponad 100,000 gwiazd lub
93 nawet poza galaktykę. Wszystkie podróże w Celestii są
94 niezauważalne; funkcja wykładniczego przybliżenia pozwala Ci
95 odkrywać Kosmos w różnych skalach - od spojrzenia na galaktyki do
96 widoku kilkumetrowych statków kosmicznych. Interfejs typu
97 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
98
99 %prep
100 %setup -q
101 %patch0
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105
106 # ugly hack not to require GConf2-devel if we're not building gnome version
107 %{!?with_gnome:sed -i "s#AM_GCONF_SOURCE_2##g" configure.in}
108
109 %build
110 cp -f /usr/share/automake/config.sub admin
111 %{__make} -f admin/Makefile.common
112
113 %configure \
114         %{?with_kde:--with-kde} \
115         %{?with_gtk:--with-gtk} \
116         %{?with_gnome:--with-gnome} \
117         %{?with_glut:--with-glut} \
118         --disable-rpath \
119         %{!?with_theora:--disable-theora} \
120         --with-lua \
121         --with-xinerama \
122         --with-qt-dir=%{_libdir}
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT \
131         kde_htmldir=%{_kdedocdir} \
132         kde_libs_htmldir=%{_kdedocdir} \
133         appsdir=%{_desktopdir}/kde
134
135 # desktop/icon
136 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
137 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
138 install src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
139
140 %find_lang %{name} --all-name --with-kde
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %if %{with gnome}
146 %post
147 %gconf_schema_install celestia.schemas
148
149 %preun
150 %gconf_schema_uninstall celestia.schemas
151 %endif
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc README AUTHORS TODO controls.txt ChangeLog
156 %attr(755,root,root) %{_bindir}/*
157 %{_datadir}/celestia
158 %{_pixmapsdir}/*
159 %if %{with kde}
160 %{_datadir}/apps/celestia
161 %{_datadir}/config/*
162 %{_datadir}/mimelnk/application/*
163 %{_datadir}/services/*
164 %{_iconsdir}/*/*/apps/%{name}.png
165 %{_desktopdir}/kde/*.desktop
166 %else
167 %{_desktopdir}/*.desktop
168 %endif
169 %{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.134372 seconds and 4 git commands to generate.