]> git.pld-linux.org Git - packages/celestia.git/blob - celestia.spec
e3e06ce752e0c772d3d6e152472cadda7ad0bd91
[packages/celestia.git] / celestia.spec
1 #
2 # Conditional build:
3 %bcond_with     kde             # KDE3 UI as the default one
4 %bcond_without  gtk             # use GTK+2 UI instead
5 %bcond_with     gnome           # use libgnome2 UI instead
6 %bcond_with     glut            # use glut UI instead
7 %bcond_without  theora          # without theora support
8
9 %if %{with kde} || %{with gnome} || %{with glut}
10 %undefine       with_gtk
11 %endif
12 Summary:        A real-time visual space simulation
13 Summary(pl.UTF-8):      Symulacja przestrzeni kosmicznej w czasie rzeczywistym
14 Name:           celestia
15 Version:        1.6.2
16 Release:        1
17 License:        GPL
18 Group:          X11/Applications/Science
19 Source0:        https://github.com/CelestiaProject/Celestia/archive/refs/tags/%{version}.tar.gz
20 # Source0-md5:  604434b1d99b7ac1b51a4933c04a652b
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-null.patch
23 URL:            https://celestia.space
24 BuildRequires:  OpenGL-GLU-devel
25 %{?with_glut:BuildRequires:     OpenGL-glut-devel >= 4.0}
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  gettext-tools
29 %if %{with gtk} || %{with gnome}
30 BuildRequires:  cairo-devel
31 BuildRequires:  gtk+2-devel >= 2:2.6
32 BuildRequires:  gtkglext-devel
33 %endif
34 BuildRequires:  gettext-tools
35 %{?with_kde:BuildRequires:      kdelibs-devel}
36 %{?with_gnome:BuildRequires:    libgnomeui-devel}
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libstdc++-devel
40 %{?with_theora:BuildRequires:   libtheora-devel}
41 BuildRequires:  libtool
42 BuildRequires:  lua53-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  sed >= 4.0
45 # celestia < 1.4 original packages
46 Obsoletes:      celestia-extrasolar
47 Obsoletes:      celestia-generator
48 Obsoletes:      celestia-stars
49 Obsoletes:      celestia-task-default
50 # texture replacement addons, virtual provides
51 Obsoletes:      celestia-textures-earth
52 Obsoletes:      celestia-textures-earth-clouds
53 Obsoletes:      celestia-textures-earth-night
54 Obsoletes:      celestia-textures-galileanmoons
55 Obsoletes:      celestia-textures-mars
56 Obsoletes:      celestia-textures-mars-bumpmap
57 Obsoletes:      celestia-textures-mercury
58 Obsoletes:      celestia-textures-mercury-bumpmap
59 Obsoletes:      celestia-textures-moon
60 Obsoletes:      celestia-textures-moon-bumpmap
61 # celestia addons
62 Obsoletes:      celestia-blackhole
63 Obsoletes:      celestia-galaxies_extended
64 Obsoletes:      celestia-galaxy_clusters
65 Obsoletes:      celestia-globular_clusters
66 Obsoletes:      celestia-im-starwars
67 Obsoletes:      celestia-pathfinder
68 Obsoletes:      celestia-voyager
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Celestia is a free real-time space simulation that lets you experience
73 our universe in three dimensions. Unlike most planetarium software,
74 Celestia doesn't confine you to the surface of the Earth. You can
75 travel throughout the solar system, to any of over 100,000 stars, or
76 even beyond the galaxy. All travel in Celestia is seamless; the
77 exponential zoom feature lets you explore space across a huge range of
78 scales, from galaxy clusters down to spacecraft only a few meters
79 across. A 'point-and-goto' interface makes it simple to navigate
80 through the universe to the object you want to visit.
81
82 %description -l pl.UTF-8
83 Celestia to wolny symulator przestrzeni komicznej w czasie
84 rzeczywistym, który pozwala doświadczać naszego Wszechświata w trzech
85 wymiarach. W odróżnieniu od innych programów planetarnych Celestia nie
86 przywiązuje Cię do powierzchni ziemi. Możesz podróżować przez Układ
87 Słoneczny do ponad 100,000 gwiazd lub nawet poza galaktykę. Wszystkie
88 podróże w Celestii są niezauważalne; funkcja wykładniczego
89 przybliżenia pozwala Ci odkrywać Kosmos w różnych skalach - od
90 spojrzenia na galaktyki do widoku kilkumetrowych statków kosmicznych.
91 Interfejs typu 'pokaż-i-leć' czyni nawigację przez Wszechświat prostą.
92
93 %prep
94 %setup -q -n Celestia-%{version}
95 %patch0 -p1
96 %patch1 -p1
97
98 %build
99 %{__gettextize}
100 cp -a po/Makefile* po2/
101 %{__libtoolize}
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106
107 %configure \
108         CFLAGS="%{rpmcflags} $(pkg-config --cflags libpng)" \
109         LIBS="-ldl" \
110         %{?with_kde:--with-kde} \
111         %{?with_gtk:--with-gtk} \
112         %{?with_gnome:--with-gnome} \
113         %{?with_glut:--with-glut} \
114         --disable-rpath \
115         %{!?with_theora:--disable-theora} \
116         --with-lua \
117         --with-qt-dir=%{_libdir}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT \
126         kde_htmldir=%{_kdedocdir} \
127         kde_libs_htmldir=%{_kdedocdir} \
128         appsdir=%{_desktopdir}/kde
129
130 # desktop/icon
131 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
132 %{!?with_kde:install src/celestia/kde/data/celestia.desktop $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop}
133 cp -p src/celestia/kde/data/hi48-app-celestia.png $RPM_BUILD_ROOT%{_pixmapsdir}/celestia.png
134
135 rm -r $RPM_BUILD_ROOT%{_localedir}/no
136
137 %find_lang %{name} --all-name --with-kde
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %if %{with gnome}
143 %post
144 %gconf_schema_install celestia.schemas
145
146 %preun
147 %gconf_schema_uninstall celestia.schemas
148 %endif
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc NEWS README AUTHORS controls.txt ChangeLog
153 %attr(755,root,root) %{_bindir}/*
154 %{_datadir}/celestia
155 %{_pixmapsdir}/*
156 %if %{with kde}
157 %{_datadir}/apps/celestia
158 %{_datadir}/config/*
159 %{_datadir}/mimelnk/application/*
160 %{_datadir}/services/*
161 %{_iconsdir}/*/*/apps/%{name}.png
162 %{_desktopdir}/kde/*.desktop
163 %else
164 %{_desktopdir}/*.desktop
165 %endif
166 %{?with_gnome:%{_sysconfdir}/gconf/schemas/celestia.schemas}
This page took 0.06735 seconds and 2 git commands to generate.