]> git.pld-linux.org Git - packages/cdrdao.git/commitdiff
- added gcc3 patch to allow build with libstdc++v3
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 12 Oct 2002 22:18:55 +0000 (22:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- refresh config.* (for athlon)

Changed files:
    cdrdao-gcc3.patch -> 1.1
    cdrdao.spec -> 1.23

cdrdao-gcc3.patch [new file with mode: 0644]
cdrdao.spec

diff --git a/cdrdao-gcc3.patch b/cdrdao-gcc3.patch
new file mode 100644 (file)
index 0000000..9efd7e1
--- /dev/null
@@ -0,0 +1,56 @@
+--- cdrdao-1.1.5/trackdb/CdTextItem.cc.orig    Sun Apr 29 15:42:08 2001
++++ cdrdao-1.1.5/trackdb/CdTextItem.cc Sat Oct 12 21:13:26 2002
+@@ -18,6 +18,7 @@
+  */
+ #include <iostream.h>
++#include <iomanip.h>
+ #include <assert.h>
+ #include <string.h>
+ #include <ctype.h>
+@@ -129,7 +130,7 @@
+       else if (isprint(data_[i]))
+       out << data_[i];
+       else
+-      out.form("\\%03o", (unsigned int)data_[i]);
++      out << '\\' << setw(3) << setfill('0') << oct << (unsigned int)data_[i] << setfill(' ') << dec;
+     }
+     out << "\"";
+@@ -140,7 +141,7 @@
+     out << " {";
+     for (i = 0; i < dataLen_; i++) {
+       if (i == 0) {
+-      out.form("%2d", (unsigned int)data_[i]);
++      out << setw(2) << dec << (unsigned int)data_[i];
+       }
+       else {
+       if (i % 12 == 0) 
+@@ -148,7 +149,7 @@
+       else
+         out << ", ";
+-      out.form("%2d", (unsigned int)data_[i]);
++      out << setw(2) << dec << (unsigned int)data_[i];
+       }
+     }
+--- cdrdao-1.1.5/utils/toc2cue.cc.orig Sun Apr 29 15:42:09 2001
++++ cdrdao-1.1.5/utils/toc2cue.cc      Sat Oct 12 21:21:18 2002
+@@ -27,6 +27,7 @@
+ #include <stdarg.h>
+ #include <getopt.h>
+ #include <fstream.h>
++#include <iomanip.h>
+ #include "util.h"
+ #include "Toc.h"
+@@ -291,7 +292,7 @@
+        trun != NULL;
+        trun = titr.next(start, end), trackNr++) {
+     out << "  TRACK ";
+-    out.form("%02d ", trackNr);
++    out << setw(2) << setfill('0') << dec << trackNr << setfill(' ') << " ";
+     switch (trun->type()) {
+     case TrackData::AUDIO:
index 33590dc2ca73c9468616be24ee0f900870cbd5f4..7a4cb5de586617c1c8178fd70969c1fe86112ef0 100644 (file)
@@ -15,14 +15,16 @@ Patch0:             %{name}-destdir.patch
 Patch1:                %{name}-opt.patch
 Patch2:                %{name}-acfix.patch
 Patch3:                %{name}-gcdmaster-paths.patch
+Patch4:                %{name}-gcc3.patch
 URL:           http://cdrdao.sourceforge.net/
 BuildRequires: autoconf
+BuildRequires: automake
+%{!?_without_gnome:BuildRequires:      gnome-libs-devel >= 1.2.3}
+%{!?_without_gnome:BuildRequires:      gnomemm-devel >= 1.1.17}
+%{!?_without_gnome:BuildRequires:      gtkmm-devel >= 1.2.5}
 BuildRequires: libstdc++-devel
 BuildRequires: libsigc++1-devel
 BuildRequires: pccts-devel
-%{!?_without_gnome:BuildRequires:      gtkmm-devel >= 1.2.5}
-%{!?_without_gnome:BuildRequires:      gnome-libs-devel >= 1.2.3}
-%{!?_without_gnome:BuildRequires:      gnomemm-devel >= 1.1.17}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _xprefix        /usr/X11R6
@@ -71,11 +73,13 @@ niedestruktywne ci
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 cd paranoia
 %{__autoconf}
 cd ..
+cp -f /usr/share/automake/config.* .
 %{__autoconf}
 # false gtkmm-config path can be used to disable building of GNOME frontend
 %configure \
This page took 0.174479 seconds and 4 git commands to generate.