]> git.pld-linux.org Git - packages/cdrdao.git/blob - cdrdao.spec
move BR: GConf2-devel to gnome bcond
[packages/cdrdao.git] / cdrdao.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # don't build gcdmaster
4 %bcond_without  mp3     # without MP3 support
5 %bcond_without  ogg     # without Ogg support
6 #
7 Summary:        Tools for burning CDRs in Disk At Once mode
8 Summary(pl.UTF-8):      Narzędzia do wypalania płyt w trybie Disk At Once
9 Summary(pt_BR.UTF-8):   Cdrdao - Escreve CD-Rs de áudio em modo "disk-at-once"
10 Name:           cdrdao
11 Version:        1.2.3
12 Release:        7
13 License:        GPL v2+
14 Group:          Applications/System
15 Source0:        http://downloads.sourceforge.net/cdrdao/%{name}-%{version}.tar.bz2
16 # Source0-md5:  8d15ba6280bb7ba2f4d6be31d28b3c0c
17 Source1:        %{name}.desktop
18 # http://cdrdao.sourceforge.net/drives.html#dt
19 Source2:        %{name}.drivers
20 Patch0:         %{name}-nolibs.patch
21 Patch1:         %{name}-pccts-antlr.patch
22 Patch2:         %{name}-gcc4.patch
23 Patch3:         %{name}-glibc.patch
24 URL:            http://cdrdao.sourceforge.net/
25 BuildRequires:  GConf2-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  cdrtools-devel >= 3:2.01a25
29 %{?with_gnome:BuildRequires:    gtkmm-devel >= 2.4.0}
30 %{?with_mp3:BuildRequires:      lame-libs-devel >= 3.92}
31 %if %{with mp3} || %{with ogg}
32 BuildRequires:  libao-devel >= 0.8
33 %endif
34 %{?with_gnome:BuildRequires:    libgnomeuimm-devel >= 2.6.0}
35 BuildRequires:  libmad-devel >= 0.15.1b-4
36 %{?with_mp3:BuildRequires:      libmad-devel >= 0.15.1b-4}
37 %{?with_gnome:BuildRequires:    libsigc++-devel >= 2.0.0}
38 BuildRequires:  libstdc++-devel
39 %{?with_ogg:BuildRequires:      libvorbis-devel >= 1:1.0}
40 BuildRequires:  pccts >= 1.33MR33-8
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpmbuild(macros) >= 1.311
43 BuildRequires:  sed >= 4.0
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Cdrdao records audio and data CD-Rs in Disk At Once mode. This mode
48 gives much better control over contents of CD.
49
50 %description -l pl.UTF-8
51 Cdrdao zapisuje płytki audio i z danymi w trybie Disk At Once. W tym
52 trybie masz znacznie większą kontrolę nad zawartością płytki.
53
54 %description -l pt_BR.UTF-8
55 Escreve CD-Rs de áudio em modo "disk-at-once" (DAO) permitindo
56 controle sobre pre-gaps (tamanho reduzido a 0, dados não zerados de
57 áudio) e informações de sub-canais como códigos ISRC. Todos os dados
58 que são escritos no disco devem ser especificados através de um
59 arquivo texto. Dados de áudio também podem estar no formato WAVE ou
60 raw.
61
62 %package gcdmaster
63 Summary:        GNOME frontend to cdrdao for composing audio CDs
64 Summary(pl.UTF-8):      Frontend GNOME do cdrdao do składania płyt CD-Audio
65 Group:          X11/Applications
66 Requires(post,postun):  shared-mime-info
67 Requires:       %{name} = %{version}-%{release}
68
69 %description gcdmaster
70 gcdmaster allows the creation of toc-files for cdrdao and can control
71 the recording process. Its main application is the composition of
72 audio CDs from one or more audio files. It supports PQ-channel
73 editing, entry of meta data like ISRC codes/CD-TEXT and non
74 destructive cut of the audio data.
75
76 %description gcdmaster -l pl.UTF-8
77 gcdmaster pozwala na tworzenie plików toc dla cdrdao oraz może
78 kontrolować proces nagrywania. Głównym celem jest składanie płyt
79 CD-Audio z jednego lub więcej plików z dźwiękiem. Obsługuje edycję
80 kanału PQ, wpisy meta-danych takich jak kody ISRC/CD-TEXT oraz
81 niedestruktywne cięcie danych audio.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88 %patch3 -p1
89
90 %{__sed} -i -e 's#/usr/src/linux/include##g' scsilib/DEFAULT*/Defaults.linux
91 %if !%{with gnome}
92 %{__sed} -i -e 's/^en_xdao=yes$/en_xdao=no/' configure.ac
93 %endif
94
95 install %{SOURCE1} xdao/gcdmaster.desktop
96
97 %build
98 %{__aclocal}
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 PKG_CONFIG=%{_bindir}/pkg-config \
103 %configure \
104         --with-pcctsbin=%{_bindir} \
105         --with-pcctsinc=%{_libdir}/pccts/h \
106         --with-scglib-inc=%{_includedir}/schily \
107         --with-scglib-lib=%{_libdir} \
108         --with%{!?with_gnome:out}-xdao \
109         --with%{!?with_mp3:out}-mp3-support \
110         --with%{!?with_ogg:out}-ogg-support
111
112 %{__make} \
113         CC="%{__cc}" \
114         COPTOPT="%{rpmcflags}"
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/%{name}}
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/drivers
124
125 %if %{with gnome}
126 rm -r $RPM_BUILD_ROOT%{_datadir}/{application-registry,mime-info}
127 %endif
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post gcdmaster
133 %update_mime_database
134
135 %postun gcdmaster
136 %update_mime_database
137
138 %files
139 %defattr(644,root,root,755)
140 %doc CREDITS README README.PlexDAE
141 %attr(755,root,root) %{_bindir}/cdrdao
142 %attr(755,root,root) %{_bindir}/toc2*
143 %attr(755,root,root) %{_bindir}/cue2toc
144 %{_datadir}/%{name}
145 %{_mandir}/man1/cdrdao.1*
146 %{_mandir}/man1/cue2toc.1*
147 %{_mandir}/man1/toc2cddb.1*
148 %{_mandir}/man1/toc2cue.1*
149
150 %if %{with gnome}
151 %files gcdmaster
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/gcdmaster
154 %{_datadir}/gcdmaster
155 %{_datadir}/mime/packages/gcdmaster.xml
156 %{_desktopdir}/gcdmaster.desktop
157 %{_sysconfdir}/gconf/schemas/gcdmaster.schemas
158 %{_pixmapsdir}/*
159 %{_mandir}/man1/gcdmaster.1*
160 %endif
This page took 0.078739 seconds and 3 git commands to generate.