]> git.pld-linux.org Git - packages/cdrdao.git/blob - cdrdao.spec
- add without mp3
[packages/cdrdao.git] / cdrdao.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome   # without gcdmaster
4 %bcond_without  mp3     # without mp3 and ogg
5 #
6 Summary:        Tools for burning CDRs in Disk At Once mode
7 Summary(pl):    Narzêdzia do wypalania p³yt w trybie Disk At Once
8 Summary(pt_BR): Cdrdao - Escreve CD-Rs de áudio em modo "disk-at-once"
9 Name:           cdrdao
10 Version:        1.2.0
11 Release:        1
12 License:        GPL v2+
13 Group:          Applications/System
14 Source0:        http://dl.sourceforge.net/cdrdao/%{name}-%{version}.tar.gz
15 # Source0-md5:  dc2bdef7a7c8973e678ba4a4a2d9cc7e
16 Source1:        %{name}.desktop
17 # http://cdrdao.sourceforge.net/drives.html#dt
18 Source2:        %{name}.drivers
19 Patch0:         %{name}-nolibs.patch
20 Patch1:         %{name}-pccts-antlr.patch
21 Patch2:         %{name}-gcc4.patch
22 URL:            http://cdrdao.sourceforge.net/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  cdrtools-devel >= 3:2.01a25
26 %{?with_gnome:BuildRequires:    libgnomeuimm-devel >= 2.0.0}
27 %{?with_gnome:BuildRequires:    gtkmm-devel >= 2.2.8}
28 BuildRequires:  lame-libs-devel >= 3.92
29 BuildRequires:  libao-devel >= 0.8
30 BuildRequires:  libmad-devel >= 0.15.1b-4
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libvorbis-devel >= 1.0
33 BuildRequires:  pccts >= 1.33MR33-8
34 BuildRequires:  sed >= 4.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Cdrdao records audio and data CD-Rs in Disk At Once mode. This mode
39 gives much better control over contents of CD.
40
41 %description -l pl
42 Cdrdao zapisuje p³ytki audio i z danymi w trybie Disk At Once. W tym
43 trybie masz znacznie wiêksz± kontrolê nad zawarto¶ci± p³ytki.
44
45 %description -l pt_BR
46 Escreve CD-Rs de áudio em modo "disk-at-once" (DAO) permitindo
47 controle sobre pre-gaps (tamanho reduzido a 0, dados não zerados de
48 áudio) e informações de sub-canais como códigos ISRC. Todos os dados
49 que são escritos no disco devem ser especificados através de um
50 arquivo texto. Dados de áudio também podem estar no formato WAVE ou
51 raw.
52
53 %package gcdmaster
54 Summary:        GNOME frontend to cdrdao for composing audio CDs
55 Summary(pl):    Frontend GNOME do cdrdao do sk³adania p³yt CD-Audio
56 Group:          X11/Applications
57 Requires:       %{name} = %{version}-%{release}
58
59 %description gcdmaster
60 gcdmaster allows the creation of toc-files for cdrdao and can control
61 the recording process. Its main application is the composition of
62 audio CDs from one or more audio files. It supports PQ-channel
63 editing, entry of meta data like ISRC codes/CD-TEXT and non
64 destructive cut of the audio data.
65
66 %description gcdmaster -l pl
67 gcdmaster pozwala na tworzenie plików toc dla cdrdao oraz mo¿e
68 kontrolowaæ proces nagrywania. G³ównym celem jest sk³adanie p³yt
69 CD-Audio z jednego lub wiêcej plików z d¼wiêkiem. Obs³uguje edycjê
70 kana³u PQ, wpisy meta-danych takich jak kody ISRC/CD-TEXT oraz
71 niedestruktywne ciêcie danych audio.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76 %patch1 -p1
77 %patch2 -p1
78
79 sed -i -e 's#/usr/src/linux/include##g' scsilib/DEFAULT*/Defaults.linux
80 %if %{without gnome}
81 sed -i -e 's/^en_xdao=yes$/en_xdao=no/' configure.ac
82 %endif
83
84 %build
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 PKG_CONFIG=%{_bindir}/pkg-config \
90 %configure \
91         --with-pcctsbin=%{_bindir} \
92         --with-pcctsinc=/usr/lib/pccts/h \
93         --with-scglib-inc=/usr/include/schily \
94         %if %{with gnome}
95         --with-xdao \ 
96         %else
97         --without-xdao \
98         %endif
99         %if %{without mp3}
100         --without-ogg-support \
101         --without-mp3-support \
102         %endif 
103         --with-scglib-lib=/usr/lib 
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/%{name}}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/gcdmaster.desktop
115 install xdao/stock/gcdmaster.png $RPM_BUILD_ROOT%{_pixmapsdir}
116 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/drivers
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc CREDITS README README.PlexDAE 
124 %attr(755,root,root) %{_bindir}/cdrdao
125 %attr(755,root,root) %{_bindir}/toc2*
126 %attr(755,root,root) %{_bindir}/cue2toc
127 %{_datadir}/%{name}
128 %{_mandir}/man1/cdrdao.1*
129 %{_mandir}/man1/cue2toc.1*
130
131 %if %{with gnome}
132 %files gcdmaster
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/gcdmaster
135 %{_desktopdir}/gcdmaster.desktop
136 %{_pixmapsdir}/*
137 %{_mandir}/man1/gcdmaster.*
138 %endif
This page took 0.066228 seconds and 3 git commands to generate.