]> git.pld-linux.org Git - packages/cdrdao.git/blob - cdrdao.spec
- release 2
[packages/cdrdao.git] / cdrdao.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # don't build gcdmaster
4 %bcond_without  mp3     # without MP3 support
5 %bcond_without  ogg     # without Ogg support
6 #
7 Summary:        Tools for burning CDRs in Disk At Once mode
8 Summary(pl.UTF-8):      Narzędzia do wypalania płyt w trybie Disk At Once
9 Summary(pt_BR.UTF-8):   Cdrdao - Escreve CD-Rs de áudio em modo "disk-at-once"
10 Name:           cdrdao
11 Version:        1.2.2
12 Release:        2
13 License:        GPL v2+
14 Group:          Applications/System
15 Source0:        http://dl.sourceforge.net/cdrdao/%{name}-%{version}.tar.bz2
16 # Source0-md5:  f0cbf36907406cb4f4c568f9e6669a34
17 Source1:        %{name}.desktop
18 # http://cdrdao.sourceforge.net/drives.html#dt
19 Source2:        %{name}.drivers
20 Patch0:         %{name}-nolibs.patch
21 Patch1:         %{name}-pccts-antlr.patch
22 Patch2:         %{name}-gcc4.patch
23 Patch3:         %{name}-sigc.patch
24 URL:            http://cdrdao.sourceforge.net/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  cdrtools-devel >= 3:2.01a25
28 %{?with_gnome:BuildRequires:    gtkmm-devel >= 2.4.0}
29 %{?with_mp3:BuildRequires:      lame-libs-devel >= 3.92}
30 %if %{with mp3} || %{with ogg}
31 BuildRequires:  libao-devel >= 0.8
32 %endif
33 %{?with_mp3:BuildRequires:      libmad-devel >= 0.15.1b-4}
34 %{?with_gnome:BuildRequires:    libgnomeuimm-devel >= 2.6.0}
35 BuildRequires:  libmad-devel >= 0.15.1b-4
36 %{?with_gnome:BuildRequires:    libsigc++-devel >= 2.0.0}
37 BuildRequires:  libstdc++-devel
38 %{?with_ogg:BuildRequires:      libvorbis-devel >= 1:1.0}
39 BuildRequires:  pccts >= 1.33MR33-8
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpmbuild(macros) >= 1.311
42 BuildRequires:  sed >= 4.0
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Cdrdao records audio and data CD-Rs in Disk At Once mode. This mode
47 gives much better control over contents of CD.
48
49 %description -l pl.UTF-8
50 Cdrdao zapisuje płytki audio i z danymi w trybie Disk At Once. W tym
51 trybie masz znacznie większą kontrolę nad zawartością płytki.
52
53 %description -l pt_BR.UTF-8
54 Escreve CD-Rs de áudio em modo "disk-at-once" (DAO) permitindo
55 controle sobre pre-gaps (tamanho reduzido a 0, dados não zerados de
56 áudio) e informações de sub-canais como códigos ISRC. Todos os dados
57 que são escritos no disco devem ser especificados através de um
58 arquivo texto. Dados de áudio também podem estar no formato WAVE ou
59 raw.
60
61 %package gcdmaster
62 Summary:        GNOME frontend to cdrdao for composing audio CDs
63 Summary(pl.UTF-8):      Frontend GNOME do cdrdao do składania płyt CD-Audio
64 Group:          X11/Applications
65 Requires:       %{name} = %{version}-%{release}
66 Requires(post,postun):  shared-mime-info
67
68 %description gcdmaster
69 gcdmaster allows the creation of toc-files for cdrdao and can control
70 the recording process. Its main application is the composition of
71 audio CDs from one or more audio files. It supports PQ-channel
72 editing, entry of meta data like ISRC codes/CD-TEXT and non
73 destructive cut of the audio data.
74
75 %description gcdmaster -l pl.UTF-8
76 gcdmaster pozwala na tworzenie plików toc dla cdrdao oraz może
77 kontrolować proces nagrywania. Głównym celem jest składanie płyt
78 CD-Audio z jednego lub więcej plików z dźwiękiem. Obsługuje edycję
79 kanału PQ, wpisy meta-danych takich jak kody ISRC/CD-TEXT oraz
80 niedestruktywne cięcie danych audio.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p0
88
89 sed -i -e 's#/usr/src/linux/include##g' scsilib/DEFAULT*/Defaults.linux
90 %if !%{with gnome}
91 sed -i -e 's/^en_xdao=yes$/en_xdao=no/' configure.ac
92 %endif
93
94 %build
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 PKG_CONFIG=%{_bindir}/pkg-config \
100 %configure \
101         --with-pcctsbin=%{_bindir} \
102         --with-pcctsinc=%{_libdir}/pccts/h \
103         --with-scglib-inc=%{_includedir}/schily \
104         --with-scglib-lib=%{_libdir} \
105         --with%{!?with_gnome:out}-xdao \
106         --with%{!?with_mp3:out}-mp3-support \
107         --with%{!?with_ogg:out}-ogg-support
108
109 %{__make} \
110         CC="%{__cc}" \
111         COPTOPT="%{rpmcflags}"
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/%{name}}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/drivers
121
122 rm -r $RPM_BUILD_ROOT%{_datadir}/{application-registry,mime-info}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post gcdmaster
128 %update_mime_database
129
130 %postun gcdmaster
131 %update_mime_database
132
133 %files
134 %defattr(644,root,root,755)
135 %doc CREDITS README README.PlexDAE 
136 %attr(755,root,root) %{_bindir}/cdrdao
137 %attr(755,root,root) %{_bindir}/toc2*
138 %attr(755,root,root) %{_bindir}/cue2toc
139 %{_datadir}/%{name}
140 %{_mandir}/man1/cdrdao.1*
141 %{_mandir}/man1/cue2toc.1*
142
143 %if %{with gnome}
144 %files gcdmaster
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/gcdmaster
147 %{_datadir}/gcdmaster
148 %{_datadir}/mime/packages/gcdmaster.xml
149 %{_desktopdir}/gcdmaster.desktop
150 %{_pixmapsdir}/*
151 %{_mandir}/man1/gcdmaster.1*
152 %endif
This page took 0.074332 seconds and 3 git commands to generate.