]> git.pld-linux.org Git - packages/cdrdao.git/blob - cdrdao.spec
- glibc.patch added; stolen from -> http://bugs.gentoo.org/270414
[packages/cdrdao.git] / cdrdao.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # don't build gcdmaster
4 %bcond_without  mp3     # without MP3 support
5 %bcond_without  ogg     # without Ogg support
6 #
7 Summary:        Tools for burning CDRs in Disk At Once mode
8 Summary(pl.UTF-8):      Narzędzia do wypalania płyt w trybie Disk At Once
9 Summary(pt_BR.UTF-8):   Cdrdao - Escreve CD-Rs de áudio em modo "disk-at-once"
10 Name:           cdrdao
11 Version:        1.2.2
12 Release:        2
13 License:        GPL v2+
14 Group:          Applications/System
15 Source0:        http://dl.sourceforge.net/cdrdao/%{name}-%{version}.tar.bz2
16 # Source0-md5:  f0cbf36907406cb4f4c568f9e6669a34
17 Source1:        %{name}.desktop
18 # http://cdrdao.sourceforge.net/drives.html#dt
19 Source2:        %{name}.drivers
20 Patch0:         %{name}-nolibs.patch
21 Patch1:         %{name}-pccts-antlr.patch
22 Patch2:         %{name}-gcc4.patch
23 Patch3:         %{name}-sigc.patch
24 Patch4:         %{name}-glibc.patch
25 URL:            http://cdrdao.sourceforge.net/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  cdrtools-devel >= 3:2.01a25
29 %{?with_gnome:BuildRequires:    gtkmm-devel >= 2.4.0}
30 %{?with_mp3:BuildRequires:      lame-libs-devel >= 3.92}
31 %if %{with mp3} || %{with ogg}
32 BuildRequires:  libao-devel >= 0.8
33 %endif
34 %{?with_mp3:BuildRequires:      libmad-devel >= 0.15.1b-4}
35 %{?with_gnome:BuildRequires:    libgnomeuimm-devel >= 2.6.0}
36 BuildRequires:  libmad-devel >= 0.15.1b-4
37 %{?with_gnome:BuildRequires:    libsigc++-devel >= 2.0.0}
38 BuildRequires:  libstdc++-devel
39 %{?with_ogg:BuildRequires:      libvorbis-devel >= 1:1.0}
40 BuildRequires:  pccts >= 1.33MR33-8
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpmbuild(macros) >= 1.311
43 BuildRequires:  sed >= 4.0
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Cdrdao records audio and data CD-Rs in Disk At Once mode. This mode
48 gives much better control over contents of CD.
49
50 %description -l pl.UTF-8
51 Cdrdao zapisuje płytki audio i z danymi w trybie Disk At Once. W tym
52 trybie masz znacznie większą kontrolę nad zawartością płytki.
53
54 %description -l pt_BR.UTF-8
55 Escreve CD-Rs de áudio em modo "disk-at-once" (DAO) permitindo
56 controle sobre pre-gaps (tamanho reduzido a 0, dados não zerados de
57 áudio) e informações de sub-canais como códigos ISRC. Todos os dados
58 que são escritos no disco devem ser especificados através de um
59 arquivo texto. Dados de áudio também podem estar no formato WAVE ou
60 raw.
61
62 %package gcdmaster
63 Summary:        GNOME frontend to cdrdao for composing audio CDs
64 Summary(pl.UTF-8):      Frontend GNOME do cdrdao do składania płyt CD-Audio
65 Group:          X11/Applications
66 Requires:       %{name} = %{version}-%{release}
67 Requires(post,postun):  shared-mime-info
68
69 %description gcdmaster
70 gcdmaster allows the creation of toc-files for cdrdao and can control
71 the recording process. Its main application is the composition of
72 audio CDs from one or more audio files. It supports PQ-channel
73 editing, entry of meta data like ISRC codes/CD-TEXT and non
74 destructive cut of the audio data.
75
76 %description gcdmaster -l pl.UTF-8
77 gcdmaster pozwala na tworzenie plików toc dla cdrdao oraz może
78 kontrolować proces nagrywania. Głównym celem jest składanie płyt
79 CD-Audio z jednego lub więcej plików z dźwiękiem. Obsługuje edycję
80 kanału PQ, wpisy meta-danych takich jak kody ISRC/CD-TEXT oraz
81 niedestruktywne cięcie danych audio.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88 %patch3 -p0
89 %patch4 -p1
90
91 sed -i -e 's#/usr/src/linux/include##g' scsilib/DEFAULT*/Defaults.linux
92 %if !%{with gnome}
93 sed -i -e 's/^en_xdao=yes$/en_xdao=no/' configure.ac
94 %endif
95
96 %build
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 PKG_CONFIG=%{_bindir}/pkg-config \
102 %configure \
103         --with-pcctsbin=%{_bindir} \
104         --with-pcctsinc=%{_libdir}/pccts/h \
105         --with-scglib-inc=%{_includedir}/schily \
106         --with-scglib-lib=%{_libdir} \
107         --with%{!?with_gnome:out}-xdao \
108         --with%{!?with_mp3:out}-mp3-support \
109         --with%{!?with_ogg:out}-ogg-support
110
111 %{__make} \
112         CC="%{__cc}" \
113         COPTOPT="%{rpmcflags}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/%{name}}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/drivers
123
124 %if %{with gnome}
125 rm -r $RPM_BUILD_ROOT%{_datadir}/{application-registry,mime-info}
126 %endif
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post gcdmaster
132 %update_mime_database
133
134 %postun gcdmaster
135 %update_mime_database
136
137 %files
138 %defattr(644,root,root,755)
139 %doc CREDITS README README.PlexDAE 
140 %attr(755,root,root) %{_bindir}/cdrdao
141 %attr(755,root,root) %{_bindir}/toc2*
142 %attr(755,root,root) %{_bindir}/cue2toc
143 %{_datadir}/%{name}
144 %{_mandir}/man1/cdrdao.1*
145 %{_mandir}/man1/cue2toc.1*
146
147 %if %{with gnome}
148 %files gcdmaster
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/gcdmaster
151 %{_datadir}/gcdmaster
152 %{_datadir}/mime/packages/gcdmaster.xml
153 %{_desktopdir}/gcdmaster.desktop
154 %{_pixmapsdir}/*
155 %{_mandir}/man1/gcdmaster.1*
156 %endif
This page took 0.109202 seconds and 3 git commands to generate.