]> git.pld-linux.org Git - packages/cdp.git/commitdiff
- rel 39; getline fix auto/th/cdp-0_33-29
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 1 Sep 2011 07:51:25 +0000 (07:51 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cdp-getline.patch -> 1.1
    cdp.spec -> 1.49

cdp-getline.patch [new file with mode: 0644]
cdp.spec

diff --git a/cdp-getline.patch b/cdp-getline.patch
new file mode 100644 (file)
index 0000000..a207e36
--- /dev/null
@@ -0,0 +1,54 @@
+diff -ur cdp-0.33.org/display.c cdp-0.33/display.c
+--- cdp-0.33.org/display.c     1995-11-10 07:10:42.000000000 +0100
++++ cdp-0.33/display.c 2011-09-01 09:49:41.544769864 +0200
+@@ -540,7 +540,7 @@
+     displayStatusPrintf( pInfo, pCD->trk[ track - 1 ].songname );
+   
+     line = TOC_TOP_LINE + 1 + track - 1 - pInfo->scrStartTrack;
+-    code = getline( line, STARTX_TRK_NAME, WIDTH_TRK_NAME + 2,REVERSE_COLOR,
++    code = getline_cdp( line, STARTX_TRK_NAME, WIDTH_TRK_NAME + 2,REVERSE_COLOR,
+                   NORMAL_COLOR, MARKED_COLOR | A_BOLD, 
+                   lpszNewName, SONG_SIZE, 
+                   pCD->trk[ track - 1 ].songname );
+@@ -573,7 +573,7 @@
+     resetCurrTrackMark( pInfo );
+     pCD = pInfo->pCD;
+-    code = getline( 2, 19, WIDTH_CDNAME, REVERSE_COLOR,
++    code = getline_cdp( 2, 19, WIDTH_CDNAME, REVERSE_COLOR,
+                   NORMAL_COLOR, MARKED_COLOR | A_BOLD, 
+                   lpszNewName, sizeof( pCD->cdname ), 
+                   pCD->cdname );
+@@ -604,7 +604,7 @@
+     resetCurrTrackMark( pInfo );
+     pCD = pInfo->pCD;
+-    code = getline( 1, 19, WIDTH_ARTIST,REVERSE_COLOR,
++    code = getline_cdp( 1, 19, WIDTH_ARTIST,REVERSE_COLOR,
+                   NORMAL_COLOR, MARKED_COLOR | A_BOLD, 
+                   lpszNewName, sizeof( pCD->artist ), 
+                   pCD->artist );
+diff -ur cdp-0.33.org/getline.c cdp-0.33/getline.c
+--- cdp-0.33.org/getline.c     2011-09-01 09:50:11.075466389 +0200
++++ cdp-0.33/getline.c 2011-09-01 09:49:41.544769864 +0200
+@@ -139,7 +139,7 @@
+ }
+                            
+-int     getline( int      y,
++int     getline_cdp( int      y,
+                int      x, 
+                int      width,
+                chtype   attrText,
+diff -ur cdp-0.33.org/getline.h cdp-0.33/getline.h
+--- cdp-0.33.org/getline.h     1995-11-10 07:10:42.000000000 +0100
++++ cdp-0.33/getline.h 2011-09-01 09:49:41.548103522 +0200
+@@ -7,7 +7,7 @@
+ #define  __getline__H
+-int     getline( int      y, 
++int     getline_cdp( int      y, 
+                int      x,
+                int      width,
+                chtype   attrText,
index 2b735ec602e1a7751d23107398daa053d061a1e2..0f2c0f60a5b3766e252b6e7c6ac6dcb979cf51f9 100644 (file)
--- a/cdp.spec
+++ b/cdp.spec
@@ -5,7 +5,7 @@ Summary(pl.UTF-8):      Pełnoekranowy, tekstowy program do odtwarzania płyt CD
 Summary(tr.UTF-8):     Müzik CD'lerini çalmak için bir metin ekran programı
 Name:          cdp
 Version:       0.33
-Release:       28
+Release:       29
 License:       GPL
 Group:         Applications/Sound
 Source0:       ftp://sunsite.unc.edu/pub/Linux/apps/sound/cdrom/curses/%{name}-%{version}.tgz
@@ -20,6 +20,7 @@ Patch6:               %{name}-changer.patch
 Patch7:                %{name}-keys.patch
 Patch8:                %{name}-nonblock.patch
 Patch9:                %{name}-bo_fix.patch
+Patch10:       %{name}-getline.patch
 BuildRequires: ncurses-devel >= 5.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -58,6 +59,7 @@ kullanabilirsiniz.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 %build
 %{__make} COMP_OPT="%{rpmcflags} -Wall"
This page took 0.520975 seconds and 4 git commands to generate.