]> git.pld-linux.org Git - packages/cdl3.git/blob - cdl3.spec
- up to 1.2.7
[packages/cdl3.git] / cdl3.spec
1 Summary:        CDL3 System - compiler
2 Summary(pl.UTF-8):      Kompilator systemu CDL3
3 Name:           cdl3
4 Version:        1.2.7
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        ftp://ftp.cs.kun.nl/pub/cdl3/%{name}-%{version}.tar.gz
9 # Source0-md5:  d028bf290af22ec8c90ea11ca9a88fda
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libtool
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 CDL3 is an implementation language based on affix grammars. It rides
17 the borderline between syntactic formalism and programming language,
18 and tries to combine the good properties of both. The control
19 structure and data structures have been choosen such that it is
20 extremely easy to write deterministic parsers and transducers in CDL3.
21 In this sense, CDL3 is a Compiler Description Language (hence the
22 acronym). Its applicability is, however, not limited to compiler
23 construction. The language is wellsuited, more in general, for all
24 applications that can be characterized as syntax-directed:
25 communication between processes (human and machine) adhering to
26 well-established protocols, or interpreter-like systems, interactively
27 obeying a set of commands.
28
29 %description -l pl.UTF-8
30 CDL3 to język implementacyjny oparty na gramatykach affiksowych.
31 Przekracza granicę pomiędzy formalizmem składniowym a językiem
32 programowania i próbuje połączyć dobre cechy obu rzeczy. Struktura
33 sterująca i struktury danych zostały tak dobrane, aby było bardzo
34 łatwo pisać w CDL3 deterministyczne analizatory i translatory. W tym
35 sensie CDL3 jest językiem opisu kompilatorów (Compiler Description
36 Language - stąd akronim). Jego zastosowanie nie jest jednak
37 ograniczone do konstruowania kompilatorów. Język jest dobrze
38 dopasowany, bardziej ogólnie, do wszystkich zastosowań, które można
39 scharakteryzować jako zorientowane na składnię: komunikacji między
40 procesami (człowiekiem i maszyną) zgodnie z dobrze ustalonymi
41 protokołami lub systemy w stylu interpreterów, interaktywnie reagujące
42 na zestaw poleceń.
43
44 %package examples
45 Summary:        CDL3 - example of use
46 Summary(pl.UTF-8):      CDL3 - przykłady wykorzystania
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description examples
51 CDL3 - example of use.
52
53 %description examples -l pl.UTF-8
54 CDL3 - przykłady wykorzystania.
55
56 %prep
57 %setup -q
58 %{__sed} -i -e 's,CLK_TCK,CLOCKS_PER_SEC,g' rts/cdl3rts.c
59
60 %build
61 cp -f /usr/share/automake/config.sub .
62 %{__libtoolize}
63 %{__aclocal}
64 %{__autoconf}
65 %{__automake}
66 %configure
67
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-%{version}}
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 mv -f $RPM_BUILD_ROOT%{_datadir}/cdl3/include/*.h $RPM_BUILD_ROOT%{_includedir}
78 mv -f $RPM_BUILD_ROOT%{_datadir}/cdl3/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p      /sbin/postshell
84 -/usr/sbin/fix-info-dir -c %{_infodir}
85
86 %postun -p      /sbin/postshell
87 -/usr/sbin/fix-info-dir -c %{_infodir}
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog NEWS README TODO docs/*.ps docs/*.k3
92 %attr(755,root,root) %{_bindir}/cdlc
93 %{_includedir}/*
94 %{_libdir}/lib*.a
95 %{_libdir}/lib*.la
96 %{_mandir}/man[137n]/*
97
98 %files examples
99 %defattr(644,root,root,755)
100 %{_examplesdir}/%{name}-%{version}
This page took 0.080965 seconds and 3 git commands to generate.