]> git.pld-linux.org Git - packages/cdk.git/blob - cdk.spec
- added includes patch (release 2)
[packages/cdk.git] / cdk.spec
1 %define         ver_ver     4.9.10
2 %define         ver_release 20010106
3
4 Summary:        Curses Development Kit
5 Name:           cdk
6 Version:        %{ver_ver}_td%{ver_release}
7 Release:        2
8 License:        BSD
9 Group:          Libraries
10 Group(de):      Libraries
11 Group(es):      Bibliotecas
12 Group(fr):      Librairies
13 Group(pl):      Biblioteki
14 URL:            http://dickey.his.com/cdk/cdk.html
15 Source0:        ftp://dickey.his.com/cdk/%{name}-%{ver_ver}-%{ver_release}.tgz
16 Patch0:         %{name}-includes.patch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 CDK is a widget set developed on top of the basic curses library. It
21 contains 21 ready to use widgets. Some which are a text entry field, a
22 scrolling list, a selection list, a alphalist, pull-down menu, radio
23 list, viewer widget, dialog box, and many more.
24
25 This version of CDK is maintained by Thomas Dickey and is not the same
26 as that at http://www.vexus.ca/CDK.html.
27
28 %package devel
29 Summary:        Header files and development documentation for CDK library
30 Summary(pl):    Pliki nag³ówkowe i dokumentacja do CDK
31 Group:          Development/Libraries
32 Group(de):      Entwicklung/Libraries
33 Group(fr):      Development/Librairies
34 Group(pl):      Programowanie/Biblioteki
35 Requires:       %{name} = %{version}
36
37 %description devel
38 Header files and development documentation for CDK library. This
39 version is maintained by Thomas Dickey and is not the same as that at
40 http://www.vexus.ca/CDK.html.
41
42 %package static
43 Summary:        Static version of CDK library
44 Summary(pl):    Statyczna wersja biblioteki CDK
45 Group:          Development/Libraries
46 Group(de):      Entwicklung/Libraries
47 Group(fr):      Development/Librairies
48 Group(pl):      Programowanie/Biblioteki
49 Requires:       %{name}-devel = %{version}
50
51 %description static
52 Static version of CDK library. This version is maintained by Thomas
53 Dickey and is not the same as that at http://www.vexus.ca/CDK.html.
54
55 %prep
56 %setup -q -n %{name}-%{ver_ver}-%{ver_release}
57 %patch0 -p1
58 mkdir include/cdk
59 mv include/*.* include/cdk
60
61 %build
62 # -funsigned-char gives valid 8bit display
63 CFLAGS="%{rpmcflags} -funsigned-char"
64 %configure \
65         --disable-x \
66         --with-ncurses
67 %{__make}
68 %{__make} cdkshlib
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} installCDKSHLibrary installCDKLibrary \
74         DESTDIR="$RPM_BUILD_ROOT"
75
76 %{__make} installCDKHeaderFiles installCDKManPages \
77         DESTDIR="$RPM_BUILD_ROOT"
78
79 gzip -9nf BUGS CHANGES EXPANDING NOTES README TODO
80
81 for d in demos examples; do 
82    rm -f $d/Makefile.in
83    mkf=$d/Makefile
84    sed 's|\-I%{_prefix}/X11R6/include|\-I%{_includedir}/cdk/|' <$mkf >$mkf.fix
85    mv -f $mkf.fix $mkf
86 done
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/lib*.so.*.*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %doc *gz examples demos
101 %attr(755,root,root) %{_libdir}/lib*.so
102 %{_includedir}/*
103 %{_mandir}/man3/*
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/lib*.a
This page took 0.064562 seconds and 3 git commands to generate.