]> git.pld-linux.org Git - packages/cdecl.git/commitdiff
- glibc patch: resolve getopt declaration conflict cdecl-2_5-21
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 21 Nov 2001 21:43:48 +0000 (21:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- use bison instead of byacc
- BuildRequires: flex
- release 21

Changed files:
    cdecl-glibc.patch -> 1.1
    cdecl.spec -> 1.33

cdecl-glibc.patch [new file with mode: 0644]
cdecl.spec

diff --git a/cdecl-glibc.patch b/cdecl-glibc.patch
new file mode 100644 (file)
index 0000000..480198c
--- /dev/null
@@ -0,0 +1,22 @@
+--- cdecl-2.5/cdecl.c.orig     Wed Nov 21 21:29:59 2001
++++ cdecl-2.5/cdecl.c  Wed Nov 21 21:32:54 2001
+@@ -125,7 +125,9 @@
+ #if __STDC__
+   char *ds(char *), *cat(char *, ...), *visible(int);
++#ifdef NOGETOPT
+   int getopt(int,char **,char *);
++#endif
+   int main(int, char **);
+   int yywrap(void);
+   int dostdin(void);
+@@ -143,7 +145,9 @@
+   int dotmpfile(int, char**), dofileargs(int, char**);
+ #else
+   char *ds(), *cat(), *visible();
++#ifdef NOGETOPT
+   int getopt();
++#endif
+   void mbcheck(), dohelp(), usage();
+   void prompt(), doprompt(), noprompt();
+   void unsupp(), notsupported();
index dd85fdfea9d806f080f2537cfb2aa029a332613d..44418bb8f7da2e669381d572f4292dcb2cfed440 100644 (file)
@@ -5,7 +5,7 @@ Summary(pl):    Programy do kodowania i dekodowania deklaracji funkcji w C i C++
 Summary(tr):   Ýngilizceden C/C++ bildirimlerine çevirici
 Name:          cdecl
 Version:       2.5
-Release:       20
+Release:       21
 License:       distributable
 Group:         Development/Tools
 Group(de):     Entwicklung/Werkzeuge
@@ -13,7 +13,9 @@ Group(fr):    Development/Outils
 Group(pl):     Programowanie/Narzêdzia
 Source0:       ftp://sunsite.unc.edu/pub/Linux/devel/lang/c/%{name}-%{version}.tar.gz
 Patch0:                %{name}-misc.patch
-BuildRequires: byacc
+Patch1:                %{name}-glibc.patch
+BuildRequires: flex
+BuildRequires: bison
 BuildRequires: readline-devel >= 4.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -41,9 +43,11 @@ kullan
 
 %prep
 %setup -q
-%patch -p1
+%patch0 -p1
+%patch1 -p1
 
 %build
+bison -y cdgram.y && mv -f y.tab.c cdgram.c
 %{__make} CFLAGS="%{rpmcflags} %{rpmldflags} -DUSE_READLINE" \
        LIBS="-lreadline -ltinfo"
 
This page took 0.073714 seconds and 4 git commands to generate.