]> git.pld-linux.org Git - packages/ccs.git/blob - ccs.spec
- dropped magma
[packages/ccs.git] / ccs.spec
1 Summary:        Cluster configuration system to manage the cluster config file
2 Summary(pl.UTF-8):      System konfiguracji klastra do zarządzania jego plikiem konfiguracyjnym
3 Name:           ccs
4 Version:        2.00.00
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
9 # Source0-md5:  2ef3f4ba9d3c87b50adfc9b406171085
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-optflags.patch
13 URL:            http://sources.redhat.com/cluster/ccs/
14 BuildRequires:  cman-devel >= 2
15 BuildRequires:  libxml2-devel >= 2.0
16 BuildRequires:  rpmbuild(macros) >= 1.268
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       rc-scripts
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sbindir        /sbin
22
23 %description
24 Cluster configuration system to manage the cluster config file.
25
26 %description -l pl.UTF-8
27 System konfiguracji klastra do zarządzania jego plikiem
28 konfiguracyjnym.
29
30 %package devel
31 Summary:        Header files and static library for ccs
32 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteka statyczna ccs
33 Group:          Development/Libraries
34 # doesn't require base
35
36 %description devel
37 Header files and static library for ccs.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe i biblioteka statyczna ccs.
41
42 %prep
43 %setup -q -n cluster-%{version}
44 %patch0 -p1
45
46 %build
47 cd %{name}
48 ./configure \
49         --incdir=%{_includedir} \
50         --libdir=%{_libdir} \
51         --mandir=%{_mandir} \
52         --prefix=%{_prefix} \
53         --sbindir=%{_sbindir}
54 %{__make} \
55         CC="%{__cc}" \
56         LDFLAGS="%{rpmldflags}" \
57         OPTCFLAGS="%{rpmcflags}"
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 cd %{name}
62 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 install -d $RPM_BUILD_ROOT%{_sysconfdir}/cluster
68 touch $RPM_BUILD_ROOT%{_sysconfdir}/cluster/cluster.xml
69
70 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
71 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 /sbin/chkconfig --add %{name}
78 %service %{name} restart
79
80 %preun
81 if [ "$1" = "0" ]; then
82         %service %{name} stop
83         /sbin/chkconfig --del %{name}
84 fi
85
86 %files
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_sbindir}/*
89 %dir %{_sysconfdir}/cluster
90 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cluster/cluster.xml
91 %{_mandir}/man5/cluster.conf.5*
92 %{_mandir}/man7/ccs.7*
93 %{_mandir}/man8/ccs*.8*
94 %attr(754,root,root) /etc/rc.d/init.d/%{name}
95 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
96
97 %files devel
98 %defattr(644,root,root,755)
99 %{_includedir}/ccs.h
100 %{_libdir}/libccs.a
This page took 0.072714 seconds and 4 git commands to generate.