]> git.pld-linux.org Git - packages/ccs.git/blob - ccs.spec
- added compile.patch
[packages/ccs.git] / ccs.spec
1 Summary:        Cluster configuration system to manage the cluster config file
2 Summary(pl.UTF-8):      System konfiguracji klastra do zarządzania jego plikiem konfiguracyjnym
3 Name:           ccs
4 Version:        2.00.00
5 Release:        2
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
9 # Source0-md5:  2ef3f4ba9d3c87b50adfc9b406171085
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-optflags.patch
13 Patch1:         %{name}-include.patch
14 Patch2:         compile.patch
15 URL:            http://sources.redhat.com/cluster/ccs/
16 BuildRequires:  cman-devel >= 2
17 BuildRequires:  libxml2-devel >= 2.0
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(post,preun):   /sbin/chkconfig
20 Requires:       rc-scripts
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sbindir        /sbin
24
25 %description
26 Cluster configuration system to manage the cluster config file.
27
28 %description -l pl.UTF-8
29 System konfiguracji klastra do zarządzania jego plikiem
30 konfiguracyjnym.
31
32 %package devel
33 Summary:        Header files and static library for ccs
34 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteka statyczna ccs
35 Group:          Development/Libraries
36 # doesn't require base
37
38 %description devel
39 Header files and static library for ccs.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe i biblioteka statyczna ccs.
43
44 %prep
45 %setup -q -n cluster-%{version}
46 %patch0 -p1
47 %patch1 -p1
48 %patch2 -p1
49
50 %build
51 cd %{name}
52 ./configure \
53         --incdir=%{_includedir} \
54         --libdir=%{_libdir} \
55         --mandir=%{_mandir} \
56         --prefix=%{_prefix} \
57         --sbindir=%{_sbindir}
58 %{__make} \
59         CC="%{__cc}" \
60         LDFLAGS="%{rpmldflags}" \
61         OPTCFLAGS="%{rpmcflags}"
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 cd %{name}
66 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 install -d $RPM_BUILD_ROOT%{_sysconfdir}/cluster
72 touch $RPM_BUILD_ROOT%{_sysconfdir}/cluster/cluster.xml
73
74 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
75 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 /sbin/chkconfig --add %{name}
82 %service %{name} restart
83
84 %preun
85 if [ "$1" = "0" ]; then
86         %service %{name} stop
87         /sbin/chkconfig --del %{name}
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_sbindir}/*
93 %dir %{_sysconfdir}/cluster
94 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cluster/cluster.xml
95 %{_mandir}/man5/cluster.conf.5*
96 %{_mandir}/man7/ccs.7*
97 %{_mandir}/man8/ccs*.8*
98 %attr(754,root,root) /etc/rc.d/init.d/%{name}
99 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_includedir}/ccs.h
104 %{_libdir}/libccs.a
This page took 0.067257 seconds and 4 git commands to generate.