]> git.pld-linux.org Git - packages/ccs.git/blob - ccs.spec
- don't try to compile header file (trying to fix compilation on Ac)
[packages/ccs.git] / ccs.spec
1 Summary:        Cluster configuration system to manage the cluster config file
2 Summary(pl.UTF-8):      System konfiguracji klastra do zarządzania jego plikiem konfiguracyjnym
3 Name:           ccs
4 Version:        2.00.00
5 Release:        2
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
9 # Source0-md5:  2ef3f4ba9d3c87b50adfc9b406171085
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-optflags.patch
13 Patch1:         %{name}-include.patch
14 URL:            http://sources.redhat.com/cluster/ccs/
15 BuildRequires:  cman-devel >= 2
16 BuildRequires:  libxml2-devel >= 2.0
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires(post,preun):   /sbin/chkconfig
19 Requires:       rc-scripts
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sbindir        /sbin
23
24 %description
25 Cluster configuration system to manage the cluster config file.
26
27 %description -l pl.UTF-8
28 System konfiguracji klastra do zarządzania jego plikiem
29 konfiguracyjnym.
30
31 %package devel
32 Summary:        Header files and static library for ccs
33 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteka statyczna ccs
34 Group:          Development/Libraries
35 # doesn't require base
36
37 %description devel
38 Header files and static library for ccs.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe i biblioteka statyczna ccs.
42
43 %prep
44 %setup -q -n cluster-%{version}
45 %patch0 -p1
46 %patch1 -p1
47
48 %build
49 cd %{name}
50 ./configure \
51         --incdir=%{_includedir} \
52         --libdir=%{_libdir} \
53         --mandir=%{_mandir} \
54         --prefix=%{_prefix} \
55         --sbindir=%{_sbindir}
56 %{__make} \
57         CC="%{__cc}" \
58         LDFLAGS="%{rpmldflags}" \
59         OPTCFLAGS="%{rpmcflags}"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 cd %{name}
64 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT%{_sysconfdir}/cluster
70 touch $RPM_BUILD_ROOT%{_sysconfdir}/cluster/cluster.xml
71
72 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
73 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 /sbin/chkconfig --add %{name}
80 %service %{name} restart
81
82 %preun
83 if [ "$1" = "0" ]; then
84         %service %{name} stop
85         /sbin/chkconfig --del %{name}
86 fi
87
88 %files
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_sbindir}/*
91 %dir %{_sysconfdir}/cluster
92 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cluster/cluster.xml
93 %{_mandir}/man5/cluster.conf.5*
94 %{_mandir}/man7/ccs.7*
95 %{_mandir}/man8/ccs*.8*
96 %attr(754,root,root) /etc/rc.d/init.d/%{name}
97 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
98
99 %files devel
100 %defattr(644,root,root,755)
101 %{_includedir}/ccs.h
102 %{_libdir}/libccs.a
This page took 0.043301 seconds and 4 git commands to generate.