]> git.pld-linux.org Git - packages/ccs.git/blob - ccs.spec
- added optflags patch, sed killed
[packages/ccs.git] / ccs.spec
1 Summary:        Cluster configuration system to manage the cluster config file
2 Summary(pl):    System konfiguracji klastra do zarz±dzania jego plikiem konfiguracyjnym
3 Name:           ccs
4 Version:        1.02.00
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
9 # Source0-md5:  131c34c8b66d8d7d74384839ed4091d0
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-optflags.patch
13 URL:            http://sources.redhat.com/cluster/ccs/
14 BuildRequires:  libxml2-devel >= 2.0
15 BuildRequires:  magma-devel >= 0:1.01
16 BuildRequires:  rpmbuild(macros) >= 1.268
17 Requires(post,preun):   /sbin/chkconfig
18 Requires:       magma >= 0:1.01
19 Requires:       rc-scripts
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sbindir        /sbin
23
24 %description
25 Cluster configuration system to manage the cluster config file.
26
27 %description -l pl
28 System konfiguracji klastra do zarz±dzania jego plikiem
29 konfiguracyjnym.
30
31 %package devel
32 Summary:        Header files and static library for ccs
33 Summary(pl):    Pliki nag³ówkowe i biblioteka statyczna ccs
34 Group:          Development/Libraries
35 # doesn't require base
36
37 %description devel
38 Header files and static library for ccs.
39
40 %description devel -l pl
41 Pliki nag³ówkowe i biblioteka statyczna ccs.
42
43 %prep
44 %setup -q -n cluster-%{version}
45 %patch0 -p1
46
47 %build
48 cd %{name}
49 ./configure \
50         --incdir=%{_includedir} \
51         --libdir=%{_libdir} \
52         --mandir=%{_mandir} \
53         --prefix=%{_prefix} \
54         --sbindir=%{_sbindir}
55 %{__make} \
56         CC="%{__cc}" \
57         LDFLAGS="%{rpmldflags}" \
58         OPTCFLAGS="%{rpmcflags}"
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 cd %{name}
63 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 install -d $RPM_BUILD_ROOT%{_sysconfdir}/cluster
69 touch $RPM_BUILD_ROOT%{_sysconfdir}/cluster/cluster.xml
70
71 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
72 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 /sbin/chkconfig --add %{name}
79 %service %{name} restart
80
81 %preun
82 if [ "$1" = "0" ]; then
83         %service %{name} stop
84         /sbin/chkconfig --del %{name}
85 fi
86
87 %files
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_sbindir}/*
90 %dir %{_sysconfdir}/cluster
91 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cluster/cluster.xml
92 %{_mandir}/man5/cluster.conf.5*
93 %{_mandir}/man7/ccs.7*
94 %{_mandir}/man8/ccs*.8*
95 %attr(754,root,root) /etc/rc.d/init.d/%{name}
96 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
97
98 %files devel
99 %defattr(644,root,root,755)
100 %{_includedir}/ccs.h
101 %{_libdir}/libccs.a
This page took 0.046277 seconds and 4 git commands to generate.